Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1444618 - Review Request: buildah - A command line tool to facilitate working with containers and using them to build images.
Summary: Review Request: buildah - A command line tool to facilitate working with con...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-23 10:44 UTC by Daniel Walsh
Modified: 2023-09-14 03:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-22 13:35:27 UTC
Type: ---
Embargoed:
lsm5: fedora-review+


Attachments (Terms of Use)

Description Daniel Walsh 2017-04-23 10:44:20 UTC
Spec URL: http://people.redhat.com/dwalsh/buildah/buildah.spec
SRPM URL: http://people.redhat.com/dwalsh/buildah/buildah-0.0.1-1.git1f12f1c.fc26.src.rpm
Description:       
The buildah package provides a command line tool which can be used to:

    * Create a working container, either from scratch or using an image as a starting point.
    * Mount a working container's root filesystem for manipulation.
    * Unmount a working container's root filesystem.
    * Use the updated contents of a container's root filesystem as a filesystem layer to create a new image.
    * Delete a working container or an image.

Fedora Account System Username: dwalsh

Comment 1 Lokesh Mandvekar 2017-04-24 19:26:41 UTC
mock build failed on my rawhide machine coz btrfs/ioctl.h not found.

Could you please add BuildRequires: btfs-progs-devel to the spec and post it here?

Comment 2 Daniel Walsh 2017-04-25 12:20:20 UTC
Fixed.  Updated the SRPM

Spec URL: http://people.redhat.com/dwalsh/buildah/buildah.spec
SRPM URL: http://people.redhat.com/dwalsh/buildah/buildah-0.0.1-1.gita0a5333.fc26.src.rpm
Description:

Comment 3 Lokesh Mandvekar 2017-04-25 13:33:02 UTC
Sorry, missed another dep, please add BuildRequires: libassuan-devel as well. koji builds are successful after that.

Comment 4 Daniel Walsh 2017-04-27 14:07:41 UTC
Fixed and Updated.

Comment 5 Lokesh Mandvekar 2017-04-27 14:27:35 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[ ]: Package does not contain kernel modules.
[ ]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "Unknown or generated", "MIT/X11 (BSD like)",
     "MIT/X11 (BSD like) BSD (3 clause)", "*No copyright* MPL (v2.0)", "BSD
     (3 clause)", "BSD (2 clause)", "*No copyright* Apache (v2.0)". 1261
     files have unknown license. Detailed output of licensecheck in
     /home/lsm5/repositories/pkgs/reviews/1444618-buildah/licensecheck.txt
[ ]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/bash-completion,
     /usr/share/bash-completion/completions
[ ]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib/.build-id(nss-pem,
     libuser, vim-common, oci-systemd-hook, python3-hawkey, dhcp-libs,
     openssh-clients, iproute, nss-tools, gc, libgpg-error,
     policycoreutils-python-utils, gdbm, gpgme, python3-cryptography, rpm-
     plugin-selinux, libsolv, gdb-headless, krb5-workstation, perl-libs,
     gmp, policycoreutils, python3-gpg, iproute-tc, kpartx, libselinux-
     python3, gnutls, pcre2, python3, cyrus-sasl-lib, hardlink, nspr, rpm-
     build, dbus, fuse-libs, polkit-libs, krb5-libs, runc, rpm-build-libs,
     libnghttp2, device-mapper-persistent-data, pkgconf, shared-mime-info,
     rpm-plugin-systemd-inhibit, pcre-cpp, rhash, audit-libs, nss-sysinit,
     libgcc, libxslt, cryptsetup-libs, perl-threads-shared, gettext-libs,
     libpkgconf, golang-github-cpuguy83-go-md2man, keyutils-libs, perl-
     Encode, python2-cryptography, sqlite-libs, btrfs-progs, system-python,
     bind99-libs, dbus-libs, nss-softokn, audit-libs-python3, GeoIP, git,
     bash, vim-enhanced, polkit, openssh, libselinux-utils, libkadm5, perl-
     Unicode-UTF8, python2-rpm, docker-v1.10-migrator, system-python-libs,
     glib2, binutils, rkt, docker-rhel-push-plugin, libstdc++, file-libs,
     gnupg2-smime, gettext-devel, nss, rpm, pcre, vim-minimal, syslinux,
     gnupg2, perl-IO, gpgme-devel, dracut, git-core, python3-cffi,
     libcroco, python3-psutil, openssh-server, ocid, libdnf, perl-version,
     drpm, info, glib2-devel, pcre-utf16, nss-util, libsemanage,
     libselinux, libtomcrypt, docker-unit-test, sqlite, sudo, golang, dhcp-
     client, file, curl, libarchive, gcc, chkconfig, cmake, libcurl,
     libsemanage-python3, gettext, coreutils, pam, nss-softokn-freebl,
     libgomp, python2-cffi, libidn2, openldap, perl-Net-SSLeay, libtool-
     ltdl, audit, rpm-libs, pcre-utf32, chrony, python3-rpm, docker),
     /usr/lib/.build-id/73(coreutils, gettext)
[x]: %build honors applicable compiler flags or justifies otherwise.
[ ]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[ ]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[ ]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[!]: Uses parallel make %{?_smp_mflags} macro.
[ ]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[ ]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: buildah-0.0.1-1.gita0a5333.fc27.x86_64.rpm
          buildah-0.0.1-1.gita0a5333.fc27.src.rpm
buildah.x86_64: W: spelling-error %description -l en_US umount -> mount, amount, u mount
buildah.x86_64: W: incoherent-version-in-changelog 0.0.1-1.git7a0a5333 ['0.0.1-1.gita0a5333.fc27', '0.0.1-1.gita0a5333']
buildah.x86_64: W: unstripped-binary-or-object /usr/bin/buildah
buildah.x86_64: W: only-non-binary-in-usr-lib
buildah.x86_64: W: hidden-file-or-dir /usr/lib/.build-id
buildah.x86_64: W: hidden-file-or-dir /usr/lib/.build-id
buildah.x86_64: E: non-executable-script /usr/share/bash-completion/completions/buildah 644 /bin/bash 
buildah.src: W: spelling-error %description -l en_US umount -> mount, amount, u mount
2 packages and 0 specfiles checked; 1 errors, 7 warnings.




Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
buildah.x86_64: W: spelling-error %description -l en_US umount -> mount, amount, u mount
buildah.x86_64: W: incoherent-version-in-changelog 0.0.1-1.git7a0a5333 ['0.0.1-1.gita0a5333.fc27', '0.0.1-1.gita0a5333']
buildah.x86_64: W: unstripped-binary-or-object /usr/bin/buildah
buildah.x86_64: W: only-non-binary-in-usr-lib
buildah.x86_64: W: hidden-file-or-dir /usr/lib/.build-id
buildah.x86_64: W: hidden-file-or-dir /usr/lib/.build-id
buildah.x86_64: E: non-executable-script /usr/share/bash-completion/completions/buildah 644 /bin/bash 
1 packages and 0 specfiles checked; 1 errors, 6 warnings.



Requires
--------
buildah (rpmlib, GLIBC filtered):
    libassuan.so.0()(64bit)
    libc.so.6()(64bit)
    libdevmapper.so.1.02()(64bit)
    libdevmapper.so.1.02(Base)(64bit)
    libdevmapper.so.1.02(DM_1_02_97)(64bit)
    libgpg-error.so.0()(64bit)
    libgpgme.so.11()(64bit)
    libgpgme.so.11(GPGME_1.0)(64bit)
    libgpgme.so.11(GPGME_1.1)(64bit)
    libpthread.so.0()(64bit)
    rtld(GNU_HASH)
    runc
    skopeo-containers



Provides
--------
buildah:
    buildah
    buildah(x86-64)



Source checksums
----------------
https://github.com/projectatomic/buildah/archive/a0a5333b94264d1fb1e072d63bcb98f9e2981b49/buildah-a0a5333.tar.gz :
  CHECKSUM(SHA256) this package     : f0aa716e861ff15336fe22e86219c797df627d3bf34a60db52de9c93630bae4c
  CHECKSUM(SHA256) upstream package : f0aa716e861ff15336fe22e86219c797df627d3bf34a60db52de9c93630bae4c

Comment 6 Lokesh Mandvekar 2017-04-27 14:55:34 UTC
C/C++:
[-]: Package does not contain kernel modules.
[-]: Package contains no static executables.



Generic:
[-]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/bash-completion,
     /usr/share/bash-completion/completions

Dan, could you add /usr/share/bash-completion to %files?


[ ]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib/.build-id(nss-pem,
     libuser, vim-common, oci-systemd-hook, python3-hawkey, dhcp-libs,
     openssh-clients, iproute, nss-tools, gc, libgpg-error,
     policycoreutils-python-utils, gdbm, gpgme, python3-cryptography, rpm-
     plugin-selinux, libsolv, gdb-headless, krb5-workstation, perl-libs,
     gmp, policycoreutils, python3-gpg, iproute-tc, kpartx, libselinux-
     python3, gnutls, pcre2, python3, cyrus-sasl-lib, hardlink, nspr, rpm-
     build, dbus, fuse-libs, polkit-libs, krb5-libs, runc, rpm-build-libs,
     libnghttp2, device-mapper-persistent-data, pkgconf, shared-mime-info,
     rpm-plugin-systemd-inhibit, pcre-cpp, rhash, audit-libs, nss-sysinit,
     libgcc, libxslt, cryptsetup-libs, perl-threads-shared, gettext-libs,
     libpkgconf, golang-github-cpuguy83-go-md2man, keyutils-libs, perl-
     Encode, python2-cryptography, sqlite-libs, btrfs-progs, system-python,
     bind99-libs, dbus-libs, nss-softokn, audit-libs-python3, GeoIP, git,
     bash, vim-enhanced, polkit, openssh, libselinux-utils, libkadm5, perl-
     Unicode-UTF8, python2-rpm, docker-v1.10-migrator, system-python-libs,
     glib2, binutils, rkt, docker-rhel-push-plugin, libstdc++, file-libs,
     gnupg2-smime, gettext-devel, nss, rpm, pcre, vim-minimal, syslinux,
     gnupg2, perl-IO, gpgme-devel, dracut, git-core, python3-cffi,
     libcroco, python3-psutil, openssh-server, ocid, libdnf, perl-version,
     drpm, info, glib2-devel, pcre-utf16, nss-util, libsemanage,
     libselinux, libtomcrypt, docker-unit-test, sqlite, sudo, golang, dhcp-
     client, file, curl, libarchive, gcc, chkconfig, cmake, libcurl,
     libsemanage-python3, gettext, coreutils, pam, nss-softokn-freebl,
     libgomp, python2-cffi, libidn2, openldap, perl-Net-SSLeay, libtool-
     ltdl, audit, rpm-libs, pcre-utf32, chrony, python3-rpm, docker),
     /usr/lib/.build-id/73(coreutils, gettext)

- Not quite sure why the /usr/lib/.build-id gets generated. rpmbuild doesn't complain but fedora-review gives me this:

$ cat files.dir 
buildah
=======
/usr/lib/.build-id
/usr/lib/.build-id/73
/usr/share/doc/buildah
/usr/share/licenses/buildah

/usr/bin/buildah
/usr/lib/.build-id/73/4dd08b2524e8a7c20ef92dce19dee0e93bccc8
/usr/share/bash-completion/completions/buildah
/usr/share/doc/buildah/README.md
/usr/share/licenses/buildah/LICENSE
/usr/share/man/man1/buildah-add.1.gz
/usr/share/man/man1/buildah-bud.1.gz
/usr/share/man/man1/buildah-commit.1.gz
/usr/share/man/man1/buildah-config.1.gz
/usr/share/man/man1/buildah-containers.1.gz
/usr/share/man/man1/buildah-copy.1.gz
/usr/share/man/man1/buildah-from.1.gz
/usr/share/man/man1/buildah-images.1.gz
/usr/share/man/man1/buildah-mount.1.gz
/usr/share/man/man1/buildah-rm.1.gz
/usr/share/man/man1/buildah-rmi.1.gz
/usr/share/man/man1/buildah-run.1.gz
/usr/share/man/man1/buildah-umount.1.gz
/usr/share/man/man1/buildah.1.gz


[x]: Package contains no bundled libraries without FPC exception.

- github.com/docker/docker is vendored so it's ok to build this with bundled libraries.


[-]: Development files must be in a -devel package


[!]: Useful -debuginfo package or justification otherwise.

with_debug on line 3 should be set to 1 and rebuilt so we can have a debuginfo package, unless we need to skip debuginfo

Comment 7 Daniel Walsh 2017-04-30 10:37:03 UTC
Nalin you have any ideas on 

/usr/lib/.build-id
/usr/lib/.build-id/73

Comment 8 Daniel Walsh 2017-04-30 10:37:39 UTC
Lokesh, I have updated the packages with the directories and added with_debug.

Comment 9 Lokesh Mandvekar 2017-05-01 18:58:23 UTC
Thanks Dan. Specfile looks good. I'll ignore the /usr/lib/.build-id because it seems to be listed for many packages above which I'm sure don't concern with that dir. And there's no other issues reported with it so far.

Approving the package.


I'll also go ahead with dist-git creation.

Thanks,

Comment 10 Gwyn Ciesla 2017-05-02 12:17:09 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/buildah

Comment 11 Fedora Update System 2017-05-02 13:35:53 UTC
buildah-0.0.1-1.gita0a5333.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-afa3a2f3f7

Comment 12 Fedora Update System 2017-05-02 13:36:05 UTC
buildah-0.0.1-1.gita0a5333.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a70f3f8faf

Comment 13 Fedora Update System 2017-05-04 15:23:17 UTC
buildah-0.0.1-1.gita0a5333.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a70f3f8faf

Comment 14 Fedora Update System 2017-05-04 15:23:42 UTC
buildah-0.0.1-1.gita0a5333.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-afa3a2f3f7

Comment 15 Fedora Update System 2017-05-05 21:01:03 UTC
buildah-0.0.1-1.gita0a5333.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a70f3f8faf

Comment 16 Fedora Update System 2017-05-05 22:37:18 UTC
buildah-0.0.1-1.gita0a5333.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-afa3a2f3f7

Comment 17 Fedora Update System 2017-06-14 19:58:26 UTC
buildah-0.1.0-2.git597d2ab.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8a49d2f519

Comment 18 Fedora Update System 2017-06-14 19:58:36 UTC
buildah-0.1.0-2.git597d2ab.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d10c0f7b00

Comment 19 Fedora Update System 2017-06-15 10:59:12 UTC
buildah-0.1.0-2.git597d2ab.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8a49d2f519

Comment 20 Fedora Update System 2017-06-15 14:01:14 UTC
buildah-0.1.0-2.git597d2ab.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d10c0f7b00

Comment 21 Fedora Update System 2017-06-22 13:35:27 UTC
buildah-0.1.0-2.git597d2ab.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2017-06-28 20:51:35 UTC
buildah-0.1.0-2.git597d2ab.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Red Hat Bugzilla 2023-09-14 03:56:50 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days


Note You need to log in before you can comment on or make changes to this bug.