Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1451801 - "setfacl --restore" fails due to use of uninitialized memory
Summary: "setfacl --restore" fails due to use of uninitialized memory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: acl
Version: 6.9
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 1451820
Blocks: 1464897
TreeView+ depends on / blocked
 
Reported: 2017-05-17 14:41 UTC by Renaud Métrich
Modified: 2020-09-10 10:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1451820 1464897 (view as bug list)
Environment:
Last Closed: 2018-06-21 08:45:47 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Suggested fix (470 bytes, patch)
2017-05-17 14:41 UTC, Renaud Métrich
no flags Details | Diff

Description Renaud Métrich 2017-05-17 14:41:57 UTC
Created attachment 1279726 [details]
Suggested fix

Description of problem:

When using "setfacl --restore <aclfile>" command, the command may fail when setting ACLs because of the reading of unitialized memory, causing unexpected code path to be executed.

Requesting backport of http://git.savannah.gnu.org/cgit/acl.git/commit?id=33f01b5d

Version-Release number of selected component (if applicable):

acl-2.2.49-7.el6.x86_64

How reproducible:

Always on customer setup, never on mine.

Additional info:

Backporting http://git.savannah.gnu.org/cgit/acl.git/commit?id=33f01b5d fixed the issue.

Comment 3 Kamil Dudka 2017-05-17 14:59:31 UTC
As discussed privately, this is easy and safe to backport.  Moreover, the fix is already verified in customer's environment.


Note You need to log in before you can comment on or make changes to this bug.