Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1455673 - GNOME Software should make sure system is current on updates before upgrading to new release
Summary: GNOME Software should make sure system is current on updates before upgrading...
Keywords:
Status: CLOSED DUPLICATE of bug 1336435
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F26FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-05-25 18:21 UTC by Matthew Miller
Modified: 2017-06-05 16:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 16:51:21 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1336435 0 unspecified NEW Require/Recommend all package updates to be installed before starting a system upgrade 2022-04-28 15:39:55 UTC

Internal Links: 1336435

Description Matthew Miller 2017-05-25 18:21:55 UTC
For example, this update to libdb https://bodhi.fedoraproject.org/updates/FEDORA-2017-a4c41ecc27 notes that the update to the old release should be in place _before_ the upgrade to the new release starts. I can imagine other scenarios with a similar requirement.

Software should make sure the current system is up to date before performing an update. (We recommend this in the step-by-step procedure for using the DNF command line, here https://fedoraproject.org/wiki/Upgrading_Fedora_using_package_manager.)

Comment 1 Kamil Páral 2017-06-05 16:51:21 UTC
Merging with our previous request.

*** This bug has been marked as a duplicate of bug 1336435 ***


Note You need to log in before you can comment on or make changes to this bug.