Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1470768 - file /usr/lib64/glusterfs/3.12dev/xlator is not owned by any package
Summary: file /usr/lib64/glusterfs/3.12dev/xlator is not owned by any package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-13 15:32 UTC by Niels de Vos
Modified: 2017-09-05 17:36 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-05 17:36:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1473197 0 unspecified CLOSED glusterfs should own its directories 2022-05-16 11:32:56 UTC

Internal Links: 1473197

Description Niels de Vos 2017-07-13 15:32:45 UTC
Description of problem:
After upgrading glusterfs-3.10 to a build from the master branch, the directory /usr/lib64/glusterfs/3.10.4/xlator still exists (with some other empty directories in it).

Version-Release number of selected component (if applicable):
3.10.4 and probably all other

How reproducible:
100%

Steps to Reproduce:
1. install a version
2. upgrade
3. check for version number (directories) under /usr/lib64/glusterfs/

Actual results:
/usr/lib64/glusterfs/3.10.4/xlator still exists and does not contain any .so (xlator) files, only empty dirs.

Expected results:
After updating, /usr/lib64/glusterfs/3.10.4/xlator should be removed.

Additional info from #gluster-dev on Freenode:
16:07 < ndevos> kkeithley: /usr/lib64/glusterfs/3.10.4/xlator does not seem to be part of the (Fedora 26) package, have you noticed that before?
16:08 < ndevos> and that is a problem in the upstream package as well (just checked)
16:08 < ndevos> so, probably all RPMs...
16:20 <@kkeithley> ndevos: not part of the package, as in `rpm -q --whatprovides /usr/lib64/glusterfs/NVR/xlator` doesn't show glusterfs?
16:32 <@kkeithley> ndevos: do you think it can be owned by glusterfs? Or do we have to have fine-grained ownership amongst glusterfs, glusterfs-client-xlators, and glusterfs-extra-xlators ?
16:35 < ndevos> kkeithley: from the master branch, I get this:
16:35 < ndevos> # rpm -qf /usr/lib64/glusterfs/3.12dev/xlator
16:35 < ndevos> file /usr/lib64/glusterfs/3.12dev/xlator is not owned by any package
16:35 <@kkeithley> so that would be a yes to my question
16:36 <@kkeithley> first question
16:36 < ndevos> it should be owned by all packages that have xlators, directories can be part of multiple packages
16:41 <@kkeithley> related puzzle: /usr/lib64/glusterfs/$NVR/xlators/mgmt/{,glusterd.so} are owned by glusterfs-server. But neither the directory or the glusterd.so is listed in the %files server section.
16:41 <@kkeithley> of the .spec
16:45 < ndevos> yeah, I did not look at it yet, but I expect more of those dirs to be missing
16:45 <@kkeithley> /usr/lib64/glusterfs/$NVR/xlators/protocol/{client.so,server.so} are owned by -server and -client-xlators. Again, nothing in %files server, but %files client-xlators has client.so (and some others)
16:46 <@kkeithley> so I'm curious about how those files managed to be owned by -server
16:48 <@kkeithley> actually, no puzzle. I just need to read all of the %files server section
17:26 < ndevos> kkeithley: shall I file a bug  for the "file /usr/lib64/glusterfs/*/xlator is not owned by any package" problem?
17:26 <@kkeithley> yup
17:26 < ndevos> do you want to send a patch for it, or shall I?
17:27 <@kkeithley> I'm just testing my patch
17:27 < ndevos> cool!
17:27 < ndevos> kkeithley++
17:27 <@glusterbot> ndevos: kkeithley's karma is now 194

Comment 1 Worker Ant 2017-07-13 15:46:10 UTC
REVIEW: https://review.gluster.org/17770 (packaging: various directories not owned by any package) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle)

Comment 2 Worker Ant 2017-07-13 16:06:09 UTC
REVIEW: https://review.gluster.org/17770 (packaging: various directories not owned by any package) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle)

Comment 3 Worker Ant 2017-07-13 16:17:47 UTC
REVIEW: https://review.gluster.org/17770 (packaging: various directories not owned by any package) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle)

Comment 4 Worker Ant 2017-07-14 18:32:43 UTC
COMMIT: https://review.gluster.org/17770 committed in master by Niels de Vos (ndevos) 
------
commit 2b290b50457ce2bd37f18d516c665abc1e96d2d6
Author: Kaleb S. KEITHLEY <kkeithle>
Date:   Thu Jul 13 11:35:50 2017 -0400

    packaging: various directories not owned by any package
    
    e.g. /usr/libexec/glusterfs or /usr/lib64/glusterfs/$NV/xlator
    
    Change-Id: Ibccb8d27b6ad3d6c335e5bbf39aec03b4fe5c8dd
    BUG: 1470768
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle>
    Reviewed-on: https://review.gluster.org/17770
    Smoke: Gluster Build System <jenkins.org>
    CentOS-regression: Gluster Build System <jenkins.org>
    Reviewed-by: Milind Changire <mchangir>
    Reviewed-by: Niels de Vos <ndevos>

Comment 5 Shyamsundar 2017-09-05 17:36:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.