Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1481192 - Netinstall with only Basic desktop selected failes to start up after reboot
Summary: Netinstall with only Basic desktop selected failes to start up after reboot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lightdm-gtk
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-14 10:30 UTC by art
Modified: 2018-01-07 19:07 UTC (History)
15 users (show)

Fixed In Version: lightdm-gtk-2.0.2-6.fc26 lightdm-gtk-2.0.2-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-07 19:07:18 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of seat greeter log (2.42 MB, image/png)
2017-08-21 12:01 UTC, leigh scott
no flags Details
screenshot 1 (1.19 MB, image/jpeg)
2017-09-11 07:30 UTC, art
no flags Details
screenshot 2 (949.64 KB, image/jpeg)
2017-09-11 07:31 UTC, art
no flags Details

Description art 2017-08-14 10:30:15 UTC
Description of problem:

After the reboot upon seemingly succesful netinstall I end up in some sort of a loop after the message [OK] Started update UMTP about System Runlevel Changes. From my very limited knowledge of Gnome and Fedora Proper, it could be trying to launch Gnome initial setup menu, but in just a matter of miliseconds it would show that pre-login boot messages again, and it just gets looped. So i never get to see LightDM or anything. System gets unresponsive. It would occasionally show the tty login screen on one of the consoles if you press hard those ctrl+alt+f whatever buttons, but then again would start doing this craziness, so you can't even login via console.
I remember noticing the similar behaviour in Fedora 25 netinstall, but that time it would easily break through this initial step of trying to load something, and would take you to LightDM shortly.

Version-Release number of selected component (if applicable):


How reproducible:

had exactly the same outcome some time ago (a week, two weeks ago) but was busy to provide a bug. So i guess always reproducable for me

Steps to Reproduce:
1. Install with only Basic Desktop selected
2. Press reboot upon completion
3. End up in a loop

Actual results: get that pre-login loop

Expected results: See a LightDM login screen

Additional info:

this time i tried to preserve anaconda.log (it should be *.log as a matter of fact) if they would be of any help

my system: Dell Vostro A860, intel graphics, ath5k wifi driver

Will be happy to provide further info. 

Thanks

Comment 1 Jiri Konecny 2017-08-21 09:16:23 UTC
The lightdm is already installed by Anaconda in this phase, so this is probably bug in the lightdm package.

Changing components.

Comment 2 leigh scott 2017-08-21 09:20:53 UTC
Post the lightdm logs and Xorg.0.log

Comment 3 leigh scott 2017-08-21 12:01:41 UTC
Created attachment 1316226 [details]
screenshot of seat greeter log

I have tested the basic desktop install and the lightdm log indicated a greeter issue so I checked the seat greeter log (see screenshot).

Comment 4 Neal Gompa 2017-08-21 18:28:30 UTC
You should never use lightdm-autologin-greeter for these things. It's intended to be used for kiosks and things like that.

See the README.distro for details: https://src.fedoraproject.org/rpms/lightdm-autologin-greeter/blob/master/f/lightdm-autologin-greeter.README.distro

Switch to lightdm-gtk or some other greeter.

Comment 5 leigh scott 2017-08-21 18:33:57 UTC
(In reply to Neal Gompa from comment #4)
> You should never use lightdm-autologin-greeter for these things. It's
> intended to be used for kiosks and things like that.
> 
In that case why is it the default for 'Basic Desktop' on the net installer?
My guess is the lightdm-greeter provides is causing the issue.

Maybe you should remove this if it isn't a proper greeter

# All LightDM greeters provide this
Provides:       lightdm-greeter = 1.2

Comment 6 Fedora Update System 2017-08-21 19:30:24 UTC
lightdm-autologin-greeter-1.0-4.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e2a63143ca

Comment 7 Rex Dieter 2017-08-21 22:12:51 UTC
I'd suggest something like this in lightdm too:

diff --git a/lightdm.spec b/lightdm.spec
index 45f42ca..8a8c293 100644
--- a/lightdm.spec
+++ b/lightdm.spec
@@ -8,7 +8,7 @@
 Name:    lightdm
 Summary: A cross-desktop Display Manager
 Version: %{major}.%{minor}
-Release: 5%{?dist}
+Release: 6%{?dist}
 
 # library/bindings are LGPLv2 or LGPLv3, the rest GPLv3+
 License: (LGPLv2 or LGPLv3) and GPLv3+
@@ -81,6 +81,8 @@ Requires(pre): shadow-utils
 # leaving this here, means greeters will have to require lightdm too,
 # instead of relying on -gobject, -qt to pull it in
 Requires: lightdm-greeter = 1.2
+# preferred greeter
+Recommends: lightdm-gtk
 
 # needed for anaconda to boot into runlevel 5 after install
 Provides: service(graphical-login) = lightdm
@@ -304,6 +306,9 @@ exit 0
 
 
 %changelog
+* Mon Aug 21 2017 Rex Dieter <rdieter> - 1.22.0-6
+- Recommends: lightdm-gtk (#1481192)
+
 * Thu Aug 03 2017 Fedora Release Engineering <releng> - 1.22.0-5
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

Comment 8 Neal Gompa 2017-08-22 00:57:56 UTC
(In reply to leigh scott from comment #5)
> (In reply to Neal Gompa from comment #4)
> > You should never use lightdm-autologin-greeter for these things. It's
> > intended to be used for kiosks and things like that.
> > 
> In that case why is it the default for 'Basic Desktop' on the net installer?
> My guess is the lightdm-greeter provides is causing the issue.
> 
> Maybe you should remove this if it isn't a proper greeter
> 
> # All LightDM greeters provide this
> Provides:       lightdm-greeter = 1.2

No, because then if you want only the autologin-greeter, you can't. You'll be forced to have *another one* too.

Don't do things like this. If you want to prefer a specific greeter, use Suggests somewhere. Or fix the comps group. Or something else.

Comment 9 Neal Gompa 2017-08-22 00:58:37 UTC
@Rex:

Use "Suggests: lightdm-gtk" rather than Recommends, as that tells the solver to prefer it if no choice is made, rather than forcing it to be installed.

Comment 10 Neal Gompa 2017-08-22 01:06:55 UTC
The way to fix this is to just set a "Suggests: lightdm-gtk" in lightdm itself, so that if no selection is made, it'll install that one.

Comment 11 leigh scott 2017-08-22 06:23:25 UTC
(In reply to Neal Gompa from comment #8)

>  Or fix the comps group. Or something else.


Pull request done


https://pagure.io/fedora-comps/pull-request/161

Comment 12 Björn 'besser82' Esser 2017-08-22 07:17:12 UTC
I've added `Supplements: (lightdm%{?_isa} and lightdm-autologin-greeter)` to lightdm-gtk.  That should fix that issue.

Comment 13 Fedora Update System 2017-08-22 07:34:41 UTC
lightdm-gtk-2.0.2-6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-70b4affd10

Comment 14 Fedora Update System 2017-08-23 08:55:16 UTC
lightdm-gtk-2.0.2-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-985f7a1cc6

Comment 15 Fedora Update System 2017-08-23 09:03:40 UTC
lightdm-gtk-2.0.2-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-70b4affd10

Comment 16 Fedora Update System 2017-08-24 15:51:45 UTC
lightdm-gtk-2.0.2-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2017-08-24 23:22:15 UTC
lightdm-gtk-2.0.2-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 art 2017-09-11 07:30:22 UTC
Created attachment 1324361 [details]
screenshot 1

Comment 19 art 2017-09-11 07:31:36 UTC
Created attachment 1324362 [details]
screenshot 2

Comment 20 art 2017-09-11 07:37:23 UTC
guys, thanks for your time!
went back to testing netinstall with only basic desctop selected, and unfortunately the problem somewhat persists.
on first reboot i do get to see a splash of initial setup window, then a grey background with mouse pointer, then i'm thrown back to tty (screenshot 1) with a same type of loop and unresponsive system.
on the second reboot i dont get passed the tty at all wit a loop after a message "Started job spooling tools".
is it a matter of updating netinstall iso? or could there be another lightdm-related problem? or anything else?
thanks!

Comment 21 art 2017-09-19 12:38:49 UTC
have i set the wrong status for this maybe?

Comment 22 art 2017-10-05 09:39:02 UTC
maybe anyone tried it on Fedora 27 Beta netinstall?

Comment 23 leigh scott 2017-10-05 09:58:29 UTC
(In reply to art from comment #22)
> maybe anyone tried it on Fedora 27 Beta netinstall?

I consider it is your job to test it.

Comment 24 art 2017-10-05 10:32:00 UTC
thanks for a quick reply.
sorry, my hdd died a few days ago, so i'm on tablet only for a time being

Comment 25 art 2018-01-07 17:44:59 UTC
(In reply to art from comment #22)
> maybe anyone tried it on Fedora 27 Beta netinstall?

so i finally did a new f27 netinstall, and i didn't face that problem. so thanks guys.


Note You need to log in before you can comment on or make changes to this bug.