Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1492981 - pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace/add layout with: 'in (eng)'
Summary: pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace/add layout w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xkeyboard-config
Version: 27
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1494015 (view as bug list)
Depends On:
Blocks: F27BetaBlocker F27BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-09-19 05:44 UTC by sandeep shedmake
Modified: 2017-09-22 05:16 UTC (History)
29 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 18:28:35 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Traceback report for scenario 1 - while anaconda installation with Indic language (Marathi) as preferred LANG (deleted)
2017-09-19 05:44 UTC, sandeep shedmake
no flags Details
Traceback report for scenario 2 - Add 'in (eng)' layout while anaconda installation with Japanese or Spanish as preferred LANG (deleted)
2017-09-19 05:49 UTC, sandeep shedmake
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1469407 0 unspecified CLOSED Fedora 26 ISO - Cannot select English (India) - pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace layouts... 2021-02-22 00:41:40 UTC

Internal Links: 1469407

Description sandeep shedmake 2017-09-19 05:44:32 UTC
Created attachment 1327718 [details]
Traceback report for scenario 1 - while anaconda installation with Indic language (Marathi) as preferred LANG

Description of problem:
Get Traceback while:
- anaconda installation with Indic language (say Marathi) as preferred LANG
- adding 'in (eng)' layout while anaconda installation with Japanese or Spanish as preferred LANG


Version-Release number of selected component (if applicable):
anaconda-27.20.1-1.fc27


How reproducible:
Always


Steps to Reproduce:
'Scenario 1': Try to perform anaconda installation with any Indic language as preferred LANG
'Scenario 2': Try to add 'in (eng)' layout while anaconda installation with Japanese or Spanish as preferred LANG


Actual results:
Traceback


Expected results:
No Traceback


Additional info:
See attachments for traceback reports for both the 'Scenario 1' and 'Scenario 2'

Comment 1 sandeep shedmake 2017-09-19 05:49:16 UTC
Created attachment 1327719 [details]
Traceback report for scenario 2 - Add 'in (eng)' layout while anaconda installation with Japanese or Spanish as preferred LANG

Comment 2 Parag Nemade 2017-09-19 06:26:08 UTC
Looks like we are missing updated xkeyboard-config-2.21-3.fc27.noarch package in Beta. I have still not tested it as we need Workstation iso image updated with xkeyboard-config-2.21-3.fc27 package.

I will request Fedora QA group to evaluate if this can be blocker or exception bug but marking it as blocker currently.

I tested Indic languages only so this is affecting Indic languages only I guess.

Comment 3 Parag Nemade 2017-09-19 06:28:43 UTC
I see the update has been already submitted for F27 stable -> https://bodhi.fedoraproject.org/updates/FEDORA-2017-e38be801d8

Comment 4 Samantha N. Bueno 2017-09-20 08:54:24 UTC
This is not a bug in anaconda. It is a bug in xkeyboard-config, which has been identified and fixed recently, as you've noted.

Comment 5 Kamil Páral 2017-09-20 13:04:19 UTC
Proposing as a Beta freeze exception. This fixes Indian keyboards in anaconda. The patch looks very small, see bug 1469407 comment 31. It already has some karma in Bodhi (comment 3).

+1 Beta FE from me

Comment 6 Petr Schindler 2017-09-20 13:09:44 UTC
+1 FE from me too.

Comment 7 Stephen Gallagher 2017-09-20 13:19:38 UTC
+1 FE

Comment 8 Kalev Lember 2017-09-20 13:19:50 UTC
+1 FE

Comment 9 Kamil Páral 2017-09-20 13:25:07 UTC
Marking as accepted FE.

Comment 10 Kamil Páral 2017-09-21 09:24:44 UTC
Update from comment 3 has been pushed stable, the fix should be part of 20170921 compose. We need to test this.

Comment 11 Samantha N. Bueno 2017-09-21 10:48:37 UTC
*** Bug 1494015 has been marked as a duplicate of this bug. ***

Comment 12 sumantro 2017-09-21 16:50:43 UTC
Fedora-27-20170921.n.0 KDE live installs fine with hindi layout

Comment 13 sumantro 2017-09-21 17:18:59 UTC
Fedora-27-20170921.n.0 KDE live installs fine with EN In and japanese layout

Comment 14 Kamil Páral 2017-09-21 18:28:35 UTC
Thanks sumantro, closing.

Comment 15 Parag Nemade 2017-09-22 05:16:27 UTC
Thank you Kamil and Sumantro for your quick help and getting this update into Beta iso image.


Note You need to log in before you can comment on or make changes to this bug.