Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1493660 - Use mariadb-connector-c-devel instead of mysql-devel or mariadb-devel
Summary: Use mariadb-connector-c-devel instead of mysql-devel or mariadb-devel
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl-mysqltcl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Rene Ploetz
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: 1486480
TreeView+ depends on / blocked
Reported: 2017-09-20 16:14 UTC by Michal Schorm
Modified: 2017-11-02 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-11-02 15:38:48 UTC
Type: Bug

Attachments (Terms of Use)

Description Michal Schorm 2017-09-20 16:14:01 UTC
Hello, please apply following command to the package SPECfile:

sed -i "s/mysql-devel/mariadb-connector-c-devel/" $(fedpkg gimmespec) ; \
sed -i "s/mariadb-devel/mariadb-connector-c-devel/" $(fedpkg gimmespec) ; \
sed -i "s/%{_libdir}\/mysql/%{_libdir}\/mariadb/" $(fedpkg gimmespec) ;

I've tested, that after the command ^ the package builds successfuly in KOJI and uses mariadb client library.

This change is currently applicable to the Rawhide (f28) only.

For more information check the tracking bugzilla.

Comment 1 Rene Ploetz 2017-11-01 23:22:32 UTC
I tried to update the package today but failed twice in koji, first the library was moved from %{_libdir}/mariadb to %{_libdir} and mirrors are still using the .11 client library instead of the koji update .12 that changed that behaviour.

After I changed the path to %{_libdir}, the koji build fails due to a mariadb-connector-c (or some koji issues?!)

The install into buildroot on koji essentially fails with (see root.log for any arch):
DEBUG  Error: 
DEBUG   Problem: conflicting requests
DEBUG    - nothing provides pkconfig(openssl) needed by mariadb-connector-c-devel-3.0.2-17.fc28.x86_64 

It worked locally in mock with version .16 but fails everytime with .17 - so I need to wait for a working version of the dependency and test locally and rerun on koji.

Comment 2 Michal Schorm 2017-11-02 00:09:42 UTC
"pkconfig(openssl)" was typo. Fixed in release 18.
It should be already available in buildroot in KOJI.

Yes, I recently moved the library to the libdir. Thanks for reminder, that i should update the tracked bugs with new path.
I was forced to move it beacuse of crazy issues with the libdir/mariadb, libdir/mysql directories and symlinks to them bugs.

Comment 3 Rene Ploetz 2017-11-02 15:38:48 UTC
Thanks for the clarifications, I updated the koji build for rawhide:

Note You need to log in before you can comment on or make changes to this bug.