Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1494094 - Use mariadb-connector-c-devel instead of mysql-devel or mariadb-devel
Summary: Use mariadb-connector-c-devel instead of mysql-devel or mariadb-devel
Alias: None
Product: Fedora
Classification: Fedora
Component: exim
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: 1486480
TreeView+ depends on / blocked
Reported: 2017-09-21 12:55 UTC by Michal Schorm
Modified: 2017-11-10 20:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-11-10 20:03:54 UTC
Type: Bug

Attachments (Terms of Use)
Fixes to spec file (1.75 KB, patch)
2017-10-17 12:22 UTC, Augusto Caringi
no flags Details | Diff

Description Michal Schorm 2017-09-21 12:55:03 UTC
Hello, MariaDB went through big changes and your package will need a patch in order to build and work properly.

I tried to solve the issue, but I wasn't successful yet (at the time of bug creation).
I'll look into it more and post here the patch eventualy.

This change is currently applicable to the Rawhide (f28) only.

You can check builds I tried in COPR:

For more information check the tracking bugzilla.

Comment 1 Augusto Caringi 2017-10-17 12:21:59 UTC
Upstream is already aware of this problem:

I think that we can use the patch provided in the ticket above to fix the problem:

Also, I'm attaching a patch with some minor changes to the spec file:

- Replacing mysql-devel by mariadb-connector-c-devel
- Dropping the mariadb-10.2-compile-fix that is no longer needed

Comment 2 Augusto Caringi 2017-10-17 12:22:48 UTC
Created attachment 1339680 [details]
Fixes to spec file

Comment 3 Jaroslav Škarvada 2017-11-03 10:04:54 UTC
Thanks for info/patches, I will handle it.

Comment 4 Jaroslav Škarvada 2017-11-10 20:03:54 UTC
I used upstream patch. Resulting binary seems OK, but I didn't do much testing. Please let me know in case of any functional problems.

Note You need to log in before you can comment on or make changes to this bug.