Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1494099 - Use mariadb-connector-c-devel instead of mysql-devel or mariadb-devel
Summary: Use mariadb-connector-c-devel instead of mysql-devel or mariadb-devel
Alias: None
Product: Fedora
Classification: Fedora
Component: mydns
Version: 28
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: 1486480
TreeView+ depends on / blocked
Reported: 2017-09-21 12:58 UTC by Michal Schorm
Modified: 2018-02-24 17:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-02-24 17:48:56 UTC
Type: Bug

Attachments (Terms of Use)
Patch to fix build of MyDNS against MariaDB C/C 3.x (1.65 KB, patch)
2017-10-17 09:10 UTC, Augusto Caringi
no flags Details | Diff

Description Michal Schorm 2017-09-21 12:58:04 UTC
Hello, MariaDB went through big changes and your package will need a patch in order to build and work properly.

I tried to solve the issue, but I wasn't successful yet (at the time of bug creation).
I'll look into it more and post here the patch eventualy.

This change is currently applicable to the Rawhide (f28) only.

You can check builds I tried in COPR:

For more information check the tracking bugzilla.

Comment 1 Augusto Caringi 2017-10-17 09:09:35 UTC

    I'm attaching a patch with the needed modifications to build MyDNS against this new version of MariaDB Connector/C 3.x.

    The main problem is that they dropped the MYSQL_SERVER_VERSION define.

    In the spec file, we need to replace the BuildRequires: mysql-devel by BuildRequires: mariadb-connector-c-devel and add a BuildRequires: zlib-devel.

    I've already sent an email to upstream with my fix, asking if it's the best solution.

    Buildings on copr:

Comment 2 Augusto Caringi 2017-10-17 09:10:59 UTC
Created attachment 1339625 [details]
Patch to fix build of MyDNS against MariaDB C/C 3.x

Comment 3 Augusto Caringi 2017-10-17 09:19:46 UTC

    We can drop this from the spec file:

# Fix build with MariaDB 10.2
Patch1: mydns-mariadb102.patch

    This patch is no longer necessary.

Comment 4 Fedora End Of Life 2018-02-20 15:22:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 5 Itamar Reis Peixoto 2018-02-24 17:48:56 UTC
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.