Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1496489 - After upgrading to Fedora 27: Failed to Update - Too many results returned
Summary: After upgrading to Fedora 27: Failed to Update - Too many results returned
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-09-27 14:49 UTC by František Zatloukal
Modified: 2017-10-30 01:53 UTC (History)
6 users (show)

Fixed In Version: gnome-software-3.26.1-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-30 01:53:18 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Log from upgrade - dnf (deleted)
2017-09-27 14:50 UTC, František Zatloukal
no flags Details
Log from upgrade - PackageKit (deleted)
2017-09-27 14:51 UTC, František Zatloukal
no flags Details
Error message after upgrade (deleted)
2017-09-27 14:51 UTC, František Zatloukal
no flags Details
Notification Screenshot (deleted)
2017-10-25 05:53 UTC, Jonathan Haas
no flags Details

Description František Zatloukal 2017-09-27 14:49:27 UTC
Description of problem:
After upgrading from Fedora 26 to Fedora 27 with updates-testing enabled the user is presented with notification about failed upgrade. However, everything looks fine and distro-sync is pretty happy with installed packages and their versions. Everything looks just fine.

Version-Release number of selected component (if applicable):
gnome-software-3.26.0-1.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start upgrade to Fedora 27
2. Click on notification regarding failed upgrade

Actual results:
Failed to Update

Expected results:
User should see no warning after successful upgrade.

Additional info:
This error occurred with updates-testing enabled. Will try upgrade without this and post an update to this bug later.

Comment 1 František Zatloukal 2017-09-27 14:50:58 UTC
Created attachment 1331464 [details]
Log from upgrade - dnf

Comment 2 František Zatloukal 2017-09-27 14:51:20 UTC
Created attachment 1331465 [details]
Log from upgrade - PackageKit

Comment 3 František Zatloukal 2017-09-27 14:51:54 UTC
Created attachment 1331466 [details]
Error message after upgrade

Comment 4 Jonathan Haas 2017-10-06 06:51:31 UTC
I got the same error after doing a upgrade with gnome-software according to this instructions: https://fedoraproject.org/wiki/QA:Testcase_upgrade_gnome-software_current_workstation

Comment 5 Fedora Blocker Bugs Application 2017-10-25 05:41:55 UTC
Proposed as a Blocker and Freeze Exception for 27-final by Fedora user jonha using the blocker tracking app because:

 This might not technically violate the "There must be no [...] crash notifications on [...] first login after a default install of a release-blocking desktop." criterion, because it happens after an upgrade and not after installation and it shows an "update failed" notification instead of a crash notification.

But I think this is similar enough (in spirit) to be considered.

This happened to all Workstation installations I upgraded to F27 Beta via both dnf and gnome-software and it should at least be investigated, because it is very confusing to get an "update failed" notification after a successful upgrade.

Comment 6 Jonathan Haas 2017-10-25 05:53:36 UTC
Created attachment 1343094 [details]
Notification Screenshot

Note that in addition to the gnome-software error you get an annoying and confusing notification after every login.

Note that software upgrades generally work despite the error message.

Comment 7 Jonathan Haas 2017-10-25 14:05:09 UTC
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=789477

Comment 8 Kalev Lember 2017-10-25 14:12:10 UTC
I debugged this and it's the F27 gnome-software that's incorrectly showing an error there. Builds fixing this under way.

Comment 9 Fedora Update System 2017-10-25 14:42:13 UTC
gnome-software-3.26.1-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e25cbf4b94

Comment 10 Adam Williamson 2017-10-25 16:11:15 UTC
I'm -1 blocker on this. I'm probably +1 FE to try and ensure this doesn't affect day 1 upgrades, though, so long as the fix is fairly safe - Kalev?

Comment 11 Kalev Lember 2017-10-26 06:34:00 UTC
Yep, it's a targeted fix, and should be safe to pull in for final. +1 FE from me as well.

Comment 12 Adam Williamson 2017-10-26 20:37:16 UTC
Discussed at 2017-10-26 Fedora 27 Final go/no-go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-10-26/f27-final-and-server-beta-go-no-go-meeting.2017-10-26-17.00.html . Rejected as a blocker as it doesn't actually seem to violate the criteria at all - the upgrade *works* fine, there's just a bogus error. However, accepted as a freeze exception issue as this obviously doesn't look good and it'd be nice to avoid people hitting it between now and the 0-day update push.

Comment 13 Fedora Update System 2017-10-30 01:53:18 UTC
gnome-software-3.26.1-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.