Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1502915 - World map missing in Time & Date
Summary: World map missing in Time & Date
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libtimezonemap
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 1503758 (view as bug list)
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-10-17 03:48 UTC by Alessio
Modified: 2017-10-24 20:09 UTC (History)
23 users (show)

Fixed In Version: libtimezonemap-0.4.5.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-24 20:09:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
hawkey.log (deleted)
2017-10-17 09:11 UTC, Alessio
no flags Details
packaging.log (deleted)
2017-10-17 09:11 UTC, Alessio
no flags Details
dnf.librepo.log (deleted)
2017-10-17 09:12 UTC, Alessio
no flags Details
anaconda.log (deleted)
2017-10-17 09:12 UTC, Alessio
no flags Details
program.log (deleted)
2017-10-17 09:12 UTC, Alessio
no flags Details
storage.log (deleted)
2017-10-17 09:13 UTC, Alessio
no flags Details
sensitive-info.log (deleted)
2017-10-17 09:13 UTC, Alessio
no flags Details
vncserver.log (deleted)
2017-10-17 09:14 UTC, Alessio
no flags Details
CSS styling error patch (deleted)
2017-10-20 13:07 UTC, Jiri Konecny
no flags Details

Description Alessio 2017-10-17 03:48:05 UTC
Description of problem:
Starting at least in 20171008 compose, and at least in Workstation-Live and Workstation-netinst, the world map in Time & Zone section is missing. Same issue in 20171012 and 20171015 composes.

Version-Release number of selected component (if applicable):
anaconda 27.20.2-1

How reproducible:
Booting installation media (at least Workstation), using graphical install.

Steps to Reproduce:
1. Go to Localization - TIME & DATE

Actual results:
No world map is displayed.

Expected results:
The world map should be displayed.

Additional info:
https://alciregi.fedorapeople.org/screenshot/Screenshot%20from%202017-10-17%2005-35-03.png

Comment 1 Jiri Konecny 2017-10-17 08:11:34 UTC
Hello Alessio,

Could you please provides us logs from the installation as plain text files. You can find them in /tmp/*.log.

Thank you,
Jirka

Comment 2 Alessio 2017-10-17 09:11:02 UTC
Created attachment 1339626 [details]
hawkey.log

Comment 3 Alessio 2017-10-17 09:11:37 UTC
Created attachment 1339627 [details]
packaging.log

Comment 4 Alessio 2017-10-17 09:12:04 UTC
Created attachment 1339628 [details]
dnf.librepo.log

Comment 5 Alessio 2017-10-17 09:12:35 UTC
Created attachment 1339629 [details]
anaconda.log

Comment 6 Alessio 2017-10-17 09:12:57 UTC
Created attachment 1339630 [details]
program.log

Comment 7 Alessio 2017-10-17 09:13:27 UTC
Created attachment 1339631 [details]
storage.log

Comment 8 Alessio 2017-10-17 09:13:49 UTC
Created attachment 1339632 [details]
sensitive-info.log

Comment 9 Alessio 2017-10-17 09:14:09 UTC
Created attachment 1339633 [details]
vncserver.log

Comment 10 Alessio 2017-10-17 09:14:58 UTC
(In reply to Jiri Konecny from comment #1)
> Hello Alessio,
> 
> Could you please provides us logs from the installation as plain text files.
> You can find them in /tmp/*.log.

Hello. Here attached the logs.
The same issue is present also using VNC.

Comment 11 Vendula Poncova 2017-10-18 16:31:52 UTC
*** Bug 1503758 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Blocker Bugs Application 2017-10-19 09:27:56 UTC
Proposed as a Freeze Exception for 27-final by Fedora user jkonecny using the blocker tracking app because:

 Missing world map in the Anaconda Time and Date spoke seems really ugly, however, it is not blocking installation in any known way.

Comment 13 Jiri Konecny 2017-10-19 13:20:52 UTC
I was looking on this issue and everything looks correct to me. I'm not able to find any errors in logs.

I'm changing this to the libtimezonemap component which is the GTK widget responsible for this map. The only thing I have found out is that libtimezonemap is using GTK and librsvg and these libraries changed recently so that could be the root cause of this problem? However, I didn't saw any warning or error during build of libtimezonemap.

Cloud you please take a look on this issue?

Comment 14 David Shea 2017-10-19 14:56:06 UTC
This bug is caused by commit b2cc9ce181be7dbe90cbea3a57db1e841b0fe826 in librsvg. The SVG is generated by inkscape, and all of the style elements are CSS.

Comment 15 Adam Williamson 2017-10-19 18:26:11 UTC
+1 FE.

Comment 16 Fedora Blocker Bugs Application 2017-10-20 10:05:21 UTC
Proposed as a Blocker for 27-final by Fedora user m4rtink using the blocker tracking app because:

 We simply can't ship a stable Fedora release installer with one of the most visited screens being blank.

Comment 17 Jiri Konecny 2017-10-20 13:06:32 UTC
After some further investigation it looks like this issue is really in libtimezonemap. The problem is style in the svg file:

<style id="style5">g { display: none !important; } g:target { display: inline !important; }</style>

I'm not that good in the CSS, however, as I understand there shouldn't be "display: none" for the "g" group which is used everywhere. The reason why this is happening just now and not before is the commit you mentioned. IMHO the style setting was ignored because the CSS wasn't the default interpreter and the mentioned commit is fixing this issue.

I'm attaching patch which is fixing the Anaconda issue.

Comment 18 Jiri Konecny 2017-10-20 13:07:23 UTC
Created attachment 1341221 [details]
CSS styling error patch

Comment 19 Fedora Update System 2017-10-20 17:16:04 UTC
libtimezonemap-0.4.5.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-39b1c8aab4

Comment 20 Fedora Update System 2017-10-21 19:29:48 UTC
libtimezonemap-0.4.5.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-39b1c8aab4

Comment 21 Geoffrey Marr 2017-10-23 21:26:14 UTC
Discussed during the 2017-10-23 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker and an AcceptedFreezeException was made as it does not violate any existing criteria, but it is an obvious error that warrants a FreezeException.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-23/f27-blocker-review.2017-10-23-16.00.txt

Comment 22 František Zatloukal 2017-10-24 14:55:55 UTC
libtimezonemap-0.4.5.1-1.fc27 fixes the issue.

Comment 23 Fedora Update System 2017-10-24 20:09:05 UTC
libtimezonemap-0.4.5.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.