Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1556048 - libkolab: FTBFS in F28
Summary: libkolab: FTBFS in F28
Keywords:
Status: CLOSED DUPLICATE of bug 1518800
Alias: None
Product: Fedora
Classification: Fedora
Component: libkolab
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Timotheus Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F28FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-03-14 23:07 UTC by Fedora Release Engineering
Modified: 2018-04-04 15:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-04 15:26:15 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1518800 0 unspecified CLOSED libkolab: FTBFS in Fedora rawhide 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1562743 0 unspecified CLOSED F27 to F28 upgrade fails due to libkolab 2021-02-22 00:41:40 UTC

Internal Links: 1518800 1562743

Description Fedora Release Engineering 2018-03-14 23:07:40 UTC
Your package libkolab failed to build from source in current F28.

https://koji.fedoraproject.org/koji/taskinfo?taskID=24812456

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Comment 1 Adam Williamson 2018-04-03 23:38:07 UTC
It fails because it's looking for what looks like a kdelibs4 header:

In file included from /builddir/build/BUILD/libkolab-1.0.2/kolabformat/v2helpers.h:23,
                 from /builddir/build/BUILD/libkolab-1.0.2/kolabformat/kolabobject.cpp:20:
/builddir/build/BUILD/libkolab-1.0.2/./kolabformatV2/kolabbase.h:40:10: fatal error: kdatetime.h: No such file or directory
 #include <kdatetime.h>
          ^~~~~~~~~~~~~

I tried just adding a BR for kf5-kdelibs4support-devel , but that doesn't help (as it doesn't include the right dir on the include path). Before going any further in trying to fix this, should the package just be retired for F28+ ? It doesn't seem to be needed: the only thing that depends on anything provided by libkolab is python2-kolab, and nothing requires anything that python2-kolab provides. AFAICS.

Comment 2 Rex Dieter 2018-04-04 15:23:34 UTC
That's a deprecated (and recently removed) api from kf5-kcalendarcore I believe

Comment 3 Rex Dieter 2018-04-04 15:24:32 UTC
My recommendation is to retire this, at least until it's fixed and/or anything else really needs it.

Comment 4 Rex Dieter 2018-04-04 15:26:15 UTC
See also further correspondence in bug #1518800 (marking as dup, since there's more info there)

*** This bug has been marked as a duplicate of bug 1518800 ***


Note You need to log in before you can comment on or make changes to this bug.