Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1566311 - [abrt] gnome-software: get_app_section(): gnome-software killed by SIGABRT
Summary: [abrt] gnome-software: get_app_section(): gnome-software killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:1d28284f921e9a8b9c1b98c6282...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 03:17 UTC by Luya Tshimbalanga
Modified: 2018-04-26 19:32 UTC (History)
6 users (show)

Fixed In Version: gnome-software-3.28.1-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 00:21:00 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (48.64 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: cgroup (365 bytes, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: core_backtrace (21.31 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: cpuinfo (1.28 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: dso_list (17.04 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: environ (1.63 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: maps (84.71 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: mountinfo (4.13 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: open_fds (4.04 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: proc_pid_status (1.27 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details
File: var_log_messages (3.91 KB, text/plain)
2018-04-12 03:17 UTC, Luya Tshimbalanga
no flags Details

Description Luya Tshimbalanga 2018-04-12 03:17:12 UTC
Description of problem:
Viewing an update information

Version-Release number of selected component:
gnome-software-3.28.0-5.fc28

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: get_app_section
executable:     /usr/bin/gnome-software
journald_cursor: s=26aa96ce22ea4c5b94dfb36ec05ed497;i=1fb6;b=3fcf0d1a75314e159ff83e802cbc46fa;m=1fe25e1ea;t=5699e156f7d7d;x=485d92ba64d2f9f6
kernel:         4.16.0-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 1558928

Comment 1 Luya Tshimbalanga 2018-04-12 03:17:16 UTC
Created attachment 1420633 [details]
File: backtrace

Comment 2 Luya Tshimbalanga 2018-04-12 03:17:17 UTC
Created attachment 1420634 [details]
File: cgroup

Comment 3 Luya Tshimbalanga 2018-04-12 03:17:19 UTC
Created attachment 1420635 [details]
File: core_backtrace

Comment 4 Luya Tshimbalanga 2018-04-12 03:17:20 UTC
Created attachment 1420636 [details]
File: cpuinfo

Comment 5 Luya Tshimbalanga 2018-04-12 03:17:22 UTC
Created attachment 1420637 [details]
File: dso_list

Comment 6 Luya Tshimbalanga 2018-04-12 03:17:26 UTC
Created attachment 1420638 [details]
File: environ

Comment 7 Luya Tshimbalanga 2018-04-12 03:17:28 UTC
Created attachment 1420639 [details]
File: limits

Comment 8 Luya Tshimbalanga 2018-04-12 03:17:29 UTC
Created attachment 1420640 [details]
File: maps

Comment 9 Luya Tshimbalanga 2018-04-12 03:17:30 UTC
Created attachment 1420641 [details]
File: mountinfo

Comment 10 Luya Tshimbalanga 2018-04-12 03:17:31 UTC
Created attachment 1420642 [details]
File: open_fds

Comment 11 Luya Tshimbalanga 2018-04-12 03:17:33 UTC
Created attachment 1420643 [details]
File: proc_pid_status

Comment 12 Luya Tshimbalanga 2018-04-12 03:17:34 UTC
Created attachment 1420644 [details]
File: var_log_messages

Comment 13 Kalev Lember 2018-04-13 15:58:26 UTC
Thanks, should be fixed in gnome-software 3.28.1

Comment 14 Fedora Update System 2018-04-13 16:00:03 UTC
bijiben-3.28.1-1.fc28 devhelp-3.28.1-1.fc28 eog-3.28.1-1.fc28 epiphany-3.28.1-1.fc28 evince-3.28.2-1.fc28 evolution-3.28.1-2.fc28 evolution-data-server-3.28.1-2.fc28 evolution-ews-3.28.1-1.fc28 evolution-mapi-3.28.1-1.fc28 gdk-pixbuf2-2.36.12-1.fc28 gdm-3.28.1-1.fc28 gedit-3.28.1-1.fc28 gedit-plugins-3.28.1-1.fc28 gjs-1.52.1-1.fc28 glib2-2.56.1-1.fc28 gnome-boxes-3.28.2-1.fc28 gnome-builder-3.28.1-1.fc28 gnome-calculator-3.28.1-1.fc28 gnome-calendar-3.28.1-1.fc28 gnome-chess-3.28.1-1.fc28 gnome-contacts-3.28.1-1.fc28 gnome-desktop3-3.28.1-1.fc28 gnome-disk-utility-3.28.1-1.fc28 gnome-getting-started-docs-3.28.1-1.fc28 gnome-maps-3.28.1-1.fc28 gnome-music-3.28.1-1.fc28 gnome-session-3.28.1-1.fc28 gnome-settings-daemon-3.28.1-1.fc28 gnome-software-3.28.1-1.fc28 gnome-sound-recorder-3.28.1-1.fc28 gnome-system-monitor-3.28.1-1.fc28 gnome-todo-3.28.1-1.fc28 gnome-tweaks-3.28.1-1.fc28 gnome-user-docs-3.28.1-1.fc28 gnome-user-share-3.28.0-1.fc28 gobject-introspection-1.56.1-1.fc28 gvfs-1.36.1-1.fc28 libdazzle-3.28.1-1.fc28 libsoup-2.62.1-1.fc28 mm-common-0.9.12-1.fc28 nautilus-3.28.1-1.fc28 pango-1.42.1-1.fc28 shotwell-0.28.2-1.fc28 simple-scan-3.28.1-1.fc28 sysprof-3.28.1-1.fc28 vala-0.40.3-1.fc28 vte291-0.52.1-1.fc28 webkit2gtk3-2.20.1-1.fc28 yelp-3.28.1-1.fc28 zenity-3.28.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e67e16187d

Comment 15 luke_l 2018-04-14 07:24:33 UTC
*** Bug 1567489 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2018-04-15 02:25:29 UTC
bijiben-3.28.1-1.fc28, devhelp-3.28.1-1.fc28, eog-3.28.1-2.fc28, epiphany-3.28.1-1.fc28, evince-3.28.2-1.fc28, evolution-3.28.1-2.fc28, evolution-data-server-3.28.1-2.fc28, evolution-ews-3.28.1-1.fc28, evolution-mapi-3.28.1-1.fc28, gdk-pixbuf2-2.36.12-1.fc28, gdm-3.28.1-1.fc28, gedit-3.28.1-1.fc28, gedit-plugins-3.28.1-1.fc28, gjs-1.52.1-1.fc28, glib2-2.56.1-1.fc28, gnome-boxes-3.28.2-1.fc28, gnome-builder-3.28.1-1.fc28, gnome-calculator-3.28.1-1.fc28, gnome-calendar-3.28.1-1.fc28, gnome-chess-3.28.1-1.fc28, gnome-contacts-3.28.1-1.fc28, gnome-desktop3-3.28.1-1.fc28, gnome-disk-utility-3.28.1-1.fc28, gnome-getting-started-docs-3.28.1-1.fc28, gnome-maps-3.28.1-1.fc28, gnome-music-3.28.1-1.fc28, gnome-session-3.28.1-1.fc28, gnome-settings-daemon-3.28.1-1.fc28, gnome-shell-3.28.1-1.fc28, gnome-shell-extensions-3.28.1-1.fc28, gnome-software-3.28.1-1.fc28, gnome-sound-recorder-3.28.1-1.fc28, gnome-system-monitor-3.28.1-1.fc28, gnome-terminal-3.28.1-1.fc28, gnome-todo-3.28.1-1.fc28, gnome-tweaks-3.28.1-1.fc28, gnome-user-docs-3.28.1-1.fc28, gnome-user-share-3.28.0-1.fc28, gobject-introspection-1.56.1-1.fc28, gvfs-1.36.1-1.fc28, libdazzle-3.28.1-1.fc28, libsoup-2.62.1-1.fc28, mm-common-0.9.12-1.fc28, mutter-3.28.1-1.fc28, nautilus-3.28.1-1.fc28, pango-1.42.1-1.fc28, shotwell-0.28.2-1.fc28, simple-scan-3.28.1-1.fc28, sysprof-3.28.1-1.fc28, vala-0.40.3-1.fc28, vte291-0.52.1-1.fc28, webkit2gtk3-2.20.1-1.fc28, yelp-3.28.1-1.fc28, zenity-3.28.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e67e16187d

Comment 17 Fedora Update System 2018-04-17 00:21:00 UTC
bijiben-3.28.1-1.fc28, devhelp-3.28.1-1.fc28, eog-3.28.1-2.fc28, epiphany-3.28.1-1.fc28, evince-3.28.2-1.fc28, evolution-3.28.1-2.fc28, evolution-data-server-3.28.1-2.fc28, evolution-ews-3.28.1-1.fc28, evolution-mapi-3.28.1-1.fc28, gdk-pixbuf2-2.36.12-1.fc28, gdm-3.28.1-1.fc28, gedit-3.28.1-1.fc28, gedit-plugins-3.28.1-1.fc28, gjs-1.52.1-1.fc28, glib2-2.56.1-1.fc28, gnome-boxes-3.28.2-1.fc28, gnome-builder-3.28.1-1.fc28, gnome-calculator-3.28.1-1.fc28, gnome-calendar-3.28.1-1.fc28, gnome-chess-3.28.1-1.fc28, gnome-contacts-3.28.1-1.fc28, gnome-desktop3-3.28.1-1.fc28, gnome-disk-utility-3.28.1-1.fc28, gnome-getting-started-docs-3.28.1-1.fc28, gnome-maps-3.28.1-1.fc28, gnome-music-3.28.1-1.fc28, gnome-session-3.28.1-1.fc28, gnome-settings-daemon-3.28.1-1.fc28, gnome-shell-3.28.1-1.fc28, gnome-shell-extensions-3.28.1-1.fc28, gnome-software-3.28.1-1.fc28, gnome-sound-recorder-3.28.1-1.fc28, gnome-system-monitor-3.28.1-1.fc28, gnome-terminal-3.28.1-1.fc28, gnome-todo-3.28.1-1.fc28, gnome-tweaks-3.28.1-1.fc28, gnome-user-docs-3.28.1-1.fc28, gnome-user-share-3.28.0-1.fc28, gobject-introspection-1.56.1-1.fc28, gvfs-1.36.1-1.fc28, libdazzle-3.28.1-1.fc28, libsoup-2.62.1-1.fc28, mm-common-0.9.12-1.fc28, mutter-3.28.1-1.fc28, nautilus-3.28.1-1.fc28, pango-1.42.1-1.fc28, shotwell-0.28.2-1.fc28, simple-scan-3.28.1-1.fc28, sysprof-3.28.1-1.fc28, vala-0.40.3-1.fc28, vte291-0.52.1-1.fc28, webkit2gtk3-2.20.1-1.fc28, yelp-3.28.1-1.fc28, zenity-3.28.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Michal Schmidt 2018-04-20 06:37:20 UTC
Similar problem has been detected:

Clicked on "OS updates" to view the list of packages to be installed.

reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: get_app_section
executable:     /usr/bin/gnome-software
journald_cursor: s=f7e2d776d03f4f2fb49725f4b7a29a54;i=1abc9c;b=e895e1f090274fba879d0b94644d2ed4;m=7f7d8fd0;t=56a41cb46c388;x=f918571f3447a1cf
kernel:         4.16.1-300.fc28.x86_64
package:        gnome-software-3.28.0-5.fc28
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            500

Comment 19 Rafal Luzynski 2018-04-26 19:32:24 UTC
Similar problem has been detected:

I browsed the list of updates. I could click every application update and it displayed the details. But when I clicked "OS Updates" gnome-software crashed. I repeated the same operation 3 times with 2 different locales and it always crashed. That was this morning. When I repeated the same steps now (the same day in the evening) nothing crashed but I can see more application updates. I have not updated anything yet, g-s version is the same. I guess that new app metadata arrived, that's all.

It looks like g-s can crash when it has old app metadata.

reporter:       libreport-2.9.4
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: get_app_section
executable:     /usr/bin/gnome-software
journald_cursor: s=1ec97338c8654abab6be81f3290cb757;i=3f23;b=f7d3cee800cd408a950bb6e3ab5fdf2a;m=4dcdcea6;t=56abdd81762f3;x=12725c9ebc51229
kernel:         4.16.0-300.fc28.x86_64
package:        gnome-software-3.28.0-5.fc28
reason:         gnome-software killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000


Note You need to log in before you can comment on or make changes to this bug.