Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1606143 - ruby: FTBFS in Fedora rawhide
Summary: ruby: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 18:38 UTC by Mohan Boddu
Modified: 2018-07-26 17:14 UTC (History)
7 users (show)

Fixed In Version: ruby-2.5.1-94.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-26 17:14:19 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2018-07-20 18:38 UTC, Mohan Boddu
no flags Details
root.log (deleted)
2018-07-20 18:38 UTC, Mohan Boddu
no flags Details
state.log (deleted)
2018-07-20 18:38 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 18:38:07 UTC
ruby failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28228587


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix ruby at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
ruby will be orphaned. Before branching of Fedora 30,
ruby will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 18:38:17 UTC
Created attachment 1467467 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 18:38:21 UTC
Created attachment 1467468 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 18:38:28 UTC
Created attachment 1467469 [details]
state.log

Comment 4 Vít Ondruch 2018-07-26 07:51:04 UTC
This is the root cause:

~~~
$ cat CMakeLists.txt 
cmake_minimum_required(VERSION 2.6)
install (FILES test.txt DESTINATION bin)

$ cmake . -DCMAKE_INSTALL_PREFIX=/tmp/test_rubygems_15764/prefix
-- The C compiler identification is GNU 8.1.1
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
CMake Error in CMakeLists.txt:
  No CMAKE_CXX_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
  to the compiler, or to the compiler name if it is in the PATH.


-- Configuring incomplete, errors occurred!
See also "/tmp/test_rubygems_15764/ext/CMakeFiles/CMakeOutput.log".
See also "/tmp/test_rubygems_15764/ext/CMakeFiles/CMakeError.log".
~~~

The question is if we should have gcc-c++ available or not. I still think we should not need it and it would be better to fix/disable this particular test, but OTOH:

https://bugs.ruby-lang.org/issues/14590


Note You need to log in before you can comment on or make changes to this bug.