Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1606435 - subscription-manager: FTBFS in Fedora rawhide
Summary: subscription-manager: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: subscription-manager
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Chris Snyder
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1595885 (view as bug list)
Depends On:
Blocks: PYTHON37 F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 19:59 UTC by Mohan Boddu
Modified: 2018-08-13 11:53 UTC (History)
7 users (show)

Fixed In Version: subscription-manager-1.23.3-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-13 11:53:02 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2018-07-20 19:59 UTC, Mohan Boddu
no flags Details
root.log (deleted)
2018-07-20 19:59 UTC, Mohan Boddu
no flags Details
state.log (deleted)
2018-07-20 19:59 UTC, Mohan Boddu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1895 0 None None None 2018-08-08 18:12:58 UTC

Description Mohan Boddu 2018-07-20 19:59:14 UTC
subscription-manager failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28235146


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix subscription-manager at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
subscription-manager will be orphaned. Before branching of Fedora 30,
subscription-manager will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 19:59:24 UTC
Created attachment 1468255 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 19:59:28 UTC
Created attachment 1468256 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 19:59:35 UTC
Created attachment 1468257 [details]
state.log

Comment 4 Miro Hrončok 2018-07-23 13:38:22 UTC
*** Bug 1595885 has been marked as a duplicate of this bug. ***

Comment 5 Chris Snyder 2018-07-23 14:07:24 UTC
@dev looks like the fix for this will be to remove our usage of the reserved word "async" from the following (located in the build.log attachment):

"""

  File "/usr/lib64/python3.7/allsubs.py", line 23
    from subscription_manager import async
                                         ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/subscription-manager-1.21.5-3.fc29.ppc64le/usr/lib64/python3.7/site-packages/subscription_manager/gui/mysubstab.py'...
  File "/usr/lib64/python3.7/mysubstab.py", line 26
    from subscription_manager.async import AsyncBind
                                  ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/subscription-manager-1.21.5-3.fc29.ppc64le/usr/lib64/python3.7/site-packages/subscription_manager/gui/registergui.py'...
  File "/usr/lib64/python3.7/registergui.py", line 248
    self.async = AsyncBackend(self.backend)
             ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/subscription-manager-1.21.5-3.fc29.ppc64le/usr/lib64/python3.7/site-packages/subscription_manager/gui/reposgui.py'...
  File "/usr/lib64/python3.7/reposgui.py", line 29
    from subscription_manager.async import AsyncRepoOverridesUpdate

"""

Comment 6 Miro Hrončok 2018-07-23 14:21:45 UTC
That would be the fix, yes. As reported in bz1595885.

Comment 7 Miro Hrončok 2018-07-25 09:26:06 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 8 Miro Hrončok 2018-08-06 10:22:06 UTC
This is another friendly reminder.

Please take action.

Comment 9 Chris Snyder 2018-08-08 18:12:59 UTC
PR with the requisite changes: https://github.com/candlepin/subscription-manager/pull/1895.

Moving to assigned while waiting for review.

Comment 10 Miro Hrončok 2018-08-13 11:53:02 UTC
Thank You.


Note You need to log in before you can comment on or make changes to this bug.