Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1632981 - Cannot commit Japanese candidates or Korean Hangul in gnome-terminal and libreoffice
Summary: Cannot commit Japanese candidates or Korean Hangul in gnome-terminal and libr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1632646 (view as bug list)
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-26 02:04 UTC by sangu
Modified: 2018-11-04 09:25 UTC (History)
17 users (show)

Fixed In Version: mutter-3.30.1-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 18:37:23 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gtk/issues/1365 0 None None None 2018-09-27 09:54:33 UTC

Description sangu 2018-09-26 02:04:17 UTC
Description of problem:
Inputting hangul marchs in place in gnome-terminal

Version-Release number of selected component (if applicable):
1.5.1-2.fc29.x86_64

How reproducible:
always

Steps to Reproduce:
1. launch gnome-terminal
2. input hangul (switch hangul, click any keys)
3.

Actual results: click rrrrrr (with ibus-hangul)


Expected results: click rrrrrr (with ibus-hangul)
ㄲㄲㄲㄲ

Additional info:
ibus-1.5.19-4.fc29.x86_64
gnome-shell-3.30.0-8.fc29.x86_64
xorg-x11-server-Xwayland-1.20.1-2.fc29.x86_64
libwayland-server-1.16.0-1.fc29.x86_64

Comment 1 Peng Wu 2018-09-26 08:03:41 UTC
Could you describe more about how to reproduce this issue?

Comment 2 fujiwara 2018-09-26 10:42:27 UTC
I think this and bug #1632646 is same.
Seems if preedit is updated before the text is committed, gtk serial numbers are different and text_input_commit_apply() is failed.

Comment 3 sangu 2018-09-26 12:06:16 UTC
(In reply to fujiwara from comment #2)
> I think this and bug #1632646 is same.
> Seems if preedit is updated before the text is committed, gtk serial numbers
> are different and text_input_commit_apply() is failed.
Yes.
When inputting with ibus-hangul, the same problem happens in libreoffice.

Comment 4 Jens Petersen 2018-10-04 03:12:12 UTC
(Note this is unrelated to bug 1628462)

Comment 5 Jens Petersen 2018-10-04 03:53:45 UTC
Proposing this as a F29 Final Blocker since it affects input
of Japanese and Korean in important applications like gnome-terminal
and libreoffice.

Comment 6 František Zatloukal 2018-10-08 17:59:34 UTC
Discussed during the 2018-10-08 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException and to punt (postpone decision) on blocker status was made:

"Punt (delay decision) on blocker, AcceptedFreezeException (Final) - this is definitely bad enough to warrant a freeze exception. We were not certain on blocker status; we would like to know if any other input methods, particularly major Chinese ones, are affected in order to be able to make a decision"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-10-08/f29-blocker-review.2018-10-08-16.00.log.txt

Comment 7 Adam Williamson 2018-10-12 19:38:46 UTC
There is now a proposed fix for this, but it seems like it was a bit too simple and may need further work:

https://gitlab.gnome.org/GNOME/gtk/merge_requests/384

Comment 8 Geoffrey Marr 2018-10-15 19:19:36 UTC
Discussed during the 2018-10-15 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as a conditional violation of the "basic functionality test" criterion when affected input methods are used, certainly including Japanese and Korean and likely also affecting some Chinese IMs.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-10-15/f29-blocker-review.2018-10-15-16.00.txt

Comment 9 fujiwara 2018-10-22 11:52:57 UTC
libreoffice calls two gtk_im_context_set_cursor_location() for one updating preedit and I will file a libreoffice bug separated from this bug after a mutter fix is landed and I'd suggest only this bug of gnome-terminal can be a blocker.

Comment 10 Kalev Lember 2018-10-22 14:12:09 UTC
Just a quick note for the status: there are several fixes being discussed for this, both in gtk+ and mutter. Carlos Garnacho is working on it and will try to land one of the fixes for this week's GNOME 3.30.2 release.

In addition to the gtk+ and mutter fixes, it's likely there's a separate libreoffice issue (https://bugzilla.redhat.com/show_bug.cgi?id=1632981#c9) that may need fixing separately.

Comment 12 Jens Petersen 2018-10-23 03:02:46 UTC
Thanks Jonas, this looks good to me so far in my inital testing.
I am able to input both Japanese (kkc) and Korean (hangul)
in a F29 Gnome Wayland session running your mutter scratch build.

Comment 13 Fedora Update System 2018-10-23 06:22:06 UTC
mutter-3.30.1-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-081ab1aeb9

Comment 14 Fedora Update System 2018-10-23 17:10:16 UTC
mutter-3.30.1-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-081ab1aeb9

Comment 15 Fedora Update System 2018-10-23 18:37:23 UTC
mutter-3.30.1-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Daiki Ueno 2018-11-04 09:25:16 UTC
*** Bug 1632646 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.