Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1635319 - error: ../../grub-core/kern/efi/mm.c:172:out of memory.
Summary: error: ../../grub-core/kern/efi/mm.c:172:out of memory.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30BetaBlocker F30BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-10-02 15:38 UTC by Mikhail
Modified: 2019-07-21 20:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-06 20:20:40 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
photo of monitor with broken grub screen (deleted)
2018-10-02 15:38 UTC, Mikhail
no flags Details

Description Mikhail 2018-10-02 15:38:04 UTC
Created attachment 1489498 [details]
photo of monitor with broken grub screen

Description of problem:
error: ../../grub-core/kern/efi/mm.c:172:out of memory.
error: ../../grub-core/loader/i386/efi/linux.c:201:you need to load the kernel first.

Press any key to continue...

Version-Release number of selected component (if applicable):
2.02-59.fc30

Last workable version:
2.02-58.fc30


Steps to Reproduce:
1. Update to 2.02-59.fc30 version
2. Reboot
3.

Actual results:
System unbotable

Expected results:
System is bootable

Comment 1 Fedora Blocker Bugs Application 2018-10-02 15:39:17 UTC
Proposed as a Blocker and Freeze Exception for 30-beta by Fedora user mikhail using the blocker tracking app because:

 System unbootable

Comment 2 Adam Williamson 2018-10-02 16:18:25 UTC
I already reported this to pjones yesterday, he said he knew what it was and would fix it.

Comment 3 Mikhail 2018-10-06 12:12:04 UTC
Today grub2 was updated to 2.02-62.fc30 version this problem not observed anymore.

Comment 4 Adam Williamson 2018-10-06 20:20:40 UTC
yep, openQA also confirms this is fixed now (netinst tests failed as they got older grub from previous compose, but other tests passed).

Comment 5 Phil Regier 2019-07-21 20:59:48 UTC
Getting exactly the same error booting the F30 release .iso from getfedora.org imaged to a USB key.


Note You need to log in before you can comment on or make changes to this bug.