Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1683189 - [abrt] gnome-remote-desktop: handle_socket_data(): gnome-remote-desktop-daemon killed by SIGABRT
Summary: [abrt] gnome-remote-desktop: handle_socket_data(): gnome-remote-desktop-daemo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-remote-desktop
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonas Ådahl
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c10204843e4a20c4e2815fc0883...
: 1764211 (view as bug list)
Depends On:
Blocks: F30FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-02-26 12:28 UTC by Alessio
Modified: 2019-10-22 13:26 UTC (History)
7 users (show)

Fixed In Version: gnome-remote-desktop-0.1.7-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-04 18:01:57 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: cgroup (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: core_backtrace (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: cpuinfo (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: dso_list (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: environ (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: limits (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: maps (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: mountinfo (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: open_fds (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details
File: proc_pid_status (deleted)
2019-02-26 12:28 UTC, Alessio
no flags Details

Description Alessio 2019-02-26 12:28:10 UTC
Version-Release number of selected component:
gnome-remote-desktop-0.1.6-3.fc30

Additional info:
reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-remote-desktop-daemon
crash_function: handle_socket_data
executable:     /usr/libexec/gnome-remote-desktop-daemon
journald_cursor: s=cdbb55224b3145b8b88e48d5256fa4f1;i=d3b;b=7479f69095de40088c6cdc7e2e0a3283;m=5762add3;t=582c9a907ddea;x=6c9f0a848f0e7754
kernel:         5.0.0-0.rc7.git1.1.fc30.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 1641368

Comment 1 Alessio 2019-02-26 12:28:13 UTC
Created attachment 1538793 [details]
File: backtrace

Comment 2 Alessio 2019-02-26 12:28:14 UTC
Created attachment 1538794 [details]
File: cgroup

Comment 3 Alessio 2019-02-26 12:28:15 UTC
Created attachment 1538795 [details]
File: core_backtrace

Comment 4 Alessio 2019-02-26 12:28:17 UTC
Created attachment 1538796 [details]
File: cpuinfo

Comment 5 Alessio 2019-02-26 12:28:18 UTC
Created attachment 1538797 [details]
File: dso_list

Comment 6 Alessio 2019-02-26 12:28:19 UTC
Created attachment 1538798 [details]
File: environ

Comment 7 Alessio 2019-02-26 12:28:20 UTC
Created attachment 1538799 [details]
File: limits

Comment 8 Alessio 2019-02-26 12:28:21 UTC
Created attachment 1538800 [details]
File: maps

Comment 9 Alessio 2019-02-26 12:28:22 UTC
Created attachment 1538801 [details]
File: mountinfo

Comment 10 Alessio 2019-02-26 12:28:23 UTC
Created attachment 1538802 [details]
File: open_fds

Comment 11 Alessio 2019-02-26 12:28:24 UTC
Created attachment 1538803 [details]
File: proc_pid_status

Comment 12 Alessio 2019-02-27 10:13:13 UTC
Similar problem has been detected:

It seems to happens after closing the vnc client on remote host

reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-remote-desktop-daemon
crash_function: handle_socket_data
executable:     /usr/libexec/gnome-remote-desktop-daemon
journald_cursor: s=f968c072c5e14ea9a888be5afcdcdaeb;i=2b4d;b=2a868fd58c2e49f08068ccc78eaece9d;m=4bc89a5ec;t=582dd6459ea3f;x=430014d133626a3
kernel:         5.0.0-0.rc7.git1.1.fc30.x86_64
package:        gnome-remote-desktop-0.1.6-3.fc30
reason:         gnome-remote-desktop-daemon killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Alessio 2019-03-04 11:55:12 UTC
*** Bug 1683674 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Blocker Bugs Application 2019-03-04 12:01:03 UTC
Proposed as a Blocker for 30-final by Fedora user alciregi using the blocker tracking app because:

 IMO it violates the "Default panel functionality"

Comment 15 Alessio 2019-03-04 15:31:15 UTC
Installing gnome-remote-desktop-0.1.7-1.fc30 the issue doesn't appear anymore.

Thanks.

Comment 16 Adam Williamson 2019-03-04 18:01:57 UTC
OK, that build is tagged f30, so will be in the next compose. Let's close this as fixed. Thanks!

Comment 17 Evan H. 2019-07-01 01:59:24 UTC
Similar problem has been detected:

I just received a notification on the Fedora desktop.

reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-remote-desktop-daemon
crash_function: handle_socket_data
executable:     /usr/libexec/gnome-remote-desktop-daemon
journald_cursor: s=fd8dfed5d44942dcbf4eb664cf860a0b;i=13eea;b=6b69dd69c00c48baab696273b46e616c;m=36810a38;t=58c9329e13bc8;x=15c201177748ed60
kernel:         5.1.15-300.fc30.x86_64
package:        gnome-remote-desktop-0.1.7-1.fc30
reason:         gnome-remote-desktop-daemon killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 18 znert.trent 2019-10-22 13:26:10 UTC
*** Bug 1764211 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.