Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1708960 - [abrt] solaar: update(): window.py:774:update:AssertionError
Summary: [abrt] solaar: update(): window.py:774:update:AssertionError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: solaar
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bf5c6f0846ef474fa293699b3f0...
Depends On:
Blocks: 1731545
TreeView+ depends on / blocked
 
Reported: 2019-05-12 00:37 UTC by Peter Larsen
Modified: 2019-11-01 01:29 UTC (History)
7 users (show)

Fixed In Version: solaar-1.0.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-06 12:32:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (465 bytes, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details
File: cgroup (331 bytes, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details
File: cpuinfo (1.47 KB, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details
File: environ (3.79 KB, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details
File: mountinfo (4.40 KB, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details
File: namespaces (129 bytes, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details
File: open_fds (1.05 KB, text/plain)
2019-05-12 00:37 UTC, Peter Larsen
no flags Details

Description Peter Larsen 2019-05-12 00:37:32 UTC
Description of problem:
Initial login after upgrading display/video module setup (doesn't seem releated to me).

Version-Release number of selected component:
solaar-0.9.2-11.20180813gitf0fc63e.fc30

Additional info:
reporter:       libreport-2.10.0
cmdline:        /usr/bin/python3 -s /usr/bin/solaar
crash_function: update
exception_type: AssertionError
executable:     /usr/bin/solaar
interpreter:    python3-3.7.3-1.fc30.x86_64
kernel:         5.0.13-300.fc30.x86_64
runlevel:       unknown
type:           Python3
uid:            1000

Truncated backtrace:
window.py:774:update:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/solaar/ui/__init__.py", line 165, in _status_changed
    window.update(device, need_popup)
  File "/usr/lib/python3.7/site-packages/solaar/ui/window.py", line 774, in update
    assert item
AssertionError

Local variables in innermost frame:
device: <UnifyingReceiver(/dev/hidraw2,15)>
need_popup: 0
selected_device_id: None
is_alive: False
item: None

Potential duplicate: bug 1658412

Comment 1 Peter Larsen 2019-05-12 00:37:36 UTC
Created attachment 1567391 [details]
File: backtrace

Comment 2 Peter Larsen 2019-05-12 00:37:38 UTC
Created attachment 1567392 [details]
File: cgroup

Comment 3 Peter Larsen 2019-05-12 00:37:40 UTC
Created attachment 1567393 [details]
File: cpuinfo

Comment 4 Peter Larsen 2019-05-12 00:37:43 UTC
Created attachment 1567394 [details]
File: environ

Comment 5 Peter Larsen 2019-05-12 00:37:45 UTC
Created attachment 1567395 [details]
File: mountinfo

Comment 6 Peter Larsen 2019-05-12 00:37:46 UTC
Created attachment 1567396 [details]
File: namespaces

Comment 7 Peter Larsen 2019-05-12 00:37:48 UTC
Created attachment 1567397 [details]
File: open_fds

Comment 8 Martin Tessun 2019-06-21 18:05:09 UTC
Similar problem has been detected:

After Login Solaar crashes. After restarting it manually it works, but does sometimes only see one device (instead of two) connected to the unifying receiver.

reporter:       libreport-2.10.0
cmdline:        /usr/bin/python3 -s /usr/bin/solaar
crash_function: update
exception_type: AssertionError
executable:     /usr/bin/solaar
interpreter:    python3-3.7.3-3.fc30.x86_64
kernel:         5.1.11-300.fc30.x86_64
package:        solaar-0.9.2-11.20180813gitf0fc63e.fc30
reason:         window.py:774:update:AssertionError
runlevel:       N 5
type:           Python3
uid:            2053

Comment 9 Jason Tibbitts 2019-06-21 20:27:59 UTC
Solaar isn't really going anywhere upstream.  There are a trickle of commits, which I guess I can pull into the Fedora package, but they don't look like any of them would have any bearing on the majority of the reported issues.

I think I'm going to go ahead and retire it.  It can always come back if things start moving again upstream.

Comment 10 Fedora Update System 2019-08-27 14:25:21 UTC
FEDORA-2019-c00c923eba has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c00c923eba

Comment 11 Fedora Update System 2019-08-30 00:04:19 UTC
solaar-1.0.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c00c923eba

Comment 12 Fedora Update System 2019-09-06 12:32:33 UTC
solaar-1.0.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 bugzilla.redhat.com@mno.pw 2019-11-01 01:29:33 UTC
*** Bug 1767676 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.