Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1723242 - crash when installing flatpak
Summary: crash when installing flatpak
Keywords:
Status: CLOSED DUPLICATE of bug 1697566
Alias: None
Product: Fedora
Classification: Fedora
Component: curl
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-24 01:04 UTC by Chris Murphy
Modified: 2019-07-12 12:51 UTC (History)
9 users (show)

Fixed In Version: curl-7.64.0-8.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-06 04:09:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
gnome-software --verbose (deleted)
2019-06-24 01:05 UTC, Chris Murphy
no flags Details
coredumpctl gdb flatpak (deleted)
2019-06-24 04:03 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2019-06-24 01:04:27 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always (8 for 8 so far)


Steps to Reproduce:
1. Enable flaghub.org repo
2. Gnome-Software search for and try to install Slack 
3.

Actual results:

Crash

Expected results:

No crash. If there's something wrong with the remote, then there should be an appropriate error message.

Additional info:

Comment 1 Chris Murphy 2019-06-24 01:05:01 UTC
Created attachment 1583801 [details]
gnome-software --verbose

Comment 2 Chris Murphy 2019-06-24 01:08:01 UTC
abrt is of no use in helping to report this, it says for this crash "Reporting is disabled because the generated backtrace has low informational value"

It took nearly 30 minutes for the abrt+retrace server to come to that conclusion.

$ coredumpctl
TIME                            PID   UID   GID SIG COREFILE  EXE
Sun 2019-06-23 18:57:46 MDT    4953  1000  1000  11 present   /usr/bin/gnome-software
[chris@flap ~]$ coredumpctl info 4953
           PID: 4953 (gnome-software)
           UID: 1000 (chris)
           GID: 1000 (chris)
        Signal: 11 (SEGV)
     Timestamp: Sun 2019-06-23 18:57:44 MDT (9min ago)
  Command Line: gnome-software --verbose
    Executable: /usr/bin/gnome-software
 Control Group: /user.slice/user-1000.slice/user/gnome-terminal-server.service
          Unit: user
     User Unit: gnome-terminal-server.service
         Slice: user-1000.slice
     Owner UID: 1000 (chris)
       Boot ID: 46e170c2589f498bac3c52e884dd591a
    Machine ID: ce3f1eade82d42bd891a8c15714b13cf
      Hostname: flap.local
       Storage: /var/lib/systemd/coredump/core.gnome-software.1000.46e170c2589f498bac3c52e884dd591a.4953.1561337864000000.lz4
       Message: Process 4953 (gnome-software) of user 1000 dumped core.
                
                Stack trace of thread 5033:
                #0  0x00007f3a252ec764 n/a (libcurl.so.4)
                #1  0x00007f3a252eca3b curl_multi_socket_action (libcurl.so.4)
                #2  0x00007f3a253ec37a n/a (libostree-1.so.1)
                #3  0x00007f3a3747cedd g_main_context_dispatch (libglib-2.0.so.0)
                #4  0x00007f3a3747d270 n/a (libglib-2.0.so.0)
                #5  0x00007f3a3747d313 g_main_context_iteration (libglib-2.0.so.0)
                #6  0x00007f3a253b37da ostree_repo_pull_with_options (libostree-1.so.1)
                #7  0x00007f3a25501a6c n/a (libflatpak.so.0)
                #8  0x00007f3a2551a18c n/a (libflatpak.so.0)
                #9  0x00007f3a25526f53 n/a (libflatpak.so.0)
                #10 0x00007f3a2553d1f2 n/a (libflatpak.so.0)
                #11 0x00007f3a255da5b7 gs_flatpak_transaction_run (libgs_plugin_flatpak.so)
                #12 0x00007f3a255dc614 gs_plugin_app_install (libgs_plugin_flatpak.so)
                #13 0x000055f32b6ced42 n/a (gnome-software)
                #14 0x000055f32b6cf372 n/a (gnome-software)
                #15 0x000055f32b6d0838 n/a (gnome-software)
                #16 0x000055f32b6d0e66 n/a (gnome-software)
                #17 0x00007f3a374a6f14 n/a (libglib-2.0.so.0)
                #18 0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #19 0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #20 0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 4953:
                #0  0x00007f3a364d65c7 __poll (libc.so.6)
                #1  0x00007f3a3747d1de n/a (libglib-2.0.so.0)
                #2  0x00007f3a3747d313 g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f3a37334485 g_application_run (libgio-2.0.so.0)
                #4  0x000055f32b66f49d main (gnome-software)
                #5  0x00007f3a36409f33 __libc_start_main (libc.so.6)
                #6  0x000055f32b66f54e _start (gnome-software)
                
                Stack trace of thread 4954:
                #0  0x00007f3a364d65c7 __poll (libc.so.6)
                #1  0x00007f3a3747d1de n/a (libglib-2.0.so.0)
                #2  0x00007f3a3747d313 g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f3a3747d361 n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 4955:
                #0  0x00007f3a364d65c7 __poll (libc.so.6)
                #1  0x00007f3a3747d1de n/a (libglib-2.0.so.0)
                #2  0x00007f3a3747d5a3 g_main_loop_run (libglib-2.0.so.0)
                #3  0x00007f3a3736fd5a n/a (libgio-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5112:
                #0  0x00007f3a365bdb4f __write (libpthread.so.0)
                #1  0x00007f3a253f758e n/a (libostree-1.so.1)
                #2  0x00007f3a2539e6cf n/a (libostree-1.so.1)
                #3  0x00007f3a253a09bb n/a (libostree-1.so.1)
                #4  0x00007f3a253a342d ostree_repo_write_content (libostree-1.so.1)
                #5  0x00007f3a253a34f2 n/a (libostree-1.so.1)
                #6  0x00007f3a372f279d n/a (libgio-2.0.so.0)
                #7  0x00007f3a372d8aee n/a (libgio-2.0.so.0)
                #8  0x00007f3a373078f7 n/a (libgio-2.0.so.0)
                #9  0x00007f3a374a6f14 n/a (libglib-2.0.so.0)
                #10 0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #11 0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #12 0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 4957:
                #0  0x00007f3a364d65c7 __poll (libc.so.6)
                #1  0x00007f3a3747d1de n/a (libglib-2.0.so.0)
                #2  0x00007f3a3747d313 g_main_context_iteration (libglib-2.0.so.0)
                #3  0x00007f3a3765ea9d n/a (libdconfsettings.so)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5092:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5106:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5093:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5078:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5113:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5095:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5101:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5100:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a374a706a n/a (libglib-2.0.so.0)
                #4  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #5  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #6  0x00007f3a364e1303 __clone (libc.so.6)
                
                Stack trace of thread 5103:
                #0  0x00007f3a364dbfad syscall (libc.so.6)
                #1  0x00007f3a374c8f4e g_cond_wait_until (libglib-2.0.so.0)
                #2  0x00007f3a3744e031 n/a (libglib-2.0.so.0)
                #3  0x00007f3a3744e656 g_async_queue_timeout_pop (libglib-2.0.so.0)
                #4  0x00007f3a374a6fb9 n/a (libglib-2.0.so.0)
                #5  0x00007f3a374a64e2 n/a (libglib-2.0.so.0)
                #6  0x00007f3a365b45a2 start_thread (libpthread.so.0)
                #7  0x00007f3a364e1303 __clone (libc.so.6)
lines 133-173/173 (END)

Comment 3 Chris Murphy 2019-06-24 01:15:14 UTC
gnome-software-3.32.3-1.fc30.x86_64
ostree-2019.2-1.fc30.x86_64
flatpak-1.4.1-1.fc30.x86_64

Comment 5 Chris Murphy 2019-06-24 01:17:56 UTC
Also, this system had a clean install of Fedora 30 today using netinstall. So it only ever had these versions, and no crusty remnants from previous installations.

Comment 6 Chris Murphy 2019-06-24 01:30:51 UTC
$ flatpak install --from com.slack.Slack.flatpakref

This also fails and it looks like it's flatpak crashing all along which in turn crashes gnome-software. Sooo, two bugs. Because neither of them should crash.

Comment 7 Chris Murphy 2019-06-24 04:03:53 UTC
Created attachment 1583851 [details]
coredumpctl gdb flatpak

Process the flatpak crash with gdb via coredumpctl

Comment 8 Chris Murphy 2019-06-24 04:13:54 UTC
So after spending 3 hours downloading and installing all the debuginfos and running it through abrt again locally, it says this is a dup of bug 1697566.

If I can download a bagillion debug symbols and locally figure out there's a dup, why can't the faf server figure that out?

Comment 9 Kalev Lember 2019-06-24 06:37:19 UTC
Can you file this in https://github.com/flatpak/flatpak to get some upstream attention to the crash, please? gnome-software just uses libflatpak here that crashes and that shouldn't happen.

Comment 10 Chris Murphy 2019-06-24 14:59:33 UTC
https://github.com/flatpak/flatpak/issues/2977

I still think it's a separate bug when a GUI application lacks sufficient error handling that it crashes when something it depends on crashes.

Comment 11 Chris Murphy 2019-06-30 15:52:55 UTC
https://github.com/flatpak/flatpak/issues/2977 has been updated, looks like it's actually libcurl that's crashing in both the gnome-software and flatpak cases, fixed in libcurl 7.65. I'm going to switch this bug to libcurl.

Comment 12 Kamil Dudka 2019-07-01 07:26:40 UTC
Thanks for the report!  I will backport the upstream fix.

Comment 13 Kamil Dudka 2019-07-01 09:12:28 UTC
dist-git commit: https://src.fedoraproject.org/rpms/curl/c/0c07534e

Comment 14 Fedora Update System 2019-07-01 09:54:35 UTC
FEDORA-2019-eeae54025e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-eeae54025e

Comment 15 Fedora Update System 2019-07-03 02:26:20 UTC
curl-7.64.0-8.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-eeae54025e

Comment 16 Fedora Update System 2019-07-06 04:09:24 UTC
curl-7.64.0-8.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Mark Pariente 2019-07-11 05:16:23 UTC
The issue still persists for me on curl-7.64.0-8.fc30.x86_64. On one of my machines flatpak update / flatpak install results in 100% segmentation fault. According to https://github.com/flatpak/flatpak/issues/2977 the curl issue is fixed in version 7.65.1 - so we'd need that version in fedora 30.

Comment 18 Michael Catanzaro 2019-07-12 12:49:37 UTC
Clearly it's not fixed, but it's not helpful to have so many issues for a single problem. Let's continue in bug #1697566.

*** This bug has been marked as a duplicate of bug 1697566 ***

Comment 19 Michael Catanzaro 2019-07-12 12:51:17 UTC
(In reply to Mark Pariente from comment #17)
> The issue still persists for me on curl-7.64.0-8.fc30.x86_64. On one of my
> machines flatpak update / flatpak install results in 100% segmentation
> fault. According to https://github.com/flatpak/flatpak/issues/2977 the curl
> issue is fixed in version 7.65.1 - so we'd need that version in fedora 30.

That patch is already in curl-7.64.0-8.fc30, and the bug has been confirmed to still exist in 7.65.1.


Note You need to log in before you can comment on or make changes to this bug.