Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1725167 - Popup UI element disappears on dropdown activation
Summary: Popup UI element disappears on dropdown activation
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2019-06-28 14:58 UTC by Adam Chasen
Modified: 2019-07-02 08:26 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-02 08:26:02 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
popup disappears (deleted)
2019-06-28 14:58 UTC, Adam Chasen
no flags Details
Incorrectly scaled bookmark drop down menu (deleted)
2019-07-01 08:40 UTC, Jan Vlug
no flags Details

Description Adam Chasen 2019-06-28 14:58:25 UTC
Created attachment 1585672 [details]
popup disappears

Description of problem:
Popup/tooltip UI element (not website) disappears upon activation of dropdown menu. The example is using the bitwarden extension, but I recall this affecting other popups as well (just cannot recall).

Version-Release number of selected component (if applicable):
firefox-wayland-67.0.4-1.fc30.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install bitwarden extension
2. activate popup using toolbar icon
3. add an entry
4. activate a dropdown selector

Actual results:
popup disappears, but dropdown selector is drawn in correct location


Expected results:
dropdown selector is drawn and popup remains visibile

Additional info:
video attached

Comment 1 Martin Stransky 2019-06-29 07:43:24 UTC
Yes, it's fixed upstream in Firefox 69 (nightly).

Comment 2 Martin Stransky 2019-07-01 06:21:12 UTC
btw. can you try latest nightly? how-to is here: https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Testing_Mozilla_binaries
Thanks.

Comment 3 Jan Vlug 2019-07-01 08:38:51 UTC
The drop drop down does not disappear any more in 69.0a1 (2019-06-30) (64-bit) nightly.
But it is sometimes incorrectly scaled. See attached screenshot.

Comment 4 Jan Vlug 2019-07-01 08:40:26 UTC
Created attachment 1586195 [details]
Incorrectly scaled bookmark drop down menu

I also see some SELinux messages when using Firefox nightly. I do not know whether this is related.

Comment 5 Jan Vlug 2019-07-01 09:45:41 UTC
This is the SELinux issue: bug 1723308

Comment 6 Adam Chasen 2019-07-01 20:33:37 UTC
The issue was not present on nightlies. I was also unable to reproduce in non-wayland firefox. I believe the nightly is a non-wayland firefox as well.

Comment 7 Jan Vlug 2019-07-01 21:00:22 UTC
Start the nightly with the following command to run with Wayland backend:
MOZ_ENABLE_WAYLAND=1 ./firefox -Profilemanager

Comment 8 Adam Chasen 2019-07-01 21:08:07 UTC
confirmed fixed in window started with MOZ_ENABLE_WAYLAND=1 ./firefox -Profilemanager

Comment 9 Martin Stransky 2019-07-02 08:26:02 UTC
Great, Thanks. That will come in Firefox 68 or 69.


Note You need to log in before you can comment on or make changes to this bug.