Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1728065 - python-zope-contenttype fails to build with Python 3.8
Summary: python-zope-contenttype fails to build with Python 3.8
Alias: None
Product: Fedora
Classification: Fedora
Component: python-zope-contenttype
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: F32FTBFS F32FailsToInstall PYTHON38
TreeView+ depends on / blocked
Reported: 2019-07-08 23:26 UTC by Miro Hrončok
Modified: 2019-09-22 20:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-09-22 20:41:33 UTC
Type: Bug

Attachments (Terms of Use)

Description Miro Hrončok 2019-07-08 23:26:22 UTC
python-zope-contenttype fails to build with Python 3.8.0b1.

+ /usr/bin/python3 build '--executable=/usr/bin/python3 -s'
Traceback (most recent call last):
  File "/builddir/build/BUILD/wand-0.5.2/wand/", line 137, in <module>
    libraries = load_library()
  File "/builddir/build/BUILD/wand-0.5.2/wand/", line 126, in load_library
    raise IOError('cannot find library; tried paths: ' + repr(tried_paths))
OSError: cannot find library; tried paths: []

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "", line 8, in <module>
    from wand.version import VERSION
  File "/builddir/build/BUILD/wand-0.5.2/wand/", line 45, in <module>
    from .api import libmagick, library
  File "/builddir/build/BUILD/wand-0.5.2/wand/", line 155, in <module>
    distname, _, __ = platform.linux_distribution()
AttributeError: module 'platform' has no attribute 'linux_distribution'
error: Bad exit status from /var/tmp/rpm-tmp.ez1Ult (%build)

platform.linux_distribution has been deprecated since version 3.5, and was removed in version 3.8: See alternative like the distro package.

For the build logs, see:

For all our attempts to build python-zope-contenttype with Python 3.8, see:

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.8:

Let us know here if you have any questions.

Comment 1 Miro Hrončok 2019-07-30 15:04:28 UTC
Ralph? Could you have a look please?

Comment 2 Miro Hrončok 2019-08-05 11:02:41 UTC
Package orphaned.

Comment 3 Ben Cotton 2019-08-13 16:57:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 4 Ben Cotton 2019-08-13 18:33:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 5 Miro Hrončok 2019-08-14 22:24:34 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.

PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 6 Miro Hrončok 2019-08-21 16:35:19 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32

If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-


(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 7 Miro Hrončok 2019-08-21 17:29:22 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 8 Miro Hrončok 2019-09-22 20:41:33 UTC
This package was retired.

Note You need to log in before you can comment on or make changes to this bug.