Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1740811 - Ship BerkleyDB backend as a module
Summary: Ship BerkleyDB backend as a module
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Pichugin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-13 16:26 UTC by Ben Cotton
Modified: 2022-02-08 23:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-08 21:59:17 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Ben Cotton 2019-08-13 16:26:38 UTC
This is a tracking bug for Change: Ship BerkleyDB backend as a module
For more details, see: https://fedoraproject.org/wiki/Changes/OpenLDAPwithBerkleyDBasModule

Change the openldap-servers package so that BDB and HDB backends are required to be dynamically loaded.

Comment 1 Ben Cotton 2019-08-27 17:17:55 UTC
We have reached the '100% Code Complete' milestone in the Fedora 31 release cycle. If your Change is complete, please set the status to ON_QA. The Beta Freeze is underway. If you need a freeze exception, see https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

If this Change will not be ready for Fedora 31, please set the version to rawhide.

Comment 2 Miro Hrončok 2019-09-02 08:38:16 UTC
I see no relevant change in the openldap package.

Comment 3 Matus Honek 2019-09-02 11:12:20 UTC
Due to my limited time dispositions the change has not been effectuated. I'm moving the change to rawhide.

Comment 4 Ben Cotton 2020-02-13 17:36:18 UTC
Branched for F32

Comment 5 Matus Honek 2020-02-21 13:39:42 UTC
Once again, unfortunately, the work has not been fulfilled, so I am moving this to rawhide in order to deliver this in the next Fedora version.

Comment 6 Ben Cotton 2020-08-11 13:10:39 UTC
Branching F33 Change Tracker bugs.

Today is the code complete (testable) deadline. All bugs should be at least in MODIFIED state by now to indicate they are testable.

Comment 7 Ben Cotton 2020-08-22 00:54:24 UTC
Deferred to F34 by FESCO

Comment 9 Ben Cotton 2021-02-10 21:42:45 UTC
We have reached the 'Code Complete (testable)' milestone in the Fedora 34 release cycle. If your Change is in a testable state, please set the status to MODIFIED. If this Change will not be ready for Fedora 34, please set the version to rawhide.

The 100% code complete deadline is Tue 2021-02-23.

Comment 10 Ben Cotton 2021-08-10 12:32:45 UTC
Today is the "Code complete (testable)" deadline in the Fedora Linux 35 release schedule:
https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

If this Change is complete enough to be tested, please indicate this by setting this bug to the MODIFIED status. (If it is 100% complete, you can set it to ON_QA).

If you wish to defer this Change to Fedora Linux 36, please needinfo bcotton.

Comment 11 Simon Pichugin 2021-08-11 16:15:26 UTC
Hi Ben,
yes, please, defer this Change to Fedora 36.

The reason for that is the new OpenLDAP 2.5 version which doesn't have BerkleyDB.
So we will work in that direction as we'd like to be in sync with Upstream.

Thank you!

Comment 12 Ben Cotton 2022-02-08 21:07:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 36 development cycle.
Changing version to 36.

Comment 13 Ben Cotton 2022-02-08 21:15:06 UTC
Today we reached the Code Complete (testable) milestone in the F36 schedule: https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

All code for this change should be complete enough for testing. You can indicate this by setting the bug status to MODIFIED. (If the code is fully complete, you can go ahead and set it to ON_QA.)

If you need to defer this Change to F37, please needinfo bcotton.

Comment 14 Simon Pichugin 2022-02-08 21:59:17 UTC
The issue is not relevant anymore as BerkeleyDB was fully removed in OpenLDAP 2.6 which is planned for Fedora 36.
https://bugzilla.redhat.com/show_bug.cgi?id=2021662


Note You need to log in before you can comment on or make changes to this bug.