Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 174440 - Review Request: bakery - C++ framework for creating GNOME apps
Summary: Review Request: bakery - C++ framework for creating GNOME apps
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: John Mahowald
QA Contact: David Lawrence
Depends On:
TreeView+ depends on / blocked
Reported: 2005-11-29 02:32 UTC by Denis Leroy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-03-05 19:44:29 UTC
Type: ---

Attachments (Terms of Use)

Description Denis Leroy 2005-11-29 02:32:51 UTC
Spec Name or Url:
SRPM Name or Url:

Bakery is a C++ Framework for creating GNOME applications using gtkmm. Bakery provides a Document/View architecture, but it doesn't force you to use the whole architecture. Bakery can use XML as a Document storage format, if you like. Bakery provides default functionality, which can be easily customized, makes it easy to start developing GNOME applications and gives your application structure. Bakery also contains a few utility classes.

Note: this is targeted at FC-4 and FC-5.

Comment 1 Michael A. Peters 2005-11-29 02:50:00 UTC
Not a review - but this is wrong:

* Mon Nov 28 2005 Denis Leroy <denis> - 2.3.%{minor_version}-1

That will cause the %{minor_version} to be expanded in that line to a new
version when minor_version is updated - creating an incorrect changelog.

Comment 2 Denis Leroy 2005-11-29 03:44:14 UTC
Yikes, absolutely! Interesting xemacs "bug".


Comment 3 Jochen Schmitt 2006-02-22 17:56:50 UTC
+ rpmlint of srpm ok.
+ Local build worked fine.

- rpmlint of rpms complaints:

rpmlint bakery-2.3.15-2.i686.rpm
W: bakery incoherent-version-in-changelog 2.3.15-1 2.3.15-2

rpmlint bakery-devel-2.3.15-2.i686.rpm
W: bakery-devel doc-file-dependency
/usr/share/doc/bakery-devel-2.3.15/reference/html/installdox /usr/bin/perl

- Requires to /sbin/ldconfig are not requires.
- Requires to perl missing.
- Mock build failed:

checking pkg-config is at least version 0.9.0... yes
checking for BAKERY_CFLAGS...
checking for BAKERY_LIBS...
configure: error: Package requirements (gtkmm-2.4 >= 2.6.0 gconfmm-2.6 >= 2.6.0
libglademm-2.4 >= 2.4.0 libxml++-2.6 >= 2.8.0 gnome-vfsmm-2.6 >= 2.6.0) were not
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BAKERY_CFLAGS and BAKERY_LIBS environment variable
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
error: Bad exit status from /var/tmp/rpm-tmp.97468 (%build)

Comment 4 Denis Leroy 2006-03-01 22:21:34 UTC

- ldconfig deps removed
- fixed changelog
- fixed incorect gnome-vfsmm buildrequires
- worked around perl dep problem
- builds cleanly in mock

The '/usr/bin/perl' warning is interesting, since the Perl package provides
'perl', not '/usr/bin/perl'... I worked around the problem, the offending file
was only needed during doc build.

Comment 5 John Mahowald 2006-03-04 18:23:42 UTC
* When creating the docs, this happened a few times:
sh: dot: command not found
Problems running dot. Check your installation!

Add graphviz as a BuildRequires and it should work.

* BuildRequires: gettext is missing (required by the %find_lang macro)

Comment 6 Denis Leroy 2006-03-04 21:09:02 UTC

- Update to 2.3.17 (bugfixes, more translations)
- Fixed graphviz and gettext BuildRequires
- clean mock build
- clean rpmlint

Comment 7 John Mahowald 2006-03-05 09:01:19 UTC

- rpmlint checks return:

W: bakery-debuginfo objdump-failed
Executing objdump on this file failed, all checks could not be run.
Not critical

E: bakery-devel only-non-binary-in-usr-lib
There are only non binary files in /usr/lib so they should be in /usr/share.
False alarm, symlink.

- package meets naming guidelines
- package meets packaging guidelines
- license (GPL) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream
- package compiles on devel (x86_64)
- no missing BR
- no unnecessary BR
- locales handled by %find_lang
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file

- devel package ok
- no .la files
- post/postun ldconfig ok
- devel requires base package n-v-r 


Comment 8 Denis Leroy 2006-03-05 19:44:29 UTC
Imported and built.

Note You need to log in before you can comment on or make changes to this bug.