Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 175500 - Review Request: compat-wxGTK & compat-wxPythonGTK2
Summary: Review Request: compat-wxGTK & compat-wxPythonGTK2
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: David Lawrence
Depends On:
Blocks: 154618 FE-ACCEPT
TreeView+ depends on / blocked
Reported: 2005-12-11 23:47 UTC by Tom "spot" Callaway
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-04-19 21:40:48 UTC
Type: ---

Attachments (Terms of Use)
Spec file patch (deleted)
2005-12-19 17:06 UTC, Matthias Saou
no flags Details | Diff
Spec file patch (deleted)
2005-12-19 17:27 UTC, Matthias Saou
no flags Details | Diff

Description Tom "spot" Callaway 2005-12-11 23:47:46 UTC
Spec Name or Url:

SRPM Name or Url:


These are the compat packages for wx 2.4, based off the already approved packages in Fedora Extras. Infact, other than the name change, the only difference is that some binaries have been removed (because they conflict with the 2.6 binaries) and that wx-config is now wx-2.4-config. Applications needing to use the compat-wx* packages will need to be modified to call wx-2.4-config instead of wx-config.

wxWidgets/GTK is the GTK+ (1.2) port of the C++ cross-platform wxWidgets
GUI library, offering classes for all common GUI controls as well as a
comprehensive set of helper classes for most common application tasks,
ranging from networking to HTML display and image manipulation.

wxPython is a GUI toolkit for the Python programming language. It allows
Python programmers to create programs with a robust, highly functional
graphical user interface, simply and easily. It is implemented as a Python
extension module (native code) that wraps the popular wxWindows cross
platform GUI library, which is written in C++.

Comment 1 Matthias Saou 2005-12-12 11:35:52 UTC
These look pretty good (apart from the added tabs, when the spec files used
spaces ;-)). Have you tried to modify and build some applications using them?
(just to know if it'll be easy or not), like audacity for instance?

If no one else steps up, I wouldn't mind reviewing the packages, but I'll
need to do some further testing.

Comment 2 Matthew Miller 2005-12-15 17:56:28 UTC
Matthias -- by all means, please review. :)

Comment 3 Matthias Saou 2005-12-19 17:03:35 UTC
Packages that will need to have their spec file updated for the change :
- audacity
- bochs
- comical
- pgadmin3
- scorched3d

I've only tested a rebuild of audacity, and it worked fine changing just :
- The BuildRequires to add "compat-"
- The %build section to add just before the %configure line :
  export WX_CONFIG="%{_bindir}/wx-2.4-config"

Please consider applying the spec file patch I'll attach as it fixes many
minor cosmetic issues in the spec file. It also changes to 755 the mode of
the %ghost'ed script, so that rpmlint stops complaining.

Comment 4 Matthias Saou 2005-12-19 17:06:15 UTC
Created attachment 122410 [details]
Spec file patch

Comment 5 Matthias Saou 2005-12-19 17:27:56 UTC
Created attachment 122411 [details]
Spec file patch

Comment 6 Matthias Saou 2005-12-19 17:29:54 UTC
Since the patches only contain minor changes, I already approve both packages.

Comment 7 Matthias Saou 2006-02-24 16:34:19 UTC
I see these have been imported, but only compat-wxGTK bas been built in FC5, is
that wanted? What about FC4?

Comment 8 Michael Schwendt 2006-03-17 20:13:23 UTC
There's a conflict in the virtual Provides of the published packages!

Currently both  wxGTK-devel  and  compat-wxGTK2-devel  as well as
wxGTK  and  compat-wxGTK2  contain

  "Provides: wxGTK2-devel = some version"
  "Provides: wxGTK2 = some version"

This makes them competing packages. You cannot do this, as wxGTK and
compat-wxGTK2 are _not_ equivalent. It causes RPM to let the newer
version win, which results in removal of the packages with the older
versions during installation or in a failed transaction check.

Comment 9 Michael Schwendt 2006-03-17 20:38:07 UTC
compat-wxGTK2-devel is broken!

$ wxgtk2-2.4-config --cflags
-I/usr/lib/wx/include/gtk2-2.4 -DGTK_NO_CHECK_CASTS -D__WXGTK__

It points to  /usr/lib/wx/include/gtk2-2.4  but the compat-wxGTK2-devel
package contains headers in a different path:


On the contrary, compat-wxGTK-devel is okay.

Comment 10 Matthew Miller 2006-03-17 20:40:13 UTC
Michael -- what's your advice for resolving comment #8? I'd not like to remove
that from the main wxGTK package, but it seems necessary here....

Comment 11 Michael Schwendt 2006-03-17 20:45:53 UTC
Re: comment 9

--- compat-wxGTK.spec.~1.2.~    2006-01-06 18:52:38.000000000 +0100
+++ compat-wxGTK.spec   2006-03-17 21:51:27.000000000 +0100
@@ -288,7 +288,7 @@
 %ghost %{_bindir}/wx-2.4-config
 %files common -f wxstd.lang

Re: comment 10

Remove the Provides from the compat-wxGTK2{-devel} packages, but not
from the new wxGTK{-devel} packages.

Comment 12 Michael Schwendt 2006-03-17 20:51:09 UTC
Btw, compat-wxGTK{-devel} must not "Provides: wxGTK = ..." and
"Provides: wxGTK-devel = ..." either.

Comment 13 Matthew Miller 2006-03-17 20:52:53 UTC
And then any packages which link against this must work just by virtue of the
automatic library deps, and any which have explict requires statements must be
fixed, yeah?

Comment 14 Michael Schwendt 2006-03-17 21:00:12 UTC
> And then any packages which link against this must work just
> by virtue of the automatic library deps

That's how ordinary "compat-" packages work anyway. You let a _new_
compat- package provide the SONAMES needed by old binaries. The
SONAME dependencies don't care which package contains the needed

> and any which have explict requires statements must be
> fixed, yeah?

Those packages are broken by design.

Same applies to BuildRequires and the current brokeness due to these
"virtual provides" madness. A package which "BuildRequires: wxGTK2-devel"
cannot be built with compat-wxGTK2-devel which "Provides: wxGTK2-devel"
and vice versa.

Comment 15 Matthew Miller 2006-03-17 21:02:28 UTC
Make sense. And is ideal, because it's someone else's problem. *grin*

Comment 16 Alex Lancaster 2006-04-19 14:37:45 UTC
Looks like compat-wxPythonGTK2 hasn't yet been built on devel or FC-5.  Causes
some problems like bug #188215.

Comment 17 Matthew Miller 2006-04-19 14:47:59 UTC
The specific code in bug #188215 (simply importing wxPython) should work fine
with the new 2.6.x wxPython.

Comment 18 Joel Schaerer 2006-04-19 19:56:57 UTC
When will the new packages be available? The code i would like to use is mainly
incompatible with wx2.6, so the packages are going to be needed! 
As of today, i only see the old package:
wxPythonGTK2.i386                            extras
in extras, and it doesn't work (cf bug #188215)

Comment 19 Tom "spot" Callaway 2006-04-19 21:40:48 UTC
New packages should now be available.

Comment 20 Alex Lancaster 2006-04-20 01:12:39 UTC
Shouldn't package reviews be closed as NEXTRELEASE?

Comment 21 Tom "spot" Callaway 2006-04-20 01:20:12 UTC
Ehh. Semantics.

I think of NEXTRELEASE as "FC-6" as opposed to "Immediately in repo", but I
could see either being valid.

They're built. That's what really matters, right? :)

Comment 22 Alex Lancaster 2006-04-20 02:41:10 UTC
(In reply to comment #21)
> Ehh. Semantics.
> I think of NEXTRELEASE as "FC-6" as opposed to "Immediately in repo", but I
> could see either being valid.

Sure, just wondering whether the process had changed.  I was going off of step
14 of: 

> They're built. That's what really matters, right? :)

Indeed, thank you.

Note You need to log in before you can comment on or make changes to this bug.