Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1755815 - boot failure after upgrade from RHEL 7 to RHEL 8: missing mandatory option for `users`.
Summary: boot failure after upgrade from RHEL 7 to RHEL 8: missing mandatory option fo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: grub2
Version: 8.1
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.1
Assignee: Bootloader engineering team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-26 09:27 UTC by Petr Stodulka
Modified: 2020-11-14 06:52 UTC (History)
7 users (show)

Fixed In Version: grub2-2.02-78.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1693515
Environment:
Last Closed: 2019-11-05 22:24:10 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3587 0 None None None 2019-11-05 22:24:25 UTC

Description Petr Stodulka 2019-09-26 09:27:56 UTC
+++ This bug was initially created as a clone of Bug #1693515 +++

We discovered the same issue that has been fixed already on Fedora. In short,
after the upgrade to RHEL 8 system we are stucked in grub shell. This is specific for POWER machines on PowerVM - virtualized.

This is blocker for in-place upgrades on virtualized POWER machines and we need the fix delivered in RHEL 8.1 GA (ASAP for another testing purposes).

Comment 9 Alois Mahdal 2019-09-26 19:11:56 UTC
Notes for automated testing:

   morf upg -a ppc64le el7toel8 @noop -- --hostrequire '<key_value key="CPUMODEL" op="like" value="%POWER8E%"/>'

should get upgrade on suitable machine, although the require node here is wild guess (based on years old rhel6>rhel7 issue where we had to avoid powervm) and there's probably better way.

Alternatively,

   morf upg -a ppc64le el7toel8 @noop -- --machine suitable.machine.example.com

Adding --brew-task should work as well, updating the machine first with eg. Javier's build:

   morf upg -a ppc64le el7toel8 @noop -- --hostrequire '<key_value key="CPUMODEL" op="like" value="%POWER8E%"/>' --brew-task=23736760

I'm going to try it right now and also add test case to morf so that we can verify it later more easily.

Comment 11 Alois Mahdal 2019-09-27 10:40:00 UTC
Oh wait I did not realize --brew-task won't work because it will try to bolt the package on rhel7 but this fix is on rhel8 side.  I'll come up with something better.

Comment 21 Alois Mahdal 2019-10-03 13:33:23 UTC
Currently the status is:

 *  rhel-alt ppc64le - fixed  (old fails, new is OK)
 *  rhel     ppc64le - fixed  (old fails, new is OK)

For regression test, I also tried to run it with x86_64 but it looks like it's broken for another reasons which I still need clarified by Petr.

 *  rhel     x86_64  - ??? (blocked w/ another poblem that kills the test much earlier)

We can take care of verifying this in context of upgrade.  However, I presume RTT also have their regression testing process, so just let's make sure we're not avoiding that.

Comment 22 Alois Mahdal 2019-10-03 14:33:08 UTC
OK, so we've found out:  the repo provided by Javier was invalid; did not contain all files from the build (missing noarch).  Javier, did you use some Brew feature to create the repo?  If so, there could be bug to report.

Anyway, I'm going to find or create a repo manually and use that to re-run the suite.

Comment 23 Javier Martinez Canillas 2019-10-03 14:47:52 UTC
(In reply to Alois Mahdal from comment #22)
> OK, so we've found out:  the repo provided by Javier was invalid; did not
> contain all files from the build (missing noarch).  Javier, did you use some
> Brew feature to create the repo?  If so, there could be bug to report.
> 
> Anyway, I'm going to find or create a repo manually and use that to re-run
> the suite.

The repo is valid. But may need to include both for x86_64 and i686 arches depending on which set of grub2 packages you have installed.

Comment 24 Petr Stodulka 2019-10-03 14:58:39 UTC
No, it is not valid Javier. There is not grub2-pc-modules-2.02-78.el8.noarch.rpm inside the repo for x86_64 that should be there.

Comment 25 Petr Stodulka 2019-10-03 14:59:26 UTC
Adding that one rpm extra into the transaction resolved whole problem.

Comment 26 Alois Mahdal 2019-10-03 16:06:08 UTC
Looking at compose, what rhel-8 normally includes in repo is x86_64 and noarch. (I can't see any i686.)  The repo is indeed missing at least this one particular .noacrh file (while at the same time other .noarch files were present).  It almost looks as if there was if there was some failure while copying the files.

Anyway, I've composed own repo (x86_64 + noarch) and I'm now running tests against it:

   https://liver3.brq.redhat.com/jenkins/view/OAMG/job/oamg-dispatch-adhoc/241/console

(Note that once we get the package in a compose or stage, we can---and eventually will---re-run tests again.)

Comment 27 Alois Mahdal 2019-10-03 21:32:02 UTC
So apart from some minor waivable issues (leftover packages etc.)  the above tests passed.  Ie. status:

 *  rhel-alt ppc64le - fixed  (old fails, new is OK)
 *  rhel     ppc64le - fixed  (old fails, new is OK)
 *  rhel     x86_64  - unaffected (old OK, new OK)

Thanks for the fix, Javier!


Rest is up to RTT, I guess.

Comment 30 errata-xmlrpc 2019-11-05 22:24:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3587


Note You need to log in before you can comment on or make changes to this bug.