Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1791391 - mumble: build for epel8
Summary: mumble: build for epel8
Alias: None
Product: Fedora
Classification: Fedora
Component: mumble
Version: rawhide
Hardware: Unspecified
OS: Linux
Target Milestone: ---
Assignee: John
QA Contact: Fedora Extras Quality Assurance
: 1902334 (view as bug list)
Depends On: 1928156 1677947 1980578
TreeView+ depends on / blocked
Reported: 2020-01-15 17:32 UTC by tsuned49
Modified: 2022-07-01 15:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed:
Type: Bug

Attachments (Terms of Use)

Description tsuned49 2020-01-15 17:32:47 UTC
Description of problem: can not build on Centos-8

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info: can not find pulseaudio-devel speechhd-devel

Comment 1 tsuned49 2020-01-15 17:41:50 UTC
can you build mumble for epel8

Comment 2 Vasiliy Glazov 2020-01-16 07:17:25 UTC
Need to update mumble to 1.3.0 first with Qt 5 support.

Comment 3 Carl George 🤠 2020-09-22 19:53:50 UTC
I don't know what pulseaudio-devel and speechhd-devel are.  Mumble has build requirements on speech-dispatcher-devel and pulseaudio-libs-devel.  In CentOS, those are available in PowerTools and AppStream, respectively.

If there are any missing build requirements in CentOS, the process to request those is documented here:

Comment 4 Fedora Admin user for bugzilla script actions 2020-10-18 02:52:05 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 5 Ben Cotton 2020-11-03 16:10:40 UTC
This message is a reminder that Fedora 31 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 31 on 2020-11-24.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '31'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 31 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Carl George 🤠 2020-12-03 04:50:17 UTC
*** Bug 1902334 has been marked as a duplicate of this bug. ***

Comment 7 tomislav.parcina 2020-12-03 19:45:12 UTC
Carl, is there any chance that this will be resolved soon?

Comment 8 tomislav.parcina 2020-12-11 07:30:25 UTC
Is there anything I can do to speed up things a bit?

Comment 9 Carl George 🤠 2020-12-20 05:06:13 UTC
I only recently became the maintainer of this package, and I've got work to do getting mumbled updated to 1.3.3, switching to the bundled celt library, and general spec file clean up.  I'm making some progress on that, but I'm not finished yet.  Once I'm caught up I'll attempt to build it for epel8.

Comment 10 Carl George 🤠 2020-12-23 04:19:02 UTC
Now that I have bug 1885088 and bug 1904471 resolved, I tried to do a build against epel8.  It fails with these error.

    cc1plus: error: one or more PCH files were found, but they were invalid
    cc1plus: error: use -Winvalid-pch for more information
    cc1plus: fatal error: release/mumble: No such file or directory

This same spec file is working on f33/f34, so I suspect something is different between the dependencies that is causing it to fail only on epel8.  I'm open to suggestions on how to resolve this.

Comment 11 tomislav.parcina 2020-12-23 15:42:06 UTC
Fatal error is:
    cc1plus: fatal error: release/mumble: No such file or directory
Isn't that spec file related? Should it be solvable with right spec file configuration?

Comment 12 Carl George 🤠 2020-12-23 17:16:22 UTC
I repeat, the exact same spec file builds fine on f33/f34 but fails on epel8, so I don't see how it's a spec file problem.  Happy to be proven wrong if I'm missing something.  My theory is that mumble has an undocumented minimum version of one of the build requirements, but I haven't proven it yet.  I was also able to do successful local builds all the way back to f28, so I'm comparing the build requirement versions of that and el8 to see what jumps out at me.

Comment 13 Carl George 🤠 2021-07-09 00:11:21 UTC
I've learned the cause of the "one or more PCH files were found, but they were invalid" error.  RHEL8's hardened gcc is incompatible with PCH [0].  PCH must be disabled in software when compiling software for RHEL8.  The current mumble 1.3 branch has an undocumented "no-pch" config option that accomplishes this [1].  I'll also note that the upcoming mumble 1.4 does away with PCH as part of their migration to cmake [2].  Adding "no-pch" to the spec file allows it to build for epel8.  The only thing stopping me now is the lack of rnnoise in epel8, which I have requested [3].

[0] bug 1721553 comment 38
[3] bug 1980578

Comment 14 Carl George 🤠 2021-07-10 03:50:13 UTC
The test build I did that worked was 1.3.4-1 with the "no-pch" option, but without the rnnoise option.  Enabling both causes the the build to fail again.  After some investigation, I think the cause is some incompatibility between the rnnoise code and RHEL 8's qt 5.12.  I was able to do a successful build in epel8-next [0] with CentOS Stream 8's qt 5.15.  I have submitted that as an update [1].  Once qt 5.15 is released with RHEL 8.5 later this year, I'll be able to do a regular epel8 build for this.


Comment 15 Fedora Admin user for bugzilla script actions 2022-07-01 15:18:50 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Note You need to log in before you can comment on or make changes to this bug.