Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1794222 - Tracking retirement of python-unittest2
Summary: Tracking retirement of python-unittest2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-unittest2
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1831165 (view as bug list)
Depends On: 1808384 1809967 1809969 1809970 1809986 1830970 1834206
Blocks: F33FTBFS PYTHON39 1789416
TreeView+ depends on / blocked
 
Reported: 2020-01-22 23:54 UTC by Avram Lubkin
Modified: 2020-05-29 07:12 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-29 07:12:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Avram Lubkin 2020-01-22 23:54:04 UTC
This came out of Bug 1789200.
unittest2 is an older version of unittest intended as a backport to Python 2.6. A small number of packages require it under Python 3. This bug is to track the effort to remove the dependency from those packages.

Comment 1 Avram Lubkin 2020-01-23 00:12:39 UTC
dnf repoquery --disablerepo=* --enablerepo=fedora{,-source} --releasever=rawhide --whatrequires python3-unittest2 --refresh
ProDy-0:1.10.10-4.fc32.src
fedpkg-0:1.37-10.fc32.src
obs-service-tar_scm-0:0.10.10-2.fc32.src
pyephem-0:3.7.6.0-17.fc32.src
python-funcsigs-0:1.0.2-17.fc32.src
python-testtools-0:2.3.0-15.fc32.src
python-traceback2-0:1.4.0-25.fc32.src
python3-testtools-0:2.3.0-15.fc32.noarch
tuned-0:2.13.0-1.fc32.src

Comment 2 Avram Lubkin 2020-01-23 00:13:11 UTC
ProDy - pushed but not built
fedpkg - pushed but not built
obs-service-tar_scm - pushed but not built
pyephem - https://src.fedoraproject.org/rpms/pyephem/pull-request/1
python-funcsigs - pushed but not built
python-testtools - TBD
python-traceback2 - (Only needed by unittest2 and testtools) https://bugzilla.redhat.com/show_bug.cgi?id=1789416 
tuned - verified in koji

Comment 3 Avram Lubkin 2020-01-23 01:23:30 UTC
python-testtools - https://src.fedoraproject.org/rpms/python-testtools/pull-request/6

Comment 4 Avram Lubkin 2020-01-23 02:05:24 UTC
tuned - https://github.com/redhat-performance/tuned/issues/241

Comment 5 Ben Cotton 2020-02-11 17:27:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 6 Avram Lubkin 2020-02-19 14:21:28 UTC
Current Status:
pyephem - https://src.fedoraproject.org/rpms/pyephem/pull-request/1
python-traceback2 - https://bugzilla.redhat.com/show_bug.cgi?id=1789416 
python3-testtools - https://src.fedoraproject.org/rpms/python-testtools/pull-request/6
tuned - https://github.com/redhat-performance/tuned/issues/241

I bumped the pull requests and the tuned issue.
I'd do an upstream PR for tuned, but it's unclear what platforms they are supporting.

Comment 7 Miro Hrončok 2020-02-25 19:13:54 UTC
Current Status:

$ repoquery --refresh --repo=koji{,-source} --whatrequires python3-unittest2
pyephem-0:3.7.6.0-18.fc32.src
tuned-0:2.13.0-2.fc32.src


pyephem has an open PR (ignored)


tuned is trivially fixable by:

+sed -i s/unittest2/unittest/ $(grep -lr unittest2)
+sed -i s/assertItemsEqual/assertCountEqual/ $(grep -lr assertItemsEqual)

Upstream PR: https://github.com/redhat-performance/tuned/pull/249


I say we retire it now. Alfredo?

Comment 8 Miro Hrončok 2020-02-25 20:10:33 UTC
Tuned downstream PR: https://src.fedoraproject.org/rpms/tuned/pull-request/2

Comment 9 Miro Hrončok 2020-03-02 11:38:13 UTC
The unittest2 package now fails to install:

Error: 
 Problem: conflicting requests
  - nothing provides python3-traceback2 needed by python3-unittest2-1.1.0-24.fc32.noarch
  - nothing provides python3.8dist(traceback2) needed by python3-unittest2-1.1.0-24.fc32.noarch


Please, retire it.

Comment 10 Miro Hrončok 2020-05-04 18:09:40 UTC
*** Bug 1831165 has been marked as a duplicate of this bug. ***

Comment 11 Miro Hrončok 2020-05-04 18:10:22 UTC
Can I please retire the package?

Comment 12 Lumír Balhar 2020-05-27 06:25:48 UTC
This package now fails to build in Python 3.9 side tag because there is no python3-traceback2.

Comment 13 Miro Hrončok 2020-05-27 08:39:28 UTC
3 more weeks. I have retired the package.

Comment 14 Alfredo Moralejo 2020-05-28 09:05:32 UTC
Sorry for the delay, it's fine to retire.

Comment 15 Igor Raits 2020-05-28 17:39:58 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

All subpackages of a package agaisnt which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.