Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1794394 - internal compiler error: in nothrow_spec_p
Summary: internal compiler error: in nothrow_spec_p
Keywords:
Status: CLOSED DUPLICATE of bug 1794094
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-23 13:41 UTC by Alejandro Alvarez
Modified: 2020-10-05 08:33 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 13:42:58 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Preprocessed C++ file (deleted)
2020-01-23 13:41 UTC, Alejandro Alvarez
no flags Details

Description Alejandro Alvarez 2020-01-23 13:41:04 UTC
Created attachment 1654850 [details]
Preprocessed C++ file

Description of problem:

/home/aalvarez/Work/Projects/SourceXtractorPlusPlus/SEFramework/SEFramework/Output/OutputRegistry.h:53:88: internal compiler error: in nothrow_spec_p, at cp/except.c:1247
   53 |     m_name_to_col_info_map.emplace(column_name, ColInfo{column_unit, column_description});
      |                                                                                        ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccPTf72k.out file, please attach this to your bugreport.


Version-Release number of selected component (if applicable): gcc 10 in Fedora Rawhide (32)


How reproducible:
Consistently every time I try to compile that file. Original source: https://github.com/astrorama/SourceXtractorPlusPlus/blob/4711cc1/SEFramework/SEFramework/Output/OutputRegistry.h#L53


Actual results: The compilation fails with this error

Expected results: Fedora 32 with gcc 9 was working fine

Additional info: Preprocessed file attached

Comment 1 Jakub Jelinek 2020-01-23 13:42:58 UTC

*** This bug has been marked as a duplicate of bug 1794094 ***


Note You need to log in before you can comment on or make changes to this bug.