Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1794410 - GCC 10 regression during Telegram Desktop build
Summary: GCC 10 regression during Telegram Desktop build
Keywords:
Status: CLOSED DUPLICATE of bug 1794094
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-23 14:32 UTC by Vitaly
Modified: 2020-10-05 08:31 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 14:40:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Vitaly 2020-01-23 14:32:58 UTC
Description of problem:
GCC 10 regression during Telegram Desktop build.

Version-Release number of selected component (if applicable):
10.0.1-0.4.fc32

How reproducible:
Always.

Steps to Reproduce:
1. Download SRPM: https://xvitaly.fedorapeople.org/bug-reports/telegram-desktop-1.9.7-1.fc31.src.rpm
2. mock -r fedora-rawhide-x86_64-rpmfusion_free ./telegram-desktop-1.9.7-1.fc31.src.rpm

Actual results:
GCC crash.

Expected results:
Successful build.

Additional info:
[582/651] /usr/bin/c++  -DAL_ALEXT_PROTOTYPES -DDESKTOP_APP_DISABLE_CRASH_REPORTS -DDESKTOP_APP_USE_PACKAGED -DDESKTOP_APP_USE_PACKAGED_FONTS -DLOTTIE_USE_CACHE -DLOT_BUILD -DNDEBUG -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQ_OS_LINUX64 -DTDESKTOP_API_HASH=dfbe1bc42dc9d20507e17d1814cc2f0a -DTDESKTOP_API_ID=208164 -DTDESKTOP_DISABLE_AUTOUPDATE -DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION -DTDESKTOP_DISABLE_GTK_INTEGRATION -DTDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME -DTDESKTOP_DISABLE_SPELLCHECK -DTDESKTOP_LAUNCHER_BASENAME=telegramdesktop -ITelegram/Telegram_autogen/include -ITelegram/gen -I../Telegram/SourceFiles -I../Telegram/lib_base -I../Telegram/lib_rpl -I../Telegram/lib_crl -I../Telegram/lib_tl -ITelegram/lib_ui/gen -I../Telegram/lib_ui -I../Telegram/lib_ui/emoji_suggestions -I../Telegram/lib_storage -I../Telegram/lib_lottie -I../Telegram/ThirdParty/rlottie/inc -I../Telegram/lib_qr -isystem /usr/include/guidelines-support-library -isystem /usr/include/qt5/QtCore/5.13.2 -isystem /usr/include/qt5/QtCore/5.13.2/QtCore -isystem /usr/include/qt5/QtGui/5.13.2 -isystem /usr/include/qt5/QtGui/5.13.2/QtGui -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/mkspecs/linux-g++ -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtDBus -isystem /usr/include/ffmpeg -isystem /usr/include/qrcodegencpp -isystem /usr/include/minizip -isystem /usr/include/tgvoip -isystem /usr/include/AL -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -DNDEBUG   -fno-strict-aliasing -pipe -Wall -W -fPIC -Wno-unused-variable -Wno-unused-parameter -Wno-unused-function -Wno-switch -Wno-comment -Wno-unused-but-set-variable -Wno-missing-field-initializers -Wno-sign-compare -Wno-attributes -Wno-parentheses -Wno-stringop-overflow -Wno-maybe-uninitialized -Wno-error=class-memaccess -std=gnu++17 -Winvalid-pch -include /builddir/build/BUILD/tdesktop-1.9.7-full/x86_64-redhat-linux-gnu/Telegram/CMakeFiles/Telegram.dir/cmake_pch.hxx -MD -MT Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o -MF Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o.d -o Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o -c ../Telegram/SourceFiles/storage/storage_sparse_ids_list.cpp
FAILED: Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o 
/usr/bin/c++  -DAL_ALEXT_PROTOTYPES -DDESKTOP_APP_DISABLE_CRASH_REPORTS -DDESKTOP_APP_USE_PACKAGED -DDESKTOP_APP_USE_PACKAGED_FONTS -DLOTTIE_USE_CACHE -DLOT_BUILD -DNDEBUG -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQ_OS_LINUX64 -DTDESKTOP_API_HASH=XXX -DTDESKTOP_API_ID=XXX -DTDESKTOP_DISABLE_AUTOUPDATE -DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION -DTDESKTOP_DISABLE_GTK_INTEGRATION -DTDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME -DTDESKTOP_DISABLE_SPELLCHECK -DTDESKTOP_LAUNCHER_BASENAME=telegramdesktop -ITelegram/Telegram_autogen/include -ITelegram/gen -I../Telegram/SourceFiles -I../Telegram/lib_base -I../Telegram/lib_rpl -I../Telegram/lib_crl -I../Telegram/lib_tl -ITelegram/lib_ui/gen -I../Telegram/lib_ui -I../Telegram/lib_ui/emoji_suggestions -I../Telegram/lib_storage -I../Telegram/lib_lottie -I../Telegram/ThirdParty/rlottie/inc -I../Telegram/lib_qr -isystem /usr/include/guidelines-support-library -isystem /usr/include/qt5/QtCore/5.13.2 -isystem /usr/include/qt5/QtCore/5.13.2/QtCore -isystem /usr/include/qt5/QtGui/5.13.2 -isystem /usr/include/qt5/QtGui/5.13.2/QtGui -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/mkspecs/linux-g++ -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtDBus -isystem /usr/include/ffmpeg -isystem /usr/include/qrcodegencpp -isystem /usr/include/minizip -isystem /usr/include/tgvoip -isystem /usr/include/AL -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -DNDEBUG   -fno-strict-aliasing -pipe -Wall -W -fPIC -Wno-unused-variable -Wno-unused-parameter -Wno-unused-function -Wno-switch -Wno-comment -Wno-unused-but-set-variable -Wno-missing-field-initializers -Wno-sign-compare -Wno-attributes -Wno-parentheses -Wno-stringop-overflow -Wno-maybe-uninitialized -Wno-error=class-memaccess -std=gnu++17 -Winvalid-pch -include /builddir/build/BUILD/tdesktop-1.9.7-full/x86_64-redhat-linux-gnu/Telegram/CMakeFiles/Telegram.dir/cmake_pch.hxx -MD -MT Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o -MF Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o.d -o Telegram/CMakeFiles/Telegram.dir/SourceFiles/storage/storage_sparse_ids_list.cpp.o -c ../Telegram/SourceFiles/storage/storage_sparse_ids_list.cpp
*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_UNIT               | annobin: Generate final annotations
PLUGIN_START_UNIT                | annobin: Generate global annotations
PLUGIN_ALL_PASSES_START          | annobin: Generate per-function annotations
PLUGIN_ALL_PASSES_END            | annobin: Register per-function end symbol
../Telegram/SourceFiles/storage/storage_sparse_ids_list.cpp: In lambda function:
../Telegram/SourceFiles/storage/storage_sparse_ids_list.cpp:194:39: internal compiler error: in nothrow_spec_p, at cp/except.c:1247
  194 |    auto result = SparseIdsListResult {};
      |                                       ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc0xzUpQ.out file, please attach this to your bugreport.

Comment 1 Jakub Jelinek 2020-01-23 14:40:41 UTC

*** This bug has been marked as a duplicate of bug 1794094 ***


Note You need to log in before you can comment on or make changes to this bug.