Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1798876 - unable to add a fcoe disk as there is no nic listed
Summary: unable to add a fcoe disk as there is no nic listed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1798874 (view as bug list)
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-06 08:15 UTC by lnie
Modified: 2020-02-23 05:07 UTC (History)
11 users (show)

Fixed In Version: anaconda-32.23-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-23 05:07:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
anaconda.log (deleted)
2020-02-06 08:16 UTC, lnie
no flags Details

Description lnie 2020-02-06 08:15:51 UTC
Description of problem:
1 click Add a disk in the Installation Destination page
2 click "Add FCOE SAN"
3 click "ADD Fcoe disk"

This happens because  nm_client.get_devices() return value for device['device-type'] is GLib.Variant('i', 1) rather than 1 now,
As a result,though anaconda detected nic but failed to put it in the nicCombo

Version-Release number of selected component (if applicable):
Fedora-Server-dvd-x86_64-Rawhide-20200204.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2020-02-06 08:16:37 UTC
Created attachment 1658117 [details]
anaconda.log

Comment 2 Fedora Blocker Bugs Application 2020-02-06 08:21:08 UTC
Proposed as a Blocker for 32-final by Fedora user lnie using the blocker tracking app because:

 This affects:
The installer must be able to detect (if possible) and install to supported network-attached storage devices.

Comment 3 Radek Vykydal 2020-02-06 09:57:35 UTC
https://github.com/rhinstaller/anaconda/pull/2310

Comment 4 Radek Vykydal 2020-02-06 10:05:31 UTC
Thank you for the report and for the hint.

Comment 5 Radek Vykydal 2020-02-06 11:09:30 UTC
*** Bug 1798874 has been marked as a duplicate of this bug. ***

Comment 6 František Zatloukal 2020-02-10 18:10:48 UTC
Discussed during the 2020-02-10 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made:

"The installer must be able to detect (if possible) and install to supported network-attached storage devices"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2020-02-10/f32-blocker-review.2020-02-10-17.01.log.txt

Comment 7 Ben Cotton 2020-02-11 16:31:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 8 lnie 2020-02-23 05:07:09 UTC
Tested Fedora-Server-dvd-x86_64-32-20200221.n.0.iso,this bug is gone


Note You need to log in before you can comment on or make changes to this bug.