Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1799197 - boo: FTBFS in Fedora rawhide/f32
Summary: boo: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: boo
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1863288 (view as bug list)
Depends On:
Blocks: F32FTBFS F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-02-06 16:09 UTC by Fedora Release Engineering
Modified: 2021-02-02 21:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-02 21:50:07 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2020-02-06 16:09 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2020-02-06 16:09 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2020-02-06 16:09 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-02-06 16:09:13 UTC
boo failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41316024


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix boo at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
boo will be orphaned. Before branching of Fedora 33,
boo will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 16:09:21 UTC
Created attachment 1658525 [details]
build.log

Comment 2 Fedora Release Engineering 2020-02-06 16:09:28 UTC
Created attachment 1658527 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 16:09:32 UTC
Created attachment 1658528 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 17:14:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:32:35 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Timotheus Pokorra 2020-02-20 05:21:48 UTC
we have SIGARBT even on arch x86_64:

Boo.NAnt.Tasks:

     [exec] /root/rpmbuild/BUILD/boo-alpha/default.build(308,4): Attribute 'useruntimeengine' for <exec ... /> is deprecated.  Use the managed attribute and Managed property instead.
     [exec] Boo Compiler version 0.9.7.0 (6.6.0.161 (tarball Wed Feb  5 07:34:41 UTC 2020))
     [exec] * Assertion at sre-encode.c:290, condition `count > 0' not met
     [exec] 
     [exec] 
     [exec] =================================================================
     [exec]  Native Crash Reporting
     [exec] =================================================================
     [exec] Got a SIGABRT while executing native code. This usually indicates
     [exec] a fatal error in the mono runtime or one of the native libraries 
     [exec] used by your application.
     [exec] =================================================================
     [exec] 
     [exec] =================================================================
     [exec]  Native stacktrace:
     [exec] =================================================================
     [exec]  0x55e28ab90425 - /usr/bin/mono : (null)
     [exec]  0x55e28ab907d0 - /usr/bin/mono : (null)
     [exec]  0x55e28ab3c952 - /usr/bin/mono : (null)
     [exec]  0x55e28ab8f9d7 - /usr/bin/mono : (null)
     [exec]  0x7ff1d69b9a90 - /lib64/libpthread.so.0 : (null)
     [exec]  0x7ff1d67fca35 - /lib64/libc.so.6 : gsignal
     [exec]  0x7ff1d67e5895 - /lib64/libc.so.6 : abort
     [exec]  0x55e28aaf83b0 - /usr/bin/mono : (null)
     [exec]  0x55e28ae05095 - /usr/bin/mono : (null)
     [exec]  0x55e28ae22447 - /usr/bin/mono : monoeg_assertion_message
     [exec]  0x55e28ad80491 - /usr/bin/mono : (null)
     [exec]  0x55e28ad80540 - /usr/bin/mono : (null)
     [exec]  0x55e28ad80bb5 - /usr/bin/mono : (null)
     [exec]  0x55e28ad82f14 - /usr/bin/mono : (null)
     [exec]  0x55e28ad85d51 - /usr/bin/mono : (null)
     [exec]  0x55e28ad7f97b - /usr/bin/mono : (null)
     [exec]  0x404256ed - Unknown
     [exec] 
     [exec] =================================================================
     [exec]  Telemetry Dumper:
     [exec] =================================================================
     [exec] Pkilling 0x7ff1d66d7700 from 0x7ff1d67bb780
     [exec] Entering thread summarizer pause from 0x7ff1d67bb780
     [exec] Finished thread summarizer pause from 0x7ff1d67bb780.
     [exec] * Assertion: should not be reached at threads.c:6254
     [exec] 
     [exec] Waiting for dumping threads to resume
     [exec] 
     [exec] =================================================================
     [exec]  External Debugger Dump:
     [exec] =================================================================
     [exec] mono_gdb_render_native_backtraces not supported on this platform, unable to find gdb or lldb
     [exec] 
     [exec] =================================================================
     [exec]  Basic Fault Address Reporting
     [exec] =================================================================
     [exec] Memory around native instruction pointer (0x7ff1d67fca35):0x7ff1d67fca25  d2 4c 89 ce bf 02 00 00 00 b8 0e 00 00 00 0f 05  .L..............
     [exec] 0x7ff1d67fca35  48 8b 84 24 08 01 00 00 64 48 2b 04 25 28 00 00  H..$....dH+.%(..
     [exec] 0x7ff1d67fca45  00 75 24 44 89 c0 48 81 c4 18 01 00 00 c3 0f 1f  .u$D..H.........
     [exec] 0x7ff1d67fca55  44 00 00 48 8b 15 19 64 18 00 f7 d8 41 b8 ff ff  D..H...d....A...
     [exec] 
     [exec] =================================================================
     [exec]  Managed Stacktrace:
     [exec] =================================================================
     [exec]    at <unknown> <0xffffffff>
     [exec]    at System.Reflection.Emit.ModuleBuilder:build_metadata <0x0006c>
     [exec]    at System.Reflection.Emit.ModuleBuilder:Save <0x0072b>
     [exec]    at System.Reflection.Emit.AssemblyBuilder:Save <0x007eb>
     [exec]    at System.Reflection.Emit.AssemblyBuilder:Save <0x0003b>
     [exec]    at Boo.Lang.Compiler.Steps.SaveAssembly:Save <0x0011b>
     [exec]    at Boo.Lang.Compiler.Steps.SaveAssembly:Run <0x0007f>
     [exec]    at Boo.Lang.Compiler.CompilerPipeline:RunStep <0x000e4>
     [exec]    at Boo.Lang.Compiler.CompilerPipeline:RunSteps <0x0009f>
     [exec]    at <Run>c__AnonStorey0:<>m__0 <0x00073>
     [exec]    at Boo.Lang.Environments.ActiveEnvironment:With <0x00072>
     [exec]    at Boo.Lang.Compiler.CompilerPipeline:Run <0x0014f>
     [exec]    at Boo.Lang.Compiler.BooCompiler:Run <0x000a9>
     [exec]    at Boo.Lang.Compiler.BooCompiler:Run <0x00053>
     [exec]    at booc.App:Run <0x0026f>
     [exec]    at booc.App:AppRun <0x0003f>
     [exec]    at booc.App:Main <0x00063>
     [exec]    at <Module>:runtime_invoke_int_object <0x00091>
     [exec] =================================================================

BUILD FAILED - 0 non-fatal error(s), 31 warning(s)

Comment 7 Timotheus Pokorra 2020-02-21 05:26:26 UTC
I have reported this bug upstream: https://github.com/boo-lang/boo/issues/202

Comment 8 Timotheus Pokorra 2020-02-21 05:29:30 UTC
and now I found the fix, already part of Mono 6.10: https://xamarin.github.io/bugzilla-archives/45/45136/bug.html

Comment 9 Timotheus Pokorra 2020-02-21 05:48:34 UTC
No, that fix was applied already in Mono 5.0.

So I have reported a bug with Mono upstream instead: https://github.com/mono/mono/issues/18970

Comment 10 Timotheus Pokorra 2020-08-04 17:17:20 UTC
*** Bug 1863288 has been marked as a duplicate of this bug. ***

Comment 11 Ben Cotton 2020-08-11 13:07:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 12 Timotheus Pokorra 2020-08-15 06:54:28 UTC
I added an upstream report at the boo repository: https://github.com/boo-lang/boo/issues/209

Comment 13 Timotheus Pokorra 2020-12-22 06:56:05 UTC
I tried with Mono 6.12.
I tried with latest master from https://github.com/boo-lang/boo/

I am not getting any help from upstream, neither boo nor mono.

I am not using the package myself.
I will orphan the boo package, and let it retire eventually.

Comment 14 Fedora Admin user for bugzilla script actions 2020-12-22 14:52:07 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 15 Miro Hrončok 2021-02-02 21:50:07 UTC
Automation has figured out the package is retired in rawhide.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.