Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1799856 - perl-Syntax-Highlight-Perl6: FTBFS in Fedora rawhide/f32
Summary: perl-Syntax-Highlight-Perl6: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Syntax-Highlight-Perl6
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-02-06 19:11 UTC by Fedora Release Engineering
Modified: 2020-04-09 14:43 UTC (History)
4 users (show)

Fixed In Version: perl-STD-20101111-19.fc33 perl-Syntax-Highlight-Perl6-0.88-26.fc33 perl-Syntax-Highlight-Perl6-0.88-26.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-09 14:43:45 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2020-02-06 19:11 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2020-02-06 19:12 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2020-02-06 19:12 UTC, Fedora Release Engineering
no flags Details


Links
System ID Private Priority Status Summary Last Updated
CPAN 131760 0 None None None 2020-02-17 09:35:02 UTC

Description Fedora Release Engineering 2020-02-06 19:11:57 UTC
perl-Syntax-Highlight-Perl6 failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41320289


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix perl-Syntax-Highlight-Perl6 at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
perl-Syntax-Highlight-Perl6 will be orphaned. Before branching of Fedora 33,
perl-Syntax-Highlight-Perl6 will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 19:11:59 UTC
Created attachment 1660265 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2020-02-06 19:12:01 UTC
Created attachment 1660266 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 19:12:03 UTC
Created attachment 1660267 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 16:55:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:31:20 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Fedora Release Engineering 2020-03-01 04:23:03 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 7 Fedora Release Engineering 2020-03-08 04:23:10 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 32.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (that's on 2020-04-02).

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-33/f-33-key-tasks.html

Comment 8 Fedora Release Engineering 2020-03-29 04:23:13 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 32.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (that's on 2020-04-02).

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-33/f-33-key-tasks.html

Comment 9 Petr Pisar 2020-03-31 14:30:21 UTC
The tests fail like this:

t/00-compile.t ............. ok
given is experimental at /usr/share/perl5/STD.pm line 28038.
[...]
Can't call method "nfa" on unblessed reference at /usr/share/perl5/CursorBase.pm line 2388.
# Looks like your test exited with 255 before it could output anything.
t/00-std.t .................
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 2/2 subtests
[...]
Test Summary Report
-------------------
t/00-std.t               (Wstat: 65280 Tests: 0 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 2 tests but ran 0.
t/01-syntax.t            (Wstat: 65280 Tests: 5 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 37 tests but ran 5.
t/02-hilitep6.t          (Wstat: 5632 Tests: 30 Failed: 22)
  Failed tests:  7-11, 13-16, 18-30
  Non-zero exit status: 22
Files=7, Tests=37,  5 wallclock secs ( 0.04 usr  0.03 sys +  1.26 cusr  0.45 csys =  1.78 CPU)
Result: FAIL
Failed 3/7 test programs. 22/37 subtests failed.

Comment 10 Petr Pisar 2020-03-31 14:34:22 UTC
This is triggered with updating perl-YAML-LibYAML from 1:0.80-1.fc32 to 1:0.81-1.fc32.

Comment 11 Petr Pisar 2020-03-31 15:48:08 UTC
This is caused by perl-STD. I will fix it and rebuild this package.

Comment 12 Fedora Update System 2020-04-01 07:09:12 UTC
FEDORA-2020-a5db340aba has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a5db340aba

Comment 13 Fedora Update System 2020-04-02 02:16:47 UTC
FEDORA-2020-a5db340aba has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a5db340aba`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a5db340aba

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-04-09 14:43:45 UTC
FEDORA-2020-a5db340aba has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.