Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1800970 - dnf update of eclipse-usage-4.11.0-1.fc31.noarch fails
Summary: dnf update of eclipse-usage-4.11.0-1.fc31.noarch fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-usage
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-09 16:04 UTC by Colin Barker
Modified: 2020-08-28 14:58 UTC (History)
5 users (show)

Fixed In Version: eclipse-usage-4.16.0-2.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-28 14:58:01 UTC
Type: Bug


Attachments (Terms of Use)
output of rpm -qa (113.20 KB, text/plain)
2020-02-09 16:04 UTC, Colin Barker
no flags Details

Description Colin Barker 2020-02-09 16:04:30 UTC
Created attachment 1661970 [details]
output of rpm -qa

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.run 'dnf update'
2.
3.

Actual results:
 Problem 1: package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 obsoletes eclipse-epp-logging <= 2.0.8-4 provided by eclipse-epp-logging-2.0.7-8.fc31.noarch
  - cannot install the best update candidate for package eclipse-usage-4.11.0-1.fc31.noarch
  - cannot install the best update candidate for package eclipse-abrt-0.0.3-9.fc31.noarch
  - package eclipse-epp-logging-2.0.8-1.module_f31+6165+9b01e00c.noarch is filtered out by modular filtering
  - package eclipse-epp-logging-2.0.8-2.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
 Problem 2: problem with installed package eclipse-usage-4.11.0-1.fc31.noarch
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc31.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 obsoletes eclipse-epp-logging <= 2.0.8-4 provided by eclipse-epp-logging-2.0.7-8.fc31.noarch
  - cannot install the best update candidate for package eclipse-epp-logging-2.0.7-8.fc31.noarch
  - package eclipse-epp-logging-2.0.8-1.module_f31+6165+9b01e00c.noarch is filtered out by modular filtering
  - package eclipse-epp-logging-2.0.8-2.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering


Expected results:
dnf update to complete with no dependency errors

Additional info:
output of rpm -qa attached as package.log

Comment 1 andreas.buesching 2020-02-20 09:14:23 UTC
I've had the same problem. I "fixed" it by removing eclipse-epp-logging before doing the upgrade:

# sudo rpm -e --nodeps eclipse-epp-logging

So it looks like the replacement of eclipse-epp-logging by eclipse-platform does not work ... not that I'm an expert of package management ;-)

Comment 2 Rsantis 2020-03-07 01:55:08 UTC
Same problem after 30 to 31 upgrade.

Seems there's a collision with the installed 

[root@localhost ~]# dnf info eclipse-epp-logging
Last metadata expiration check: 0:03:26 ago on Fri 06 Mar 2020 08:40:55 PM EST.
Installed Packages
Name         : eclipse-epp-logging
Version      : 2.0.7
Release      : 8.fc31
Architecture : noarch
Size         : 604 k
Source       : eclipse-epp-logging-2.0.7-8.fc31.src.rpm

and the required osgi.


My solution

[1] Remove it 
[root@localhost ~]# dnf remove eclipse-epp-logging
Dependencies resolved.
=================================================================================================================================================================
 Package                                      Architecture            Version                                            Repository                         Size
=================================================================================================================================================================
Removing:
 eclipse-epp-logging                          noarch                  2.0.7-8.fc31                                       @fedora                           604 k
Removing dependent packages:
 eclipse-abrt                                 noarch                  0.0.3-9.fc31                                       @fedora                            52 k
 eclipse-usage                                noarch                  4.11.0-1.fc31                                      @fedora                           142 k
Removing unused dependencies:
 httpcomponents-client-cache                  noarch                  4.5.5-4.module_f29+6921+ca3ed728                   @updates-modular                  157 k

Transaction Summary
=================================================================================================================================================================
Remove  4 Packages


[2] Now update

dnf update
Last metadata expiration check: 0:07:49 ago on Fri 06 Mar 2020 08:40:55 PM EST.
Dependencies resolved.
=================================================================================================================================================================
 Package                                        Architecture                     Version                                 Repository                         Size
=================================================================================================================================================================
Upgrading:
 eclipse-equinox-osgi                           x86_64                           1:4.14-5.fc31                           updates                           1.6 M
 eclipse-jdt                                    noarch                           1:4.14-5.fc31                           updates                            31 M
 eclipse-p2-discovery                           noarch                           1:4.14-5.fc31                           updates                           228 k
 eclipse-pde                                    x86_64                           1:4.14-5.fc31                           updates                           111 M
 eclipse-platform                               x86_64                           1:4.14-5.fc31                           updates                            40 M
 eclipse-swt                                    x86_64                           1:4.14-5.fc31                           updates                           4.5 M

Transaction Summary
=================================================================================================================================================================
Upgrade  6 Packages



Problem solved, at least for dnf.

Comment 3 Fedora Admin user for bugzilla script actions 2020-08-18 14:53:40 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 4 Fedora Update System 2020-08-20 13:03:00 UTC
FEDORA-2020-fb0c1e9c3e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb0c1e9c3e

Comment 5 Fedora Update System 2020-08-21 01:03:50 UTC
FEDORA-2020-fb0c1e9c3e has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fb0c1e9c3e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb0c1e9c3e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-08-28 14:58:01 UTC
FEDORA-2020-fb0c1e9c3e has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.