Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1806520 - pyanaconda.modules.common.errors.storage.MountFilesystemError: Failed to mount sr0 at /tmp/tmphuna95st: mounting filesystem iso9660 is not supported
Summary: pyanaconda.modules.common.errors.storage.MountFilesystemError: Failed to moun...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bcc3547ad83377822da099d05ac...
: 1807298 (view as bug list)
Depends On:
Blocks: F32BetaFreezeException F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-24 12:36 UTC by Radek Vykydal
Modified: 2020-03-22 03:09 UTC (History)
10 users (show)

Fixed In Version: anaconda-32.24.2-2 anaconda-32.24.2-2.fc32 anaconda-32.24.3-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-06 20:49:30 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: anaconda.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: dbus.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: dnf.librepo.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: environ (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: lorax-packages.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: lsblk_output (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: lvm.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: nmcli_dev_list (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: os_info (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: program.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: storage.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: syslog (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details
File: packaging.log (deleted)
2020-02-24 12:37 UTC, Radek Vykydal
no flags Details

Description Radek Vykydal 2020-02-24 12:36:56 UTC
Description of problem:
Installing latest rawhide Fedora-Rawhide-20200223.n.0 in kvm VM from PXE:

label development-rawhide
  menu label development-rawhide
  kernel test/rv/scripted/development-rawhide/vmlinuz
  append initrd=test/rv/scripted/development-rawhide/initrd.img repo=http://download.englab.brq.redhat.com/pub/fedora/development-rawhide/Everything/x86_64/os   

while having RHEL 8.2 devel (20200220) DVD iso in CDROM.

After selecting language the traceback occurs on the summary hub.

The problem does not occur if there is no iso attached to the CDROM, or with Fedora iso in CDROM.

Version-Release number of selected component:
anaconda-32.24

The following was filed automatically by anaconda:
anaconda 32.24 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 496, in _handle_method_error
    raise exception from None
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 474, in _get_method_reply
    return self._handle_method_error(error)
  File "/usr/lib/python3.8/site-packages/dasbus/client/handler.py", line 442, in _call_method
    return self._get_method_reply(
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/utils.py", line 74, in mount_device
    device_tree.MountDevice(device_name, mount_point)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/payload/image.py", line 211, in find_optical_install_media
    payload_utils.mount_device(dev, mountpoint)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/ui/gui/spokes/installation_source.py", line 860, in _initialize
    self._cdrom = find_optical_install_media()
  File "/usr/lib64/python3.8/threading.py", line 870, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/threading.py", line 280, in run
    threading.Thread.run(self)
pyanaconda.modules.common.errors.storage.MountFilesystemError: Failed to mount sr0 at /tmp/tmphuna95st: mounting filesystem iso9660 is not supported

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   initrd=test/rv/scripted/development-rawhide/initrd.img repo=http://download.englab.brq.redhat.com/pub/fedora/development-rawhide/Everything/x86_64/os BOOT_IMAGE=test/rv/scripted/development-rawhide/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO úno-24 12:30:08 === Started libdnf-0.43.1 ===
kernel:         5.6.0-0.rc2.git3.1.fc33.x86_64
product:        Fedora
release:        Fedora release 33 (Rawhide)
release_type:   pre-release
type:           anaconda
version:        rawhide

Comment 1 Radek Vykydal 2020-02-24 12:37:02 UTC
Created attachment 1665406 [details]
File: anaconda-tb

Comment 2 Radek Vykydal 2020-02-24 12:37:07 UTC
Created attachment 1665407 [details]
File: anaconda.log

Comment 3 Radek Vykydal 2020-02-24 12:37:11 UTC
Created attachment 1665408 [details]
File: dbus.log

Comment 4 Radek Vykydal 2020-02-24 12:37:13 UTC
Created attachment 1665409 [details]
File: dnf.librepo.log

Comment 5 Radek Vykydal 2020-02-24 12:37:14 UTC
Created attachment 1665410 [details]
File: environ

Comment 6 Radek Vykydal 2020-02-24 12:37:16 UTC
Created attachment 1665411 [details]
File: lorax-packages.log

Comment 7 Radek Vykydal 2020-02-24 12:37:17 UTC
Created attachment 1665412 [details]
File: lsblk_output

Comment 8 Radek Vykydal 2020-02-24 12:37:22 UTC
Created attachment 1665413 [details]
File: lvm.log

Comment 9 Radek Vykydal 2020-02-24 12:37:23 UTC
Created attachment 1665414 [details]
File: nmcli_dev_list

Comment 10 Radek Vykydal 2020-02-24 12:37:28 UTC
Created attachment 1665415 [details]
File: os_info

Comment 11 Radek Vykydal 2020-02-24 12:37:33 UTC
Created attachment 1665416 [details]
File: program.log

Comment 12 Radek Vykydal 2020-02-24 12:37:34 UTC
Created attachment 1665417 [details]
File: storage.log

Comment 13 Radek Vykydal 2020-02-24 12:37:37 UTC
Created attachment 1665418 [details]
File: syslog

Comment 14 Radek Vykydal 2020-02-24 12:37:39 UTC
Created attachment 1665419 [details]
File: packaging.log

Comment 15 Vendula Poncova 2020-02-25 10:06:46 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/2339

Comment 16 Vendula Poncova 2020-02-26 10:32:39 UTC
*** Bug 1807298 has been marked as a duplicate of this bug. ***

Comment 17 Adam Williamson 2020-02-26 16:32:42 UTC
Funny, somehow didn't find this one when I searched.

Blocker justification, from the dupe: "proposing this as a Final blocker, as a violation of "The installer must be able to use an installer update image retrieved from removable media or a remote package source" - this is because, AFAIK, use of `inst.stage2` in this manner is necessary to use an installer update image via NFS. That is what this test actually *tests*. Also proposing as a Beta FE, as a bug in a significant feature (Final-blocking) which can't be fixed with an update."

Comment 18 Geoffrey Marr 2020-03-02 20:20:07 UTC
Discussed during the 2020-03-02 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" and an "AcceptedFreezeException" was made as we find it violates the following blocker criteria:

"The installer must be able to use an installer update image retrieved from removable media or a remote package source". 

We also are accepting this as a Beta FE as a significant issue which cannot be fixed by update (installer issue).

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-02/f32-blocker-review.2020-03-02-17.00.txt

Comment 19 Fedora Update System 2020-03-04 20:15:28 UTC
anaconda-32.24.2-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-52be94871e

Comment 20 Fedora Update System 2020-03-06 20:49:30 UTC
anaconda-32.24.2-2.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2020-03-17 13:47:05 UTC
FEDORA-2020-84ddf3ee4d has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-84ddf3ee4d

Comment 22 Fedora Update System 2020-03-18 02:38:36 UTC
anaconda-32.24.3-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-84ddf3ee4d

Comment 23 Fedora Update System 2020-03-22 03:09:07 UTC
anaconda-32.24.3-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.