Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1812165 - SELinux is preventing firewalld from using the 'sys_nice' capabilities.
Summary: SELinux is preventing firewalld from using the 'sys_nice' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1811407
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:522a55dffd978f5c78fb8a7fb48...
: 1816869 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-10 16:53 UTC by Mikhail
Modified: 2023-09-14 05:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-09 13:44:20 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Mikhail 2020-03-10 16:53:53 UTC
Description of problem:
SELinux is preventing firewalld from using the 'sys_nice' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that firewalld should have the sys_nice capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'firewalld' --raw | audit2allow -M my-firewalld
# semodule -X 300 -i my-firewalld.pp

Additional Information:
Source Context                system_u:system_r:firewalld_t:s0
Target Context                system_u:system_r:firewalld_t:s0
Target Objects                Unknown [ capability ]
Source                        firewalld
Source Path                   firewalld
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-3.14.6-6.fc33.noarch
Local Policy RPM              selinux-policy-targeted-3.14.6-6.fc33.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.6.0-0.rc4.git0.1.fc33.x86_64 #1
                              SMP Mon Mar 2 17:20:57 UTC 2020 x86_64 x86_64
Alert Count                   2
First Seen                    2020-02-27 01:43:12 +05
Last Seen                     2020-03-05 15:32:32 +05
Local ID                      fd1733d8-2658-41c0-9f77-5c9f35e6bb63

Raw Audit Messages
type=AVC msg=audit(1583404352.303:1523): avc:  denied  { sys_nice } for  pid=1134 comm="firewalld" capability=23  scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:system_r:firewalld_t:s0 tclass=capability permissive=1


Hash: firewalld,firewalld_t,firewalld_t,capability,sys_nice

Version-Release number of selected component:
selinux-policy-3.14.6-6.fc33.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.12.0
hashmarkername: setroubleshoot
kernel:         5.6.0-0.rc5.git0.1.fc33.x86_64
type:           libreport

Potential duplicate: bug 863686

Comment 1 Zdenek Pytela 2020-03-17 14:36:12 UTC
Michail,

Thank you for reporting the issue. This bug seems to reproduce only if accountsservice is installed and running. Are you aware of any functionality issues in firewalld service?

Comment 2 Zdenek Pytela 2020-03-25 16:06:25 UTC
*** Bug 1816869 has been marked as a duplicate of this bug. ***

Comment 3 Chase Lau 2020-03-25 17:18:37 UTC
Similar problem has been detected:

This has repeatedly popped up since upgrading to the Fedora 32 branch

hashmarkername: setroubleshoot
kernel:         5.6.0-0.rc5.git0.2.fc32.x86_64
package:        selinux-policy-3.14.5-31.fc32.noarch
reason:         SELinux is preventing firewalld from using the 'sys_nice' capabilities.
type:           libreport

Comment 4 Alex Pozharov 2020-03-27 20:29:00 UTC
Similar problem has been detected:

Not sure. Just updated on Fedora 32 Beta, after sometime popup about Selinux problem is showed up

hashmarkername: setroubleshoot
kernel:         5.6.0-0.rc7.git0.2.fc32.x86_64
package:        selinux-policy-3.14.5-31.fc32.noarch
reason:         SELinux is preventing firewalld from using the 'sys_nice' capabilities.
type:           libreport

Comment 5 Zdenek Pytela 2020-04-09 13:44:20 UTC

*** This bug has been marked as a duplicate of bug 1811407 ***

Comment 6 Red Hat Bugzilla 2023-09-14 05:54:06 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days


Note You need to log in before you can comment on or make changes to this bug.