Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1849083 - NFS ISO installs fail since anaconda-33.18-1.fc33 if ISO name is included in repo definition
Summary: NFS ISO installs fail since anaconda-33.18-1.fc33 if ISO name is included in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.3
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: 8.3
Assignee: Jiri Konecny
QA Contact: Release Test Team
URL:
Whiteboard: openqa
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-19 15:13 UTC by Jiri Konecny
Modified: 2020-11-04 03:25 UTC (History)
13 users (show)

Fixed In Version: anaconda-33.16.3.9-1
Doc Type: No Doc Update
Doc Text:
Clone Of: 1848718
Environment:
Last Closed: 2020-11-04 03:23:49 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4729 0 None None None 2020-11-04 03:24:15 UTC

Description Jiri Konecny 2020-06-19 15:13:51 UTC
This bug from Fedora is reproducible in RHEL-8.3 too and it should be fixed there.

There is already fix proposed upstream. See below.

+++ This bug was initially created as a clone of Bug #1848718 +++

This is a follow-up to https://bugzilla.redhat.com/show_bug.cgi?id=1844287 specifically for this NFS ISO case, which appears to be unambiguously broken.

This is supposed to work: `inst.repo=nfs:nfsvers=4:10.0.2.110:/iso/image.iso` , assuming 10.0.2.110:/iso/ is a valid and accessible NFS share, and it contains the file 'image.iso', which is an installer image with a file repo on it (i.e. a DVD image). anaconda should mount 10.0.2.110:/iso , loopback mount the specified ISO file from it, and use the repository from within the image. This is what the test case https://fedoraproject.org/wiki/QA:Testcase_install_repository_NFSISO_variation covers. Up till anaconda-33.18-1.fc33 , that's what happened.

Since that build, though, it doesn't work any more. Instead, anaconda tries literally to mount '10.0.2.110:/iso/image.iso', and that fails:

18:01:40,672 WARNING org.fedoraproject.Anaconda.Modules.Payloads:DEBUG:anaconda.modules.payloads.source.nfs.initialization:Setting up NFS source: nfs:nfsvers=4:10.0.2.110:/iso/image.iso
18:01:40,673 WARNING org.fedoraproject.Anaconda.Modules.Payloads:INFO:program:Running... mount -t nfs -o nfsvers=4,nolock 10.0.2.110:/iso/image.iso /run/install/source/mount-0000-nfs-device
18:01:40,779 NOTICE kernel:FS-Cache: Loaded
18:01:40,903 NOTICE kernel:FS-Cache: Netfs 'nfs' registered for caching
18:01:40,927 NOTICE kernel:Key type dns_resolver registered
18:01:41,158 NOTICE kernel:NFS: Registering the id_resolver key type
18:01:41,158 NOTICE kernel:Key type id_resolver registered
18:01:41,158 NOTICE kernel:Key type id_legacy registered
18:01:41,269 INFO kernel:mount.nfs (1899) used greatest stack depth: 12072 bytes left
18:01:41,271 WARNING org.fedoraproject.Anaconda.Modules.Payloads:INFO:program:stderr:
18:01:41,271 WARNING org.fedoraproject.Anaconda.Modules.Payloads:INFO:program:b'mount.nfs: mount spec 10.0.2.110:/iso/image.iso or point /run/install/source/mount-0000-nfs-device is not a directory'

I guess it may work if you do it the other possible way - just specifying `inst.repo=nfs:nfsvers=4:10.0.2.110:/iso` and relying on anaconda to look through the mount and find the ISO file - but both methods are meant to work, and the one that's failing is the one we use in the openQA test.

Proposing as a Final blocker as a violation of "The installer must be able to use all supported local and remote package and installer sources" - https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria#package-and-installer-sources . It's a *bit* arguable as there is the option of not specifying the ISO name, but that option does exist for a reason: if the share contains multiple ISO files, you may need to explicitly specify the right one.

--- Additional comment from Adam Williamson on 2020-06-19 00:30:31 UTC ---

So it looks to me like jknoecny completely rewrote this code, initially left out ISO support entirely, then added it back in in https://github.com/rhinstaller/anaconda/commit/af627cd8f68406896b4684ac5b634208d1365f40 but didn't handle this specific path - that code doesn't seem to have any way of accounting for the possibility of the ISO name being specified in the argument. So I think that needs to be added back. If he has time for this I'll leave this to Jiri as I guess he knows how the new code works so he knows where it would make sense to do the parsing for this :)

--- Additional comment from Jiri Konecny on 2020-06-19 08:03:59 UTC ---

Interesting, I thought I've added this possibility in. I'll try to fix this soon. Thanks a lot for investigating.

--- Additional comment from Jiri Konecny on 2020-06-19 11:45:42 UTC ---

PR: https://github.com/rhinstaller/anaconda/pull/2673

Comment 1 Jiri Konecny 2020-06-22 16:21:19 UTC
PR: https://github.com/rhinstaller/anaconda/pull/2677

Comment 6 Jiri Konecny 2020-08-26 11:30:40 UTC
*** Bug 1848253 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2020-11-04 03:23:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (anaconda bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4729


Note You need to log in before you can comment on or make changes to this bug.