Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1852577 - "dnf history list" displays an erratic output
Summary: "dnf history list" displays an erratic output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: nsella
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1862007 1888216 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-30 18:09 UTC by ruben.lledo.calatayud
Modified: 2021-03-24 19:56 UTC (History)
13 users (show)

Fixed In Version: dnf-4.6.1-1.fc33 dnf-4.6.1-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-05 19:16:47 UTC
Type: Bug


Attachments (Terms of Use)
Expected result (145.38 KB, image/png)
2020-06-30 18:09 UTC, ruben.lledo.calatayud
no flags Details
Wrong output (40.76 KB, image/png)
2020-06-30 18:10 UTC, ruben.lledo.calatayud
no flags Details

Description ruben.lledo.calatayud 2020-06-30 18:09:09 UTC
Created attachment 1699376 [details]
Expected result

Description of problem:
"dnf history list" displays an erractic output when piped through any other command, for example, "more" or "head":

$ dnf history list | head
$ dnf history list | more

Version-Release number of selected component (if applicable):
dnf-4.2.23

How reproducible:

Steps to Reproduce:
Type in a shell:
$ dnf history list | head
$ dnf history list | more

Actual results:
(see attached screenshot)

Expected results:
(see attached screenshot)


Additional info:

Comment 1 ruben.lledo.calatayud 2020-06-30 18:10:14 UTC
Created attachment 1699377 [details]
Wrong output

Comment 3 nsella 2020-10-26 18:01:02 UTC
*** Bug 1862007 has been marked as a duplicate of this bug. ***

Comment 4 nsella 2020-10-27 09:34:58 UTC
*** Bug 1888216 has been marked as a duplicate of this bug. ***

Comment 5 George 2020-12-10 23:32:30 UTC
This is also an issue in RHEL8.
Any need to raise a separate bug report?

Comment 6 Daniel Mach 2020-12-11 09:59:34 UTC
Yes please, it's a different distro, having a separate bug report from a user would be great.
(we try not to file the bugs by ourselves because it hides the requester and breaks the feedback loop)

Comment 8 Fedora Update System 2021-03-02 16:42:10 UTC
FEDORA-2021-4bef57b401 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4bef57b401

Comment 9 Fedora Update System 2021-03-02 16:42:10 UTC
FEDORA-2021-4d7356a470 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4d7356a470

Comment 10 Fedora Update System 2021-03-02 16:42:11 UTC
FEDORA-2021-530abc3f9a has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-530abc3f9a

Comment 11 Fedora Update System 2021-03-03 15:46:25 UTC
FEDORA-2021-4bef57b401 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4bef57b401`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4bef57b401

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-03-03 23:04:38 UTC
FEDORA-2021-530abc3f9a has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-530abc3f9a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-530abc3f9a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2021-03-03 23:52:22 UTC
FEDORA-2021-4d7356a470 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4d7356a470`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4d7356a470

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-03-05 19:16:47 UTC
FEDORA-2021-4d7356a470 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2021-03-23 00:15:26 UTC
FEDORA-2021-4bef57b401 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2021-03-23 01:10:55 UTC
FEDORA-2021-530abc3f9a has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Kamil Páral 2021-03-24 08:20:12 UTC
I can confirm that `sudo dnf history | less` (or head) no longer breaks the output.
dnf-4.6.1-1.fc33.noarch

Comment 18 ruben.lledo.calatayud 2021-03-24 19:56:24 UTC
Hello.

Fixed. Thank you very much.

Regards.


Note You need to log in before you can comment on or make changes to this bug.