Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1861055 - hplip: remove threading.Thread.isAlive method calls - use threading.Thread.is_alive()
Summary: hplip: remove threading.Thread.isAlive method calls - use threading.Thread.is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-27 17:19 UTC by Dennis Gilmore
Modified: 2020-08-19 01:01 UTC (History)
4 users (show)

Fixed In Version: hplip-3.20.6-6.fc32 hplip-3.20.6-6.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-06 04:03:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Dennis Gilmore 2020-07-27 17:19:34 UTC
Description of problem:

trying to scan a document with hp-scan I get the following traceback 

Page 1: Scanning...
Closing device.
Traceback (most recent call last):
  File "/usr/bin/hp-scan", line 1315, in <module>
    device.waitForScanActive()
  File "/usr/share/hplip/scan/sane.py", line 403, in waitForScanActive
    if self.scan_thread.isAlive() and \
AttributeError: 'ScanThread' object has no attribute 'isAlive'

Version-Release number of selected component (if applicable):
hplip-3.20.6-1.fc33.x86_64

How reproducible:
always 

Steps to Reproduce:
1. hp-scan --adf -o out.pdf -d hpaio:/net/HP_Color_LaserJet_MFP_M277dw?ip=x.x.x.x -m lineart
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Zdenek Dohnal 2020-07-28 15:47:04 UTC
Hi Dennis,

thank you for reporting the issue!

Python3.9 removed isAlive() method from threading.Thread module, replaced by is_alive().

I'll check if I can reproduce with hp-scan and my HP device, otherwise I would like you to check the fix.

Comment 2 Zdenek Dohnal 2020-07-28 15:55:35 UTC
Yep, I'm able to reproduce with my model.

Comment 3 Zdenek Dohnal 2020-07-28 16:32:21 UTC
Sent upstream https://bugs.launchpad.net/fedora/+bug/1889280 .

Comment 4 Zdenek Dohnal 2020-07-29 06:36:57 UTC
I'm not able to build hplip at the moment because configure script is not able to find out net-snmp. I alerted net-snmp maintainer about the issue and we will look into it.

Comment 5 Fedora Update System 2020-08-04 13:53:26 UTC
FEDORA-2020-faafe0da41 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-faafe0da41

Comment 6 Fedora Update System 2020-08-04 13:53:27 UTC
FEDORA-2020-5d6040ce38 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-5d6040ce38

Comment 7 Fedora Update System 2020-08-05 01:05:39 UTC
FEDORA-2020-faafe0da41 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-faafe0da41`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-faafe0da41

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-08-05 01:21:30 UTC
FEDORA-2020-5d6040ce38 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-5d6040ce38`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-5d6040ce38

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-08-06 04:03:08 UTC
FEDORA-2020-5d6040ce38 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-08-19 01:01:18 UTC
FEDORA-2020-faafe0da41 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.