Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1863126 - VirtualGL: FTBFS in Fedora rawhide/f33
Summary: VirtualGL: FTBFS in Fedora rawhide/f33
Alias: None
Product: Fedora
Classification: Fedora
Component: VirtualGL
Version: 33
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Gary Gatling
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2020-08-03 15:06 UTC by Fedora Release Engineering
Modified: 2021-01-27 06:03 UTC (History)
2 users (show)

Fixed In Version: VirtualGL-2.6.3-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2021-01-27 01:18:10 UTC
Type: ---

Attachments (Terms of Use)

Description Fedora Release Engineering 2020-08-03 15:06:29 UTC
VirtualGL failed to build from source in Fedora rawhide/f33

For details on the mass rebuild see:
Please fix VirtualGL at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
VirtualGL will be orphaned. Before branching of Fedora 34,
VirtualGL will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:

Comment 1 Ben Cotton 2020-08-11 13:53:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 2 Raphael Groner 2021-01-17 16:29:57 UTC
Propably duplication of bug #1799136 (F32 FTBFS).

Comment 3 Gary Gatling 2021-01-17 16:45:19 UTC
I'd like to try to fix this if I can. I made a rpm for version 2.6.3. I could upload it but it won't build in mock on rawhide. Let me copy the output and the spec file so you could look at it. If you can help me troubleshoot what I'm doing wrong that would be so helpful. It works in fedora 32 I think but not fedora 33 or rawhide. Let me get that ready.

Comment 4 Raphael Groner 2021-01-17 16:49:31 UTC
Yes, I'm interested. Maybe you can add me as co-maintainer?

Broken builds are generally no issue at all in rawhide and quite common though. So we'd not worry that much.

Comment 5 Raphael Groner 2021-01-17 16:49:53 UTC
*** Bug 1799136 has been marked as a duplicate of this bug. ***

Comment 6 Raphael Groner 2021-01-17 16:51:33 UTC
Needs fix in rawhide/F34, F33, F32 (in case not EOL'ed before).

Comment 7 Gary Gatling 2021-01-17 16:52:55 UTC
Yes. Co maintainer would be awesome. Thank you for your kind offer.

The problem is that it started saying as an error:

make: *** No targets specified and no makefile found.  Stop.

Comment 8 Gary Gatling 2021-01-17 17:01:10 UTC
Also, I tried adding 

BuildRequires:  make 

but I still get the same error.

Comment 9 Raphael Groner 2021-01-17 17:05:57 UTC
> make: *** No targets specified and no makefile found.  Stop.

That means cmake fails to create any Makefile. Please share the full output of cmake for better debug purpose, see below for a snippet.

> BuildRequires:  make 

Yes please explicitly add this line as it's generally requested on devel mailing list.

DEBUG: Executing command: ['btrfs', 'subv', 'list', '/var/lib/mock'] with env {'TERM': 'vt100', 'SHELL': '/bin/sh', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'LANG': 'C.UTF-8'} and shell False
DEBUG: ERROR: not a btrfs filesystem: /var/lib/mock
DEBUG: ERROR: can't access '/var/lib/mock'

... maybe is there a general issue with your builder machine? Please try to build within official koji or copr to have a proper base system.

Comment 10 Gary Gatling 2021-01-17 17:19:49 UTC
Ok. Let me try to build that in koji. Sorry about that.

Comment 11 Gary Gatling 2021-01-17 18:42:33 UTC
Ok. I am on a fedora 32 system.  

It builds ok with 

fedpkg local

but gives me the same problem with 

fedpkg mockbuild

make: *** No targets specified and no makefile found.  Stop.

Trying a scratch build.

Thanks for any ideas you might have.

Comment 12 Raphael Groner 2021-01-17 18:59:33 UTC
From build.log:

-- Could NOT find FLTK (missing: FLTK_FLUID_EXECUTABLE)

Obviously missing BuildRequires: fltk-fluid

You may have successfully installed the fltk-fluid subpackage locally but that's not explicitly referenced in spec file for mock and koji.

Comment 13 Gary Gatling 2021-01-17 19:22:17 UTC
I did not have fltk-fluid installed locally but I am trying again with it installed to make srpm.

Thanks a lot.

Comment 14 Raphael Groner 2021-01-17 20:07:33 UTC
%cmake macro got changed for out-of-source builds. You may need to migrate:

Comment 15 Gary Gatling 2021-01-17 20:53:05 UTC
Thanks a lot. Trying another build now.

Comment 16 Gary Gatling 2021-01-17 21:02:30 UTC
Ok. I started installing a box here I can use to test this version of the software. I should know more within 1-2 hours. Its installing the packages now. I'll upload this if it tests out ok.

Comment 17 Gary Gatling 2021-01-17 23:06:42 UTC
Sorry. Had to make some slight changes for epel. Now it builds in mock on fedora 32,33,34 and el7,el8. Re-trying.

Like there is no fltk-fluid rpm in epel 8 but it still builds ok. So I made a conditional. Also still had to use make for el7.

But my test machine has fedora on it. I will test rhel 7 and 8 after I verify fedora works.

Comment 18 Raphael Groner 2021-01-18 05:07:39 UTC
Ok, cool. I'm happy to can help.

Do you know if VirtualGL package works in combination with xpra? Or for what applications do you use it?

Comment 19 Gary Gatling 2021-01-18 05:19:50 UTC
I don't use it very much any longer but mainly I was using it with hybrid graphics. When I did use it I used it with java minecraft a lot.

I have a faculty member that wanted to use it with Agisoft Metashape. 

I am unsure if it could work with Xpra. I am almost finished with testing the package. I will push the new version up
after I finish the test on el8 server and sleep. It has worked as expected so far with glxgears on el7 and fedora. Thank you so much for getting me past this build problem.

Comment 20 Raphael Groner 2021-01-18 05:52:00 UTC
> Agisoft Metashape

Looks interesting, thanks for the hint. I'm working for a faculty, too.

Comment 21 Fedora Update System 2021-01-18 18:06:37 UTC
FEDORA-2021-73b44548b5 has been submitted as an update to Fedora 33.

Comment 22 Fedora Update System 2021-01-19 01:52:12 UTC
FEDORA-2021-73b44548b5 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-73b44548b5`
You can provide feedback for this update here:

See also for more information on how to test updates.

Comment 23 Raphael Groner 2021-01-24 16:37:13 UTC
There's a pull request for new version 2.6.5 and to drop the mesa patch:

Comment 24 Gary Gatling 2021-01-24 16:42:38 UTC
Hi. I'm hoping to work on this later tonight or tomorrow. I had to get some other stuff finished yesterday. I feel an obligation to test any changes with a VirtualGL server and a VirtualGL client with the changes to 2.6.5. Which I need to do with real PCs and not vms. I will set up my lab again this afternoon. But Have to re-install the PC which currently has another OS on it.

Comment 25 Raphael Groner 2021-01-24 18:34:44 UTC
No worries, please take your time. Thanks for caring.

Comment 26 Fedora Update System 2021-01-27 01:18:10 UTC
FEDORA-2021-73b44548b5 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.