Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1882722 - akmod-nvidia KEY failing for Fedora 33 Snapshot
Summary: akmod-nvidia KEY failing for Fedora 33 Snapshot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution-gpg-keys
Version: 33
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-25 12:50 UTC by Rodrigo Dlugokenski
Modified: 2020-10-12 12:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-12 12:10:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
screenshot of `dnf install akmod-nvidia` failing (deleted)
2020-10-01 21:24 UTC, Michel Lind
no flags Details


Links
System ID Private Priority Status Summary Last Updated
RPM Fusion 5767 0 None None None 2020-09-25 12:50:33 UTC

Description Rodrigo Dlugokenski 2020-09-25 12:50:34 UTC
Description of problem:

Hi all! I'm trying to test a snapshot of Fedora 33 branched from Sept 22 (but updated yesterday and today) on a nvidia + intel hybrid graphics.

So I enabled RPM Fusion free and non-free. Then I tried to `sudo dnf install akmod-nvidia` after `sudo dnf update -y` and I'm getting this in the middle of nvidia installation:

```
warning: /var/cache/dnf/rpmfusion-nonfree-nvidia-driver-f70ac34e95cd3d35/packages/akmod-nvidia-450.66-1.fc33.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID 94843c65: NOKEY
RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver                                                                                                            0.0  B/s |   0  B     00:00    
Curl error (37): Couldn't read a file:// file for file:///usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33 [Couldn't open file /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33]
```

I saw that the file asked is really non-existant. 


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install a fedora 33 snapshot from scratch
2. Enable RPM Fusion free and non free
3. Try to dnf install akmod-nvidia on gnome terminal

Actual results:

It gives key errors for rpm fusion in the middle of installation.


Expected results:

Installing nvidia just fine.


Additional info:

Forced my hand by using the rawhide key

`sudo ln -s /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-rawhide /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33`

*It worked just fine after that.* 


Can you correct this key? Thanks very much!

Comment 1 Nicolas Chauvet (kwizart) 2020-09-25 13:11:45 UTC
With fedora 33 and later, the GPG key is the 2020 version, so there is a need to implement a symlink when fedora-workstation repositories and mock configs are using the version specific path.

Comment 2 Rodrigo 2020-09-30 19:24:29 UTC
Hello

Same issue here.

I managed to install the Nvidia driver by adding --nogpgcheck to the command.

sudo dnf --nogpgcheck install akmod-nvidia

So far, loving Fedora 33.

Thank you

Comment 3 Michel Lind 2020-10-01 21:24:06 UTC
Created attachment 1718317 [details]
screenshot of `dnf install akmod-nvidia` failing

same here. Provided is a screenshot of attempting to install akmod-nvidia on my test VM

Comment 4 Miroslav Suchý 2020-10-12 12:10:05 UTC
Should be resolved by
https://bodhi.fedoraproject.org/updates/FEDORA-2020-0508ca630a


Note You need to log in before you can comment on or make changes to this bug.