Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1886456 - prosody cannot find lua-socket/lua-bitopts
Summary: prosody cannot find lua-socket/lua-bitopts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: prosody
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-08 13:50 UTC by Christopher Engelhard
Modified: 2020-10-23 22:07 UTC (History)
2 users (show)

Fixed In Version: prosody-0.11.7-2.fc34 prosody-0.11.7-2.fc32 prosody-0.11.7-2.fc31 prosody-0.11.7-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-08 20:50:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Christopher Engelhard 2020-10-08 13:50:48 UTC
prosody 0.11.7 on rawhide fails with the following error message:

**************************
Prosody was unable to find luasocket
This package can be obtained in the following ways:
        Debian/Ubuntu:    sudo apt-get install lua-socket
        luarocks:         luarocks install luasocket
        Source:           http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/
luasocket is required for Prosody to run, so we will now exit.
More help can be found on our website, at https://prosody.im/doc/depends
**************************
**************************
Prosody was unable to find lua-bitops
This package can be obtained in the following ways:
        Debian/Ubuntu:    sudo apt-get install lua-bitop
        luarocks:         luarocks install luabitop
        Source:           http://bitop.luajit.org/
WebSocket support will not be available
More help can be found on our website, at https://prosody.im/doc/depends
**************************


How reproducible: Always
Steps to Reproduce:
1. Install prosody
2. Run e.g "prosodyctl cert create example.org" or start the prosody service

Actual results: Errors as described above
Expected results: Cert created / service started

Additional info: This happens both with the prosody service and any invocation of prosodyctl. I haven't tested it in F33 yet, F32 with prosody 0.11.5 works without issues.

Comment 1 Robert Scheck 2020-10-08 20:26:59 UTC
It looks like your Rawhide system is not fully up-to-date, please use lua-socket-3.0-0.26.rc1.fc34.x86_64 (or later).

The second part is https://issues.prosody.im/1395 - which I will address with patches. It only applies to Lua 5.4 based systems.

Comment 2 Fedora Update System 2020-10-08 20:54:11 UTC
FEDORA-2020-2557e90014 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-2557e90014

Comment 3 Fedora Update System 2020-10-08 22:20:48 UTC
FEDORA-2020-2557e90014 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-2557e90014`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-2557e90014

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Christopher Engelhard 2020-10-09 07:41:33 UTC
Yeah, my mistake, I forgot to check if all dependencies were up to date.

Your updated package fixes the bitopts-issue. Thanks a lot.

Comment 5 Fedora Update System 2020-10-09 08:08:17 UTC
FEDORA-2020-43dede6432 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-43dede6432

Comment 6 Fedora Update System 2020-10-09 08:09:03 UTC
FEDORA-2020-4151f52ad2 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4151f52ad2

Comment 7 Robert Scheck 2020-10-09 08:14:59 UTC
Thank you for the report anyway!

Comment 8 Fedora Update System 2020-10-09 16:37:57 UTC
FEDORA-2020-43dede6432 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-43dede6432`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-43dede6432

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-10-09 16:52:49 UTC
FEDORA-2020-4151f52ad2 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4151f52ad2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4151f52ad2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-10-17 14:08:41 UTC
FEDORA-2020-43dede6432 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-10-17 14:24:13 UTC
FEDORA-2020-4151f52ad2 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2020-10-23 22:07:14 UTC
FEDORA-2020-2557e90014 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.