Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1904652 - Falkon does not render text in some websites
Summary: Falkon does not render text in some websites
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-12-05 09:58 UTC by Mattia Verga
Modified: 2021-01-23 09:38 UTC (History)
5 users (show)

Fixed In Version: qt5-qtwebengine-5.15.2-5.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-23 09:38:19 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Koji website rendering broken (deleted)
2020-12-05 09:58 UTC, Mattia Verga
no flags Details


Links
System ID Private Priority Status Summary Last Updated
chromium.org chromium 1164975 0 None None None 2021-01-14 11:23:19 UTC

Description Mattia Verga 2020-12-05 09:58:10 UTC
Created attachment 1736626 [details]
Koji website rendering broken

I'm using falkon as primary browser in a virtual machine running Rawhide I use for development.
I've noticed that some website, most notably Koji, are completely broken and unusable - see the attached screenshot.
I've already tried to disable AdBlocker on the affected websites with no luck.

Comment 1 Kevin Kofler 2020-12-05 12:29:59 UTC
This is most likely a regression in QtWebEngine, reassigning.

I also made the subject clearer: the issue appears to be that the text is not being rendered, only the images. (The only "text" in the Koji web site's page on your screenshot is actually part of the logo image.)

Comment 2 Kevin Kofler 2020-12-05 12:30:50 UTC
Actually, since this is a rendering issue, it could also be a graphics driver bug. What graphics hardware and driver are you using? Can anybody reproduce this on other hardware?

Comment 3 Kevin Kofler 2020-12-05 12:32:18 UTC
(You say the "hardware" here is a virtual machine, but what virtual machine? And does it have OpenGL passthrough? In that case, the host hardware also matters.)

Comment 4 Mattia Verga 2020-12-05 13:23:31 UTC
It's a QEMU/KVM virtual machine, with Virtio video driver with 3d acceleration enabled and Spice monitor with OpenGL disabled.

I've also tried to disable 3d acceleration and switch to QXL video driver, but the result doesn't change. The problem seems independent from the video driver used. Just use default settings from Virtual Machine Manager to create a Fedora rawhide machine.

Comment 5 Kevin Kofler 2021-01-11 22:35:17 UTC
Nominating as a blocker for F34 Beta under Basic Criterion 2.5.8 Required applications. If this is rejected, nominating as a blocker for F34 Final under Final Criterion 2.6.7 Default application functionality.

Comment 6 Kevin Kofler 2021-01-11 22:38:19 UTC
FYI, this has since also been confirmed in Chromium, and this mailing list thread:
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/OK3ZF3554P4D5NUGW3BJMR2R7WONIFUY/#OK3ZF3554P4D5NUGW3BJMR2R7WONIFUY
has some insights. Basically, it was tracked down to a sandbox issue affecting the Chromium code if it was compiled against glibc 2.23. We are not yet sure why the version used at compile time matters (because the syscall use changes are normally in the glibc .c files, not the headers) nor what exact syscall is being blocked by the sandbox.

Comment 7 Kevin Kofler 2021-01-11 22:53:19 UTC
> against glibc 2.23

2.33, actually

Comment 8 Kevin Kofler 2021-01-20 01:54:18 UTC
I'm trying to build a candidate fix (that I wrote) now:
https://src.fedoraproject.org/rpms/qt5-qtwebengine/blob/master/f/qtwebengine-everywhere-src-5.15.2-%231904652.patch

Comment 9 Kevin Kofler 2021-01-20 02:10:08 UTC
Unfortunately, I cannot move forward because qt5-qtwebengine FTBFS due to a GCC or Gold issue:

/usr/bin/ld.gold: warning: /usr/lib/gcc/x86_64-redhat-linux/11/../../../../lib64/Scrt1.o: unknown program property type 0xc0008002 in .note.gnu.property section
/usr/bin/ld.gold: error: treating warnings as errors
collect2: error: ld returned 1 exit status

Comment 10 Kevin Kofler 2021-01-22 14:00:09 UTC
The Binutils (gold) issue is fixed, resubmitting the qt5-qtwebengine build.

Comment 11 Kevin Kofler 2021-01-22 15:15:26 UTC
Can you please try qt5-qtwebengine-5.15.2-5.fc34? For now, you can get it from:
https://koji.fedoraproject.org/koji/taskinfo?taskID=60219042
(The 2 ARM arches are still building, and then it will also take hours to get into an actual Rawhide compose.)

Comment 12 Mattia Verga 2021-01-22 16:56:46 UTC
A first try seems not promising... I'm now fully upgrading my Rawhide VM, I'll post results later.

Comment 13 Kevin Kofler 2021-01-22 17:03:41 UTC
Do you have qt5-qtwebengine-freeworld installed? If yes, you need to uninstall it for now, until a fix is applied there too.

If the candidate fix is not working, we will probably need to find a way to debug this further (which is quite hard, sandbox code is a pain to debug), unless upstream magically comes up with something that works.

Comment 14 Mattia Verga 2021-01-22 17:45:44 UTC
qt5-qtwebengine-freeworld is not installed.

I'm afraid that this qt5-qtwebengine update is completely broken, now I can't open any webpage.
I tried with WebEngine Qt Quick Minimal Example from within QT Creator (https://doc.qt.io/qt-5/qtwebengine-webengine-minimal-example.html) and no page is displayed. In the application output tab it shows
`../../3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0262`

Falkon shows the same error message when started in console.

Comment 15 Kevin Kofler 2021-01-22 17:53:48 UTC
Thanks for your feedback. The build was still running on the ARM architectures, so I simply canceled it. Hence, the output should not end up in the Rawhide compose.

Comment 16 Kevin Kofler 2021-01-22 18:16:34 UTC
I think I know what is going wrong. I have revised the patch:
https://src.fedoraproject.org/rpms/qt5-qtwebengine/c/09e1adb883639325aa8115dc1fc3e8f5088a2438?branch=master
and I am building the revised candidate patch now:
https://koji.fedoraproject.org/koji/taskinfo?taskID=60237992

I will let you know when there is a binary RPM to test.

Comment 17 Kevin Kofler 2021-01-22 21:13:25 UTC
Can you please try this version?
https://koji.fedoraproject.org/koji/taskinfo?taskID=60238322

Comment 18 Kevin Kofler 2021-01-23 00:09:09 UTC
I tested this myself and it seems to work now!

1. fired up Fedora-KDE-Live-x86_64-Rawhide-20210120.n.0.iso in QEMU-KVM
2. started Falkon
3. opened https://koji.fedoraproject.org/koji/
4. confirmed that text rendering (without the fix) is broken
5. closed Falkon
6. upgraded qt5-qtwebengine to the RPM from https://koji.fedoraproject.org/koji/taskinfo?taskID=60238322
7. reopened Falkon
8. opened https://koji.fedoraproject.org/koji/
9. confirmed that text rendering is now working

Mattia, can you please confirm that this is also fixed for you, so that I can close this (at least once the ARM arches are built, too)?

Comment 19 Mattia Verga 2021-01-23 07:54:03 UTC
Yes, I've tested both Falkon and the qt5 creator example and both are working now. Thank you!


Note You need to log in before you can comment on or make changes to this bug.