Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1915541 - initial-setup fails - 'NoneType' object has no attribute 'liveinst'
Summary: initial-setup fails - 'NoneType' object has no attribute 'liveinst'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1916036 (view as bug list)
Depends On:
Blocks: F34BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-01-12 21:03 UTC by Paul Whalen
Modified: 2021-01-26 14:17 UTC (History)
12 users (show)

Fixed In Version: anaconda-34.18-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-26 14:17:18 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journalctl (deleted)
2021-01-12 21:08 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2021-01-12 21:03:44 UTC
Description of problem:
Initial-setup fails in the latest rawhide compose(Fedora-Rawhide-20210112.n.0)

Version-Release number of selected component (if applicable):
initial-setup-0.3.85-1.fc34

How reproducible:
Everytime


Actual results:

Traceback (most recent call last):
                                             File "/usr/libexec/initial-setup/initial-setup-text", line 10, in <module>
                                               is_instance.run()
                                             File "/usr/lib/python3.9/site-packages/initial_setup/__init__.py", line 415, in run
                                               ui.setup(self.data)
                                             File "/usr/lib/python3.9/site-packages/initial_setup/tui/tui.py", line 279, in setup
                                               TextUserInterface.setup(self, data)
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/ui/tui/__init__.py", line 204, in s>
                                               should_schedule = obj.setup(self.ENVIRONMENT)
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/ui/tui/hubs/__init__.py", line 67, >
                                               cats_and_spokes = self._collectCategoriesAndSpokes()
                                             File "/usr/lib/python3.9/site-packages/initial_setup/tui/hubs/initial_setup_hub.py", li>
                                               return common.collectCategoriesAndSpokes(self, TUI_spoke_class)
                                             File "/usr/lib/python3.9/site-packages/initial_setup/common.py", line 63, in collectCat>
                                               candidate_spokes = collect_spokes(hub_instance.paths["spokes"], spoke_parent_class)
                                             File "/usr/lib/python3.9/site-packages/initial_setup/common.py", line 40, in collect_sp>
                                               spokes.extend(collect(mask, path,
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/core/util.py", line 1307, in collect
                                               members = [(name, getattr(module, name))
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/core/util.py", line 1309, in <listc>
                                               if p(getattr(module, name))]
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/core/util.py", line 1301, in <lambd>
                                               p = lambda obj: inspect.isclass(obj) and pred(obj)
                                             File "/usr/lib/python3.9/site-packages/initial_setup/common.py", line 41, in <lambda>
                                               lambda obj: issubclass(obj, spoke_parent_class) and obj.should_run("firstboot", None)>
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/ui/tui/spokes/installation_source.p>
                                               return context.payload.type == PAYLOAD_TYPE_DNF
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/ui/context.py", line 51, in payload
                                               return self._anaconda.payload
                                             File "/usr/lib64/python3.9/site-packages/pyanaconda/anaconda.py", line 92, in payload
                                               elif self.opts.liveinst:
                                           AttributeError: 'NoneType' object has no attribute 'liveinst'


Additional info:

Working with yesterdays compose(Fedora-Rawhide-20210111.n.0).

Comment 1 Paul Whalen 2021-01-12 21:08:01 UTC
Created attachment 1746809 [details]
journalctl

Comment 2 Paul Whalen 2021-01-12 21:08:10 UTC
Fedora-Rawhide-20210112.n.0 included anaconda-34.17-1.fc34

Comment 3 Vendula Poncova 2021-01-13 16:13:27 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/3089

Comment 4 Vendula Poncova 2021-01-14 10:18:55 UTC
*** Bug 1916036 has been marked as a duplicate of this bug. ***

Comment 5 Martin Kolman 2021-01-18 17:07:26 UTC
Anaconda with the fix is now being built: https://koji.fedoraproject.org/koji/taskinfo?taskID=59971548

Comment 6 Paul Whalen 2021-01-26 14:17:18 UTC
Initial-setup working in Fedora-Rawhide-20210124.n.0 (anaconda-34.20-1.fc34). Thanks!


Note You need to log in before you can comment on or make changes to this bug.