Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1924284 - F34FailsToInstall: ocaml-dose3, ocaml-dose3-devel
Summary: F34FailsToInstall: ocaml-dose3, ocaml-dose3-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml-dose3
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F34BetaFreezeException F34FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-02-02 21:55 UTC by Miro Hrončok
Modified: 2021-03-12 01:35 UTC (History)
6 users (show)

Fixed In Version: ocaml-dose3-5.0.1-32.20200502git24316fe.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-12 01:35:47 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-02-02 21:55:15 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (ocaml-dose3) Fails To Install in Fedora 34:

can't install ocaml-dose3:
  - nothing provides ocaml(Re__) = 787224c2ee75334ebb3c52123befbf81 needed by ocaml-dose3-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Graph) = 0b727bd03b5405088c86229f3761d2b0 needed by ocaml-dose3-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Re) = 3c41895d2fce7f00ca849515617c7b16 needed by ocaml-dose3-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Re__Pcre) = 990812e344f3cb2eb627335e3c7e785f needed by ocaml-dose3-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Re__Str) = 5b7d489f4dbd72da08a0ef625b15b188 needed by ocaml-dose3-5.0.1-31.20200502git24316fe.fc34.x86_64
  
can't install ocaml-dose3-devel:
  - nothing provides ocaml(Re__) = 787224c2ee75334ebb3c52123befbf81 needed by ocaml-dose3-devel-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Graph) = 0b727bd03b5405088c86229f3761d2b0 needed by ocaml-dose3-devel-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Re) = 3c41895d2fce7f00ca849515617c7b16 needed by ocaml-dose3-devel-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Re__Pcre) = 990812e344f3cb2eb627335e3c7e785f needed by ocaml-dose3-devel-5.0.1-31.20200502git24316fe.fc34.x86_64
  - nothing provides ocamlx(Re__Str) = 5b7d489f4dbd72da08a0ef625b15b188 needed by ocaml-dose3-devel-5.0.1-31.20200502git24316fe.fc34.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/rawhide-gating/multi-builds/

Thanks!

Comment 1 Ben Cotton 2021-02-09 16:02:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-02-10 09:21:09 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Miro Hrončok 2021-03-02 15:24:02 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!

Comment 4 Richard W.M. Jones 2021-03-02 16:54:09 UTC
Rebuilt in https://koji.fedoraproject.org/koji/taskinfo?taskID=62947368

I'm also going to rebuild some dependent packages in F34.

Comment 5 Richard W.M. Jones 2021-03-02 16:54:39 UTC
Sorry, didn't mean to close this.

Comment 6 Fedora Update System 2021-03-02 16:59:27 UTC
FEDORA-2021-bc3d785335 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bc3d785335

Comment 7 Fedora Blocker Bugs Application 2021-03-02 23:23:44 UTC
Proposed as a Freeze Exception for 34-beta by Fedora user churchyard using the blocker tracking app because:

 Fixes installability.

Comment 8 Fedora Update System 2021-03-03 15:46:27 UTC
FEDORA-2021-bc3d785335 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-bc3d785335`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-bc3d785335

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Lukas Ruzicka 2021-03-08 11:29:13 UTC
I can confirm that with this update, ocaml-dose3 and ocaml-dose3-devel can be installed.

Comment 10 Geoffrey Marr 2021-03-08 19:50:19 UTC
Discussed during the 2021-03-08 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException (Beta)" was made as we agree that an FE is generally merited if a package fails to install due to the impact on people upgrading from previous stable releases, likely without updates-testing enabled. However, fixes will only be pushed if they involve minimal change and don't seem likely to endanger compose of release-blocking images.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-03-08/f34-blocker-review.2021-03-08-17.00.txt

Comment 11 Miro Hrončok 2021-03-08 22:17:56 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 34.

Thanks for taking care of it!

Comment 12 Adam Williamson 2021-03-09 00:46:08 UTC
Miro, your script seems to not consider stable pushes...

Comment 13 Richard W.M. Jones 2021-03-09 08:40:08 UTC
(In reply to Geoffrey Marr from comment #10)
> Discussed during the 2021-03-08 blocker review meeting: [0]
> 
> The decision to classify this bug as an "AcceptedFreezeException (Beta)" was
> made as we agree that an FE is generally merited if a package fails to
> install due to the impact on people upgrading from previous stable releases,
> likely without updates-testing enabled. However, fixes will only be pushed
> if they involve minimal change and don't seem likely to endanger compose of
> release-blocking images.
> 
> [0]
> https://meetbot.fedoraproject.org/fedora-blocker-review/2021-03-08/f34-
> blocker-review.2021-03-08-17.00.txt

I'm not sure what any of this means, but this package is not a very
important one so I wouldn't delay anything on account of this package.

Comment 14 Miro Hrončok 2021-03-09 09:27:59 UTC
(In reply to Adam Williamson from comment #12)
> Miro, your script seems to not consider stable pushes...

The script closes this bugzilla when the package is installable in the Koji buildroot. The build is tagged to f34-override, hence the bug is "fixed".

However, to avoid interfering with Bodhi updates, if the bug is in MODIFIED or ON_QA, the script does not close it.

The state was VERIFIED, which cannot be set by Bodhi, and hence the script closed the buzgilla.

If you want to change that, https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py#_334 (search for ON_QA).

Comment 15 Fedora Update System 2021-03-12 01:35:47 UTC
FEDORA-2021-bc3d785335 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.