Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1926217 - python-network-runner fails to build with Python 3.10: ImportError: cannot import name 'MutableMapping' from 'collections'
Summary: python-network-runner fails to build with Python 3.10: ImportError: cannot im...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-network-runner
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Radez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969045 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35FTBFS F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-02-08 13:12 UTC by Tomáš Hrnčiar
Modified: 2021-06-16 23:57 UTC (History)
3 users (show)

Fixed In Version: 0.3.6
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-16 23:57:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ansible-network network-runner pull 66 0 None open import abstract base classes from second level module 2021-06-16 01:09:26 UTC

Description Tomáš Hrnčiar 2021-02-08 13:12:32 UTC
python-network-runner fails to build with Python 3.10.0a5.
==================================== ERRORS ====================================
___________________ ERROR collecting tests/unit/test_api.py ____________________
ImportError while importing test module '/builddir/build/BUILD/network-runner-0.2.2/tests/unit/test_api.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/unit/test_api.py:19: in <module>
    from network_runner.models import playbook
network_runner/models/playbook.py:19: in <module>
    from network_runner.types.objects import Object
network_runner/types/objects.py:23: in <module>
    from network_runner.types.attrs import Attribute
network_runner/types/attrs.py:24: in <module>
    from network_runner.types.containers import Map
network_runner/types/containers.py:21: in <module>
    from collections import MutableMapping, MutableSequence
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
________________ ERROR collecting tests/unit/test_resources.py _________________
ImportError while importing test module '/builddir/build/BUILD/network-runner-0.2.2/tests/unit/test_resources.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/unit/test_resources.py:16: in <module>
    from . import base
tests/unit/base.py:19: in <module>
    from network_runner import api
network_runner/api.py:23: in <module>
    from network_runner.models.playbook import Playbook
network_runner/models/playbook.py:19: in <module>
    from network_runner.types.objects import Object
network_runner/types/objects.py:23: in <module>
    from network_runner.types.attrs import Attribute
network_runner/types/attrs.py:24: in <module>
    from network_runner.types.containers import Map
network_runner/types/containers.py:21: in <module>
    from collections import MutableMapping, MutableSequence
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
_______________ ERROR collecting tests/unit/types/test_attrs.py ________________
ImportError while importing test module '/builddir/build/BUILD/network-runner-0.2.2/tests/unit/types/test_attrs.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/unit/types/test_attrs.py:17: in <module>
    from network_runner.types import attrs
network_runner/types/attrs.py:24: in <module>
    from network_runner.types.containers import Map
network_runner/types/containers.py:21: in <module>
    from collections import MutableMapping, MutableSequence
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
_____________ ERROR collecting tests/unit/types/test_containers.py _____________
ImportError while importing test module '/builddir/build/BUILD/network-runner-0.2.2/tests/unit/types/test_containers.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/unit/types/test_containers.py:17: in <module>
    from network_runner.types.objects import Object
network_runner/types/objects.py:23: in <module>
    from network_runner.types.attrs import Attribute
network_runner/types/attrs.py:24: in <module>
    from network_runner.types.containers import Map
network_runner/types/containers.py:21: in <module>
    from collections import MutableMapping, MutableSequence
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
______________ ERROR collecting tests/unit/types/test_objects.py _______________
ImportError while importing test module '/builddir/build/BUILD/network-runner-0.2.2/tests/unit/types/test_objects.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/unit/types/test_objects.py:17: in <module>
    from network_runner.types.objects import Object
network_runner/types/objects.py:23: in <module>
    from network_runner.types.attrs import Attribute
network_runner/types/attrs.py:24: in <module>
    from network_runner.types.containers import Map
network_runner/types/containers.py:21: in <module>
    from collections import MutableMapping, MutableSequence
E   ImportError: cannot import name 'MutableMapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
=============================== warnings summary ===============================
../../../../usr/lib64/python3.10/distutils/__init__.py:16
  /usr/lib64/python3.10/distutils/__init__.py:16: DeprecationWarning: The distutils package deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
    warnings.warn("The distutils package deprecated and slated for "

-- Docs: https://docs.pytest.org/en/stable/warnings.html
=========================== short test summary info ============================
ERROR tests/unit/test_api.py
ERROR tests/unit/test_resources.py
ERROR tests/unit/types/test_attrs.py
ERROR tests/unit/types/test_containers.py
ERROR tests/unit/types/test_objects.py
!!!!!!!!!!!!!!!!!!! Interrupted: 5 errors during collection !!!!!!!!!!!!!!!!!!!!

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952331-python-network-runner/

For all our attempts to build python-network-runner with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-network-runner/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:07:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:13:22 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:58:11 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:29:19 UTC
*** Bug 1969045 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:24:53 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-06-16 23:57:13 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.