Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1927132 - python-language-server fails to build with Python 3.10: AssertionError
Summary: python-language-server fails to build with Python 3.10: AssertionError
Alias: None
Product: Fedora
Classification: Fedora
Component: python-language-server
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
: 1969015 (view as bug list)
Depends On: 1951475
Blocks: PYTHON3.10 F35FTBFS, RAWHIDEFTBFS 1969089 1969090
TreeView+ depends on / blocked
Reported: 2021-02-10 07:12 UTC by Tomáš Hrnčiar
Modified: 2021-07-03 01:27 UTC (History)
6 users (show)

Fixed In Version: python-language-server-0.36.2-5.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed:
Type: Bug

Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-10 07:12:35 UTC
python-language-server fails to build with Python 3.10.0a5.

=================================== FAILURES ===================================
__________________________ test_syntax_error_pyflakes __________________________

workspace = <pyls.workspace.Workspace object at 0x7ff628741640>

    def test_syntax_error_pyflakes(workspace):
        doc = Document(DOC_URI, workspace, DOC_SYNTAX_ERR)
        diag = pyflakes_lint.pyls_lint(doc)[0]
>       assert diag['message'] == 'invalid syntax'
E       assert "expected ':'" == 'invalid syntax'
E         - invalid syntax
E         + expected ':'

test/plugins/ AssertionError

For the build logs, see:

For all our attempts to build python-language-server with Python 3.10, see:

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Lumír Balhar 2021-02-22 08:16:45 UTC
Just a note that a few people weren't happy with the progress of the upstream development and created two new forks:


Comment 2 Mukundan Ragavan 2021-02-22 11:15:18 UTC

Looks like the new fork is going to be maintained by Spyder team. I will switch the fedora packages to the fork.

Comment 3 Mukundan Ragavan 2021-02-23 01:08:40 UTC
Does the new fork have fixes for pyls FTBFS?

Comment 4 Lumír Balhar 2021-02-23 07:10:24 UTC
So far, there is only a few commits bringing compatibility with the latest jedi. It also seems that the fork will use a different name. We might need to package the new packages and wait until all upstream projects switch. In the meantime, fixes from the new project should be applicable downstream for the old one as well.

Comment 5 Miro Hrončok 2021-06-04 20:14:58 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.

The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.


See also

If you have general questions about the rebuild, please use this mailing list thread:

Comment 6 Miro Hrončok 2021-06-07 22:59:29 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 7 Miro Hrončok 2021-06-08 11:26:46 UTC
*** Bug 1969015 has been marked as a duplicate of this bug. ***

Comment 8 Mukundan Ragavan 2021-06-08 13:07:45 UTC

Looks like the new upstream has a release v1.0.1

Good time to switch?

Comment 9 Mukundan Ragavan 2021-06-10 02:19:17 UTC
I need to hang on to this version until spyder is ported over.

PYLS_REQVER = '>=0.36.2;<1.0.0'

Comment 10 Lumír Balhar 2021-06-10 08:07:37 UTC
There is a PR for that upstream:

Comment 11 Lumír Balhar 2021-06-16 05:32:10 UTC
The PR in the Spyder project is merged. All we need now is a new release.

Comment 12 Mukundan Ragavan 2021-06-17 22:03:37 UTC
and package the new pyls. I will try to do that this weekend.

Comment 13 Zbigniew Jędrzejewski-Szmek 2021-06-18 13:39:45 UTC
Unfortunately this now blocks the compose of Scientific_KDE:
I'll build the package with the one failing test deselected. I'll leave the bug
open for the proper fix.

Comment 14 Miro Hrončok 2021-06-18 13:42:22 UTC
Please unblock F35FailsToInstall when you build to avoid automated closing.

Comment 15 Mukundan Ragavan 2021-07-03 01:27:22 UTC
On a related note, updating to spyder 5 is going to be a mess.

Problem: cannot install the best update candidate for package python3-spyder-4.2.5-1.fc34.noarch
  - nothing provides (python3.9dist(python-language-server[all]) < 1 with python3.9dist(python-language-server[all]) >= 0.36.2) needed by python3-spyder-5.0.5-1.fc34.noarch
  - nothing provides python3.9dist(parso) = 0.7 needed by python3-spyder-5.0.5-1.fc34.noarch
  - nothing provides python3.9dist(pyqt5) < 5.13 needed by python3-spyder-5.0.5-1.fc34.noarch
  - nothing provides python3.9dist(pyqtwebengine) < 5.13 needed by python3-spyder-5.0.5-1.fc34.noarch
  - nothing provides python3.9dist(qdarkstyle) = 3.0.2 needed by python3-spyder-5.0.5-1.fc34.noarch
  - nothing provides python3.9dist(rtree) >= 0.9.7 needed by python3-spyder-5.0.5-1.fc34.noarch
  - nothing provides python3.9dist(watchdog) >= 0.10.3 needed by python3-spyder-5.0.5-1.fc34.noarch


Note You need to log in before you can comment on or make changes to this bug.