Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1928542 - nouveau prevents system from starting gnome/xorg after boot
Summary: nouveau prevents system from starting gnome/xorg after boot
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-02-14 19:53 UTC by Geoffrey Marr
Modified: 2021-02-22 16:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-22 16:19:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
output of "lspci -vvnn" (deleted)
2021-02-14 19:53 UTC, Geoffrey Marr
no flags Details
output of "journalctl -b-1 -o short-monotonic -no-hostname" (deleted)
2021-02-14 19:54 UTC, Geoffrey Marr
no flags Details

Description Geoffrey Marr 2021-02-14 19:53:25 UTC
Created attachment 1756998 [details]
output of "lspci -vvnn"

Description of problem:
After recently installing and attempting to boot Fedora-Workstation-Live-x86_64-34-20210210.n.1.iso, the system would hang after "Started GNOME Display Manager" was displayed. After disabling nouveau at grub (modprobe.blacklist=nouveau), the system boots as expected. Also tried Fedora-Workstation-Live-x86_64-34-20210212.n.0.iso and several older versions of Fedora Workstation Rawhide (0124) and (0128) and they exhibit the same result. This is on a Lenovo P53 with dual Intel and NVIDIA graphics (see lspci output attached below)

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-34-20210210.n.1.iso
Fedora-Workstation-Live-x86_64-34-20210212.n.0.iso

How reproducible:
Every boot

Steps to Reproduce:
1. Install Fedora-Workstation-Live-x86_64-34-20210212.n.0.iso
2. Attempt to get to GNOME

Additional info:
See attached files for log and specific hardware output

Comment 1 Geoffrey Marr 2021-02-14 19:54:20 UTC
Created attachment 1756999 [details]
output of "journalctl -b-1 -o short-monotonic -no-hostname"

Comment 2 Fedora Blocker Bugs Application 2021-02-14 19:58:52 UTC
Proposed as a Blocker for 34-beta by Fedora user coremodule using the blocker tracking app because:

 Violates the Beta criterion:

"No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional."[0]

I am choosing this criterion as when the system is stuck trying to get into GNOME, accessing the virtual terminals still allows logging in and using the system, just not graphically.

[0] https://fedoraproject.org/wiki/Fedora_34_Beta_Release_Criteria#Desktop_panel

Comment 3 Chris Murphy 2021-02-14 20:33:39 UTC
lspci:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU117GLM [Quadro T1000 Mobile] [10de:1fb9] (rev a1) (prog-if 00 [VGA controller])
	Kernel modules: nouveau

kernel:
5.11.0-0.rc7.149.fc34.x86_64

journal shows problem first happens at:
[   13.872978] kernel: gnome-shell[1136]: segfault at 7f8944b4142a ip 00007f8944b4142a sp 00007ffcba885318 error 7 in nouveau_dri.so[7f89445e4000+dc3000]

Comment 4 Geoffrey Marr 2021-02-15 15:54:35 UTC
Installed Fedora kernel-5.10.16-200.fc33.x86_64 and the problem goes away.

Comment 5 Geoffrey Marr 2021-02-18 15:38:15 UTC
(In reply to Geoffrey Marr from comment #4)
> Installed Fedora kernel-5.10.16-200.fc33.x86_64 and the problem goes away.

Note that this was a kernel downgrade, as I installed an F33 kernel on F34.

Comment 6 Federico Bruni 2021-02-19 12:45:31 UTC
> kernel:
> 5.11.0-0.rc7.149.fc34.x86_64

There's a new kernel on fc34 repository: 5.11.0-156
You might want to upgrade and see if it solves your problem.

Comment 7 Geoffrey Marr 2021-02-22 16:19:25 UTC
(In reply to Federico Bruni from comment #6)
> > kernel:
> > 5.11.0-0.rc7.149.fc34.x86_64
> 
> There's a new kernel on fc34 repository: 5.11.0-156
> You might want to upgrade and see if it solves your problem.

Seems to work! Tested both by installing the 5.11.0-156 kernel on the existing installation and by installing Fedora-Workstation-Live-x86_64-34-20210222.n.0.iso. No longer hangs on boot, boots to system Wayland GUI.


Note You need to log in before you can comment on or make changes to this bug.