Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1931020 - [abrt] gedit: g_settings_schema_get_value(): gedit killed by SIGTRAP
Summary: [abrt] gedit: g_settings_schema_get_value(): gedit killed by SIGTRAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gedit
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:33101781477a4aedc6f78b003ef...
: 1931180 (view as bug list)
Depends On:
Blocks: F34BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-02-20 06:14 UTC by Chris Murphy
Modified: 2021-03-05 12:11 UTC (History)
11 users (show)

Fixed In Version: gedit-3.38.1-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-21 18:02:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: core_backtrace (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: cpuinfo (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: dso_list (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: environ (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: limits (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: maps (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: mountinfo (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: open_fds (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: proc_pid_status (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
File: var_log_messages (deleted)
2021-02-20 06:14 UTC, Chris Murphy
no flags Details
coredumpctl gdb, thread apply all bt full (deleted)
2021-02-20 06:38 UTC, Chris Murphy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gedit issues 408 0 None None None 2021-02-20 18:46:56 UTC

Description Chris Murphy 2021-02-20 06:14:10 UTC
Description of problem:
Click on the desktop icon in dash
Crash
100% reproducible

Version-Release number of selected component:
gedit-2:3.38.1-2.fc34

Additional info:
reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/dbus-:1.2-org.gnome.gedit
cmdline:        /usr/bin/gedit --gapplication-service
crash_function: g_settings_schema_get_value
executable:     /usr/bin/gedit
journald_cursor: s=493bc8f752994e269bbdb68d1e6fe5af;i=2ebc;b=ca96c1e7f3404f62ad01494c1fb4bc28;m=435fc530e;t=5bbbe5690a4da;x=4a3283699ff58da0
kernel:         5.11.0-156.fc34.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 1810955

Comment 1 Chris Murphy 2021-02-20 06:14:13 UTC
Created attachment 1758363 [details]
File: backtrace

Comment 2 Chris Murphy 2021-02-20 06:14:14 UTC
Created attachment 1758364 [details]
File: core_backtrace

Comment 3 Chris Murphy 2021-02-20 06:14:15 UTC
Created attachment 1758365 [details]
File: cpuinfo

Comment 4 Chris Murphy 2021-02-20 06:14:16 UTC
Created attachment 1758366 [details]
File: dso_list

Comment 5 Chris Murphy 2021-02-20 06:14:17 UTC
Created attachment 1758367 [details]
File: environ

Comment 6 Chris Murphy 2021-02-20 06:14:18 UTC
Created attachment 1758368 [details]
File: limits

Comment 7 Chris Murphy 2021-02-20 06:14:19 UTC
Created attachment 1758369 [details]
File: maps

Comment 8 Chris Murphy 2021-02-20 06:14:20 UTC
Created attachment 1758370 [details]
File: mountinfo

Comment 9 Chris Murphy 2021-02-20 06:14:21 UTC
Created attachment 1758371 [details]
File: open_fds

Comment 10 Chris Murphy 2021-02-20 06:14:22 UTC
Created attachment 1758372 [details]
File: proc_pid_status

Comment 11 Chris Murphy 2021-02-20 06:14:23 UTC
Created attachment 1758373 [details]
File: var_log_messages

Comment 12 Chris Murphy 2021-02-20 06:38:41 UTC
Created attachment 1758374 [details]
coredumpctl gdb, thread apply all bt full

Comment 13 Chris Murphy 2021-02-20 06:40:37 UTC
Happens with either

gtk3-3.24.25-2.fc34.x86_64
gtk4-4.1.0-2.fc34.x86_64

gtk3-3.24.25-3.fc34.x86_64
gtk4-4.1.0-3.fc34.x86_64

Comment 14 Fedora Blocker Bugs Application 2021-02-20 06:42:45 UTC
Proposed as a Blocker for 34-beta by Fedora user chrismurphy using the blocker tracking app because:

 No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional.

Comment 15 Chris Murphy 2021-02-20 21:59:24 UTC
I've tested gedit-3.38.1-3.fc34 on two systems and it fixes the the problem.

Comment 16 Adam Williamson 2021-02-21 18:02:34 UTC
That build is stable now, so we can close this.

Comment 17 David King 2021-03-05 12:11:21 UTC
*** Bug 1931180 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.