Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1935712 - FTBFS with PHP 8: ./redland-post.i:113:45: error: expected ')' before 'TSRMLS_CC'
Summary: FTBFS with PHP 8: ./redland-post.i:113:45: error: expected ')' before 'TSRMLS...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: redland-bindings
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1943062 (view as bug list)
Depends On: 1934995
Blocks: F35FTBFS 1973623
TreeView+ depends on / blocked
 
Reported: 2021-03-05 12:43 UTC by Remi Collet
Modified: 2021-06-18 11:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-17 00:03:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Remi Collet 2021-03-05 12:43:50 UTC
See https://fedoraproject.org/wiki/Changes/php80

Related to swig bug #1934995

Comment 1 Petr Pisar 2021-04-06 08:38:26 UTC
From a build log:

make[2]: Entering directory '/builddir/build/BUILD/redland-bindings-1.0.16.1/php'
swig -v -php7 -I. -DREDLAND_POST_I -DREDLAND_INIT_I -DREDLAND_DECL_I -DREDLAND_TYPEMAP_I -noproxy -module redland -o redland_wrap.c /usr/share/redland/Redland.i
Language subdirectory: php
Search paths:
   ./
   ./
   ./swig_lib/php/
   /usr/share/swig/4.0.2/php/
   ./swig_lib/
   /usr/share/swig/4.0.2/
Preprocessing...
Starting language-specific parse...
Processing unnamed structs...
Processing types...
C++ analysis...
Generating wrappers...
rm -f redland.php
gcc -DHAVE_CONFIG_H  -I. -DREDLAND_POST_I -DREDLAND_INIT_I -DREDLAND_DECL_I -DREDLAND_TYPEMAP_I -UHAVE_CONFIG_H   -I/usr/include/raptor2 -I/usr/include/rasqal  -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DREDLAND_BINDINGS_VERSION=\"1.0.16.1\"  -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -m64  -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection  -I/usr/include/raptor2 -I/usr/include/rasqal   -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -m64  -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fPIC -DPIC redland_wrap.c -c -o redland_wrap.o
In file included from redland_wrap.c:1104:
./redland-post.i: In function 'librdf_php_check_exception':
./redland-post.i:113:45: error: expected ')' before 'TSRMLS_CC'
  113 |                          librdf_php_log_code TSRMLS_CC);
      |                                             ^~~~~~~~~~
      |                                             )

Comment 2 Petr Pisar 2021-04-06 08:39:04 UTC
*** Bug 1943062 has been marked as a duplicate of this bug. ***

Comment 3 Remi Collet 2021-04-06 08:58:42 UTC
FYI TSRMLS_* macros, unneeded in PHP 7 have been removed in PHP 8.

Usually, trivial define works.

See: https://github.com/php/php-src/blob/PHP-7.4/TSRM/TSRM.h#L182

Comment 4 Fedora Admin user for bugzilla script actions 2021-05-05 00:30:16 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 5 Miro Hrončok 2021-06-17 00:03:54 UTC
Automation has figured out the package is retired in rawhide.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.